summaryrefslogtreecommitdiff
path: root/contrib/meson/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/meson/meson.build')
-rw-r--r--contrib/meson/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/contrib/meson/meson.build b/contrib/meson/meson.build
index 079c045a1174..98c9b0293007 100644
--- a/contrib/meson/meson.build
+++ b/contrib/meson/meson.build
@@ -18,6 +18,7 @@ libzstd_srcs = [
join_paths(common_dir, 'error_private.c'),
join_paths(common_dir, 'xxhash.c'),
join_paths(compress_dir, 'fse_compress.c'),
+ join_paths(compress_dir, 'hist.c'),
join_paths(compress_dir, 'huf_compress.c'),
join_paths(compress_dir, 'zstd_compress.c'),
join_paths(compress_dir, 'zstd_fast.c'),
@@ -130,6 +131,7 @@ test('fuzzer', fuzzer)
if target_machine.system() != 'windows'
paramgrill = executable('paramgrill',
datagen_c, join_paths(tests_dir, 'paramgrill.c'),
+ join_paths(programs_dir, 'bench.c'),
include_directories: test_includes,
link_with: libzstd,
dependencies: libm)