summaryrefslogtreecommitdiff
path: root/lib/Transforms/Utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Transforms/Utils/CMakeLists.txt')
-rw-r--r--lib/Transforms/Utils/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/lib/Transforms/Utils/CMakeLists.txt b/lib/Transforms/Utils/CMakeLists.txt
index 10cae5ca7087..f4394ea64d6e 100644
--- a/lib/Transforms/Utils/CMakeLists.txt
+++ b/lib/Transforms/Utils/CMakeLists.txt
@@ -6,11 +6,10 @@ add_llvm_library(LLVMTransformUtils
CloneFunction.cpp
CloneLoop.cpp
CloneModule.cpp
- CloneTrace.cpp
CodeExtractor.cpp
DemoteRegToStack.cpp
- InlineCost.cpp
InlineFunction.cpp
+ InstructionNamer.cpp
LCSSA.cpp
Local.cpp
LoopSimplify.cpp
@@ -19,12 +18,12 @@ add_llvm_library(LLVMTransformUtils
LowerSwitch.cpp
Mem2Reg.cpp
PromoteMemoryToRegister.cpp
- SimplifyCFG.cpp
+ SSAUpdater.cpp
SSI.cpp
+ SimplifyCFG.cpp
UnifyFunctionExitNodes.cpp
UnrollLoop.cpp
ValueMapper.cpp
- InstructionNamer.cpp
)
target_link_libraries (LLVMTransformUtils LLVMSupport)