summaryrefslogtreecommitdiff
path: root/tools/c-index-test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/c-index-test/CMakeLists.txt')
-rw-r--r--tools/c-index-test/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/c-index-test/CMakeLists.txt b/tools/c-index-test/CMakeLists.txt
index 6379194c55db..6f28c546cf37 100644
--- a/tools/c-index-test/CMakeLists.txt
+++ b/tools/c-index-test/CMakeLists.txt
@@ -7,6 +7,13 @@ add_clang_executable(c-index-test
c-index-test.c
)
+if(NOT MSVC)
+ set_property(
+ SOURCE c-index-test.c
+ PROPERTY COMPILE_FLAGS "-std=c89"
+ )
+endif()
+
target_link_libraries(c-index-test
libclang
)