aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorнаб <nabijaczleweli@nabijaczleweli.xyz>2021-05-26 23:31:43 +0000
committerBrian Behlendorf <behlendorf1@llnl.gov>2021-06-04 19:48:26 +0000
commit4a98300feb783684a3adfba4959f7d7d26a4bd79 (patch)
tree704c2a5e89b44a63debf8f3c82711209974aa824 /Makefile.am
parent783784582225e8ddfbf07993d9fc278bf08025c5 (diff)
downloadsrc-4a98300feb783684a3adfba4959f7d7d26a4bd79.tar.gz
src-4a98300feb783684a3adfba4959f7d7d26a4bd79.zip
mancheck: accept lints, accept lint overrides
Reviewed-by: Richard Laager <rlaager@wiktel.com> Reviewed-by: Brian Behlendorf <behlendorf1@llnl.gov> Reviewed-by: Tony Nguyen <tony.nguyen@delphix.com> Reviewed-by: Ryan Moeller <ryan@iXsystems.com> Signed-off-by: Ahelenia Ziemiańska <nabijaczleweli@nabijaczleweli.xyz> Closes #12129
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 1 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 8e4fffc5d793..4e7e29589fc0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -137,12 +137,7 @@ storeabi: lib
PHONY += mancheck
mancheck:
- @if type mandoc > /dev/null 2>&1; then \
- find ${top_srcdir}/man ${top_srcdir}/tests/test-runner/man -type f -name '*[1-9]*' \
- -exec mandoc -Tlint -Werror {} \+; \
- else \
- echo "skipping mancheck because mandoc is not installed"; \
- fi
+ ${top_srcdir}/scripts/mancheck.sh ${top_srcdir}/man ${top_srcdir}/tests/test-runner/man
if BUILD_LINUX
stat_fmt = -c '%A %n'