aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorнаб <nabijaczleweli@nabijaczleweli.xyz>2021-05-14 04:47:53 +0000
committerGitHub <noreply@github.com>2021-05-14 04:47:53 +0000
commit5236eafdcdf5e9e4e4d276f3c91391cdf5d97589 (patch)
tree8abe6ee518f53447c4c3a7da7e301ad088f50bd9 /Makefile.am
parentfce29d6aa4b4067cd5f0d6cd7481cce469dca3e8 (diff)
downloadsrc-5236eafdcdf5e9e4e4d276f3c91391cdf5d97589.tar.gz
src-5236eafdcdf5e9e4e4d276f3c91391cdf5d97589.zip
i-t: rewrite hooks
This produces a leaner image, doesn't fail if zdb doesn't exist, properly handles hostnameless systems, doesn't mention crypto modules for no reason, doesn't add useless empty executable in hopes an eight-year-old PR is merged, uses i-t builtins for all copies Also optimize the checkbashisms filter to spawn one (or a few) awks instead of one per regular file and remove initramfs/hooks therefrom due to a command -v false positive Reviewed-by: Brian Behlendorf <behlendorf1@llnl.gov> Signed-off-by: Ahelenia Ziemiańska <nabijaczleweli@nabijaczleweli.xyz> Closes #12017
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c44d64df0187..32ac50f78ae2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -159,9 +159,10 @@ checkbashisms:
-o -name 'paxcheck.sh' -prune \
-o -name 'make_gitrev.sh' -prune \
-o -name '90zfs' -prune \
+ -o -path '*initramfs/hooks' -prune \
-o -type f ! -name 'config*' \
! -name 'libtool' \
- -exec sh -c 'awk "NR==1 && /#!.*bin\/sh.*/ {print FILENAME;}" "{}"' \;); \
+ -exec awk 'FNR==1 && /^#!.*bin\/sh/ {print FILENAME}' {} \+); \
else \
echo "skipping checkbashisms because checkbashisms is not installed"; \
fi