aboutsummaryrefslogtreecommitdiff
path: root/pkgs/pseudo/kernel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/pseudo/kernel/Makefile')
-rw-r--r--pkgs/pseudo/kernel/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/pkgs/pseudo/kernel/Makefile b/pkgs/pseudo/kernel/Makefile
new file mode 100644
index 000000000000..b619eeb2af2c
--- /dev/null
+++ b/pkgs/pseudo/kernel/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+# Build the kernel ${KERNCONF}
+KERNCONF?= ${KERNEL:UGENERIC}
+
+TARGET?= ${MACHINE}
+# keep this compatible with peoples expectations...
+KERN_OBJDIR= ${OBJTOP}/sys/compile/${KERNCONF}
+KERN_CONFDIR= ${SRCTOP}/sys/${TARGET}/conf
+
+CONFIG= ${STAGE_HOST_OBJTOP}/usr/sbin/config
+
+${KERNCONF}.config: .MAKE .META
+ mkdir -p ${KERN_OBJDIR:H}
+ (cd ${KERN_CONFDIR} && \
+ ${CONFIG} ${CONFIGARGS} -d ${KERN_OBJDIR} ${KERNCONF})
+ (cd ${KERN_OBJDIR} && ${.MAKE} depend)
+ @touch $@
+
+# we need to pass curdirOk=yes to meta mode, since we want .meta files
+# in ${KERN_OBJDIR}
+${KERNCONF}.build: .MAKE ${KERNCONF}.config
+ (cd ${KERN_OBJDIR} && META_MODE="${.MAKE.MODE} curdirOk=yes" ${.MAKE})
+
+.if ${.MAKE.LEVEL} > 0
+all: ${KERNCONF}.build
+.endif
+
+UPDATE_DEPENDFILE= no
+
+.include <bsd.prog.mk>