aboutsummaryrefslogtreecommitdiff
path: root/tar/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tar/test/CMakeLists.txt')
-rw-r--r--tar/test/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/tar/test/CMakeLists.txt b/tar/test/CMakeLists.txt
index 98f49e29298b..9648e4892a3c 100644
--- a/tar/test/CMakeLists.txt
+++ b/tar/test/CMakeLists.txt
@@ -18,11 +18,13 @@ IF(ENABLE_TAR AND ENABLE_TEST)
test_extract_tar_gz.c
test_extract_tar_lrz.c
test_extract_tar_lz.c
+ test_extract_tar_lz4.c
test_extract_tar_lzma.c
test_extract_tar_lzo.c
test_extract_tar_xz.c
test_format_newc.c
test_help.c
+ test_leading_slash.c
test_option_C_upper.c
test_option_H_upper.c
test_option_L_upper.c
@@ -40,12 +42,14 @@ IF(ENABLE_TAR AND ENABLE_TEST)
test_option_k.c
test_option_keep_newer_files.c
test_option_lrzip.c
+ test_option_lz4.c
test_option_lzma.c
test_option_lzop.c
test_option_n.c
test_option_newer_than.c
test_option_nodump.c
test_option_older_than.c
+ test_option_passphrase.c
test_option_q.c
test_option_r.c
test_option_s.c
@@ -90,11 +94,12 @@ IF(ENABLE_TAR AND ENABLE_TEST)
INCLUDE(${CMAKE_CURRENT_BINARY_DIR}/list.h)
INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR})
- INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/test_utils)
+ INCLUDE_DIRECTORIES(${PROJECT_SOURCE_DIR}/test_utils)
# Experimental new test handling
ADD_CUSTOM_TARGET(run_bsdtar_test
- COMMAND bsdtar_test -p ${BSDTAR} -r ${CMAKE_CURRENT_SOURCE_DIR})
+ COMMAND bsdtar_test -p $<TARGET_FILE:bsdtar>
+ -r ${CMAKE_CURRENT_SOURCE_DIR})
ADD_DEPENDENCIES(run_bsdtar_test bsdtar)
ADD_DEPENDENCIES(run_all_tests run_bsdtar_test)