aboutsummaryrefslogtreecommitdiff
path: root/tools/driver/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/driver/CMakeLists.txt')
-rw-r--r--tools/driver/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/tools/driver/CMakeLists.txt b/tools/driver/CMakeLists.txt
index e592acadf17f..3f1ed40abe4d 100644
--- a/tools/driver/CMakeLists.txt
+++ b/tools/driver/CMakeLists.txt
@@ -33,12 +33,17 @@ add_clang_executable(clang
target_link_libraries(clang
clangBasic
+ clangCodeGen
clangDriver
clangFrontend
clangFrontendTool
)
-set_target_properties(clang PROPERTIES VERSION ${CLANG_EXECUTABLE_VERSION})
+if(WIN32 AND NOT CYGWIN)
+ # Prevent versioning if the buildhost is targeting for Win32.
+else()
+ set_target_properties(clang PROPERTIES VERSION ${CLANG_EXECUTABLE_VERSION})
+endif()
# Support plugins.
if(CLANG_PLUGIN_SUPPORT)