aboutsummaryrefslogtreecommitdiff
path: root/tools/llvm-cvtres/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/llvm-cvtres/CMakeLists.txt')
-rw-r--r--tools/llvm-cvtres/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tools/llvm-cvtres/CMakeLists.txt b/tools/llvm-cvtres/CMakeLists.txt
new file mode 100644
index 000000000000..52edccac8165
--- /dev/null
+++ b/tools/llvm-cvtres/CMakeLists.txt
@@ -0,0 +1,13 @@
+set(LLVM_LINK_COMPONENTS
+ Option
+ Support
+ )
+
+set(LLVM_TARGET_DEFINITIONS Opts.td)
+
+tablegen(LLVM Opts.inc -gen-opt-parser-defs)
+add_public_tablegen_target(CvtResTableGen)
+
+add_llvm_tool(llvm-cvtres
+ llvm-cvtres.cpp
+ )