aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2024-04-12 06:04:05 +0000
committerMathieu Arnold <mat@FreeBSD.org>2024-04-12 06:04:05 +0000
commit0660187ad07f36727fead6764740a225a31f342f (patch)
tree33b1e72c87dc7d4c93a723fc7a23f51d791785d7
parent38e3f7255c438a90466c0a54b352f472f4bbc001 (diff)
downloadports-0660187ad07f36727fead6764740a225a31f342f.tar.gz
ports-0660187ad07f36727fead6764740a225a31f342f.zip
cleanup: remove occurrences of WITH_DEBUG
DEBUG like all ports features, must not ever be set in a port, they are user facing features, that the user needs to enable in their environment/make.conf, either by defining WITH_DEBUG globally, or by setting WITH_DEBUG_PORTS with origin of ports they want DEBUG enabled in.
-rw-r--r--biology/salmon/Makefile1
-rw-r--r--biology/sra-tools/Makefile1
-rw-r--r--comms/limesuite/Makefile4
-rw-r--r--deskutils/qmediamanager/Makefile2
-rw-r--r--devel/alire/Makefile2
-rw-r--r--devel/asfml/Makefile1
-rw-r--r--emulators/virtualbox-ose/Makefile1
-rw-r--r--graphics/glaxnimate/Makefile2
-rw-r--r--mail/opendkim/Makefile4
-rw-r--r--multimedia/vlc/Makefile1
-rw-r--r--sysutils/npmount/Makefile2
11 files changed, 0 insertions, 21 deletions
diff --git a/biology/salmon/Makefile b/biology/salmon/Makefile
index 4e2767cda0de..f379e0c01934 100644
--- a/biology/salmon/Makefile
+++ b/biology/salmon/Makefile
@@ -40,7 +40,6 @@ CMAKE_ARGS+= -DHAVE_FAST_MALLOC:BOOL=on \
-DFETCHED_PUFFERFISH:BOOL=on \
-DFETCHED_LIBGFF:BOOL=on \
-DFETCH_STADEN:BOOL=true
-WITH_DEBUG= yes
LDFLAGS+= -lpthread
pre-configure:
diff --git a/biology/sra-tools/Makefile b/biology/sra-tools/Makefile
index 39dd02760918..2b9eb8e674cb 100644
--- a/biology/sra-tools/Makefile
+++ b/biology/sra-tools/Makefile
@@ -35,7 +35,6 @@ SHEBANG_GLOB= *.sh
GH_ACCOUNT= ncbi
GH_TUPLE+= ncbi:ncbi-vdb:${DISTVERSION}:vdb/ncbi-vdb
-WITH_DEBUG= yes
CMAKE_ARGS+= -DVDB_LIBDIR:STRING=${WRKSRC}/ncbi-vdb/build/lib
post-extract:
diff --git a/comms/limesuite/Makefile b/comms/limesuite/Makefile
index 706267c264ce..d894c45cf11a 100644
--- a/comms/limesuite/Makefile
+++ b/comms/limesuite/Makefile
@@ -87,10 +87,6 @@ PLIST_SUB+= OCTAVE_OCT_SITE_DIR=${OCTAVE_OCT_SITE_DIR:sh}/
PLIST_SUB+= OCTAVE_M_SITE_DIR=${OCTAVE_M_SITE_DIR:sh}/
.endif
-.if ${PORT_OPTIONS:MDEBUG}
-WITH_DEBUG= yes
-.endif
-
post-build:
# N.B. COPYTREE_BIN here chmods 555 which breaks CMAKE_INSTALL in user mode!
(cd ${BUILD_WRKSRC}/bin && ${COPYTREE_BIN} . ${STAGEDIR}${PREFIX}/bin)
diff --git a/deskutils/qmediamanager/Makefile b/deskutils/qmediamanager/Makefile
index 554f5c2db76d..51a35559239d 100644
--- a/deskutils/qmediamanager/Makefile
+++ b/deskutils/qmediamanager/Makefile
@@ -25,8 +25,6 @@ USE_GITHUB= yes
GH_ACCOUNT= outpaddling
-WITH_DEBUG= yes
-
PLIST_FILES= bin/qmediamanager share/man/man1/qmediamanager.1.gz
do-install:
diff --git a/devel/alire/Makefile b/devel/alire/Makefile
index 4ba7bebe4844..6f9df7e1ec24 100644
--- a/devel/alire/Makefile
+++ b/devel/alire/Makefile
@@ -32,8 +32,6 @@ DOCS_DESC= Install Design and Development documentation
.if empty(PORT_OPTIONS:MDEBUG)
_GPR_ARGS+= -XALIRE_BUILD_MODE=release
-.else
-WITH_DEBUG= yes
.endif
do-build:
diff --git a/devel/asfml/Makefile b/devel/asfml/Makefile
index 58066516a998..fbaf574a8818 100644
--- a/devel/asfml/Makefile
+++ b/devel/asfml/Makefile
@@ -44,7 +44,6 @@ _GPR_ARGS= -j${MAKE_JOBS_NUMBER} -p
.if ${PORT_OPTIONS:MDEBUG}
_GPR_ARGS+= -XASFML_BUILD_MODE=debug
-WITH_DEBUG= yes
.endif
post-extract:
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index cb64022d98c3..5db1512ec70a 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -146,7 +146,6 @@ CONFLICTS_INSTALL+= virtualbox-ose
.if ${PORT_OPTIONS:MDEBUG}
KMK_BUILDTYPE= debug
KMK_FLAGS+= BUILD_TYPE=debug
-WITH_DEBUG= yes
.else
KMK_BUILDTYPE= release
.endif
diff --git a/graphics/glaxnimate/Makefile b/graphics/glaxnimate/Makefile
index ec3c5e5ebf3f..c6311943b7d7 100644
--- a/graphics/glaxnimate/Makefile
+++ b/graphics/glaxnimate/Makefile
@@ -59,8 +59,6 @@ ALL_TARGET= all translations
OPTIONS_DEFINE= DEBUG
-DEBUG_VARS= WITH_DEBUG=yes
-
.include <bsd.port.options.mk>
.if !${PORT_OPTIONS:MDEBUG}
diff --git a/mail/opendkim/Makefile b/mail/opendkim/Makefile
index 8f581a63630e..1cacfe69cd79 100644
--- a/mail/opendkim/Makefile
+++ b/mail/opendkim/Makefile
@@ -103,10 +103,6 @@ MAKE_ENV= INSTALL_STRIP_FLAG=${STRIP}
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDEBUG}
-WITH_DEBUG= yes
-.endif
-
.if ${PORT_OPTIONS:MFILTER}
SUB_FILES= pkg-message
WITHOUT_MILTER_CFLAGS= yes
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 41fc56ab179c..2f96031d4d36 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -381,7 +381,6 @@ WITH_DVD_DEVICE?=/dev/cd0
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDEBUG}
-WITH_DEBUG=yes
CONFIGURE_ARGS+=--enable-debug --disable-optimizations
CFLAGS+=-g -O0
CXXFLAGS+=-g -O0
diff --git a/sysutils/npmount/Makefile b/sysutils/npmount/Makefile
index caecd187a145..522e719c7216 100644
--- a/sysutils/npmount/Makefile
+++ b/sysutils/npmount/Makefile
@@ -19,6 +19,4 @@ GH_ACCOUNT= outpaddling
MAKE_ENV= MANDIR=${PREFIX}/share/man
-WITH_DEBUG= yes
-
.include <bsd.port.mk>