aboutsummaryrefslogtreecommitdiff
path: root/archivers/unzip
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2008-04-03 21:43:38 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2008-04-03 21:43:38 +0000
commit1ea2728b26f388092381f5a8ce9eeeda35316a03 (patch)
treec840d1041f99177da1edc08042bd0d8ef17e1cb1 /archivers/unzip
parenta7d63a8e2b85afb9f49494304d0d6faaa6da0990 (diff)
downloadports-1ea2728b26f388092381f5a8ce9eeeda35316a03.tar.gz
ports-1ea2728b26f388092381f5a8ce9eeeda35316a03.zip
Honor CC
Reorganize LOCAL_UNZIP PR: 122389 Submitted by: Frank Fenor <frank@fenor.de> (CC part)
Notes
Notes: svn path=/head/; revision=210462
Diffstat (limited to 'archivers/unzip')
-rw-r--r--archivers/unzip/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/archivers/unzip/Makefile b/archivers/unzip/Makefile
index 5eb91103569c..536a58c1b563 100644
--- a/archivers/unzip/Makefile
+++ b/archivers/unzip/Makefile
@@ -7,7 +7,7 @@
PORTNAME= unzip
PORTVERSION= 5.52
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES?= archivers
MASTER_SITES= ftp://ftp.info-zip.org/pub/infozip/src/ ${MASTER_SITE_TEX_CTAN}
MASTER_SITE_SUBDIR= tools/zip/info-zip/src
@@ -18,19 +18,21 @@ COMMENT?= List, test and extract compressed files in a ZIP archive
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKEFILE= unix/Makefile
-MAKE_ENV= LOCAL_UNZIP="${CFLAGS} -DUSE_UNSHRINK"
PLIST_FILES= bin/unzip bin/funzip bin/unzipsfx bin/zipgrep bin/zipinfo
PORTDOCS= README WHERE
MAN1= funzip.1 unzip.1 unzipsfx.1 zipgrep.1 zipinfo.1
+
CFLAGS+= -D_FILE_OFFSET_BITS=64
+LOCAL_UNZIP= ${CFLAGS} -DACORN_FTYPE_NFS -DWILD_STOP_AT_DIR
.if defined(WITH_UNZIP_UNREDUCE)
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} unreduce_full.zip
EXTRACT_ONLY= ${PORTNAME}552.tar.gz
-MAKE_ENV= LOCAL_UNZIP="${CFLAGS} \
- -DUSE_SMITH_CODE -DACORN_FTYPE_NFS -DWILD_STOP_AT_DIR"
+LOCAL_UNZIP+= -DUSE_SMITH_CODE
.endif
+MAKE_ENV= CC="${CC}" LOCAL_UNZIP="${LOCAL_UNZIP}"
+
.ifdef USE_UNZIP
.error You have `USE_UNZIP' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif