aboutsummaryrefslogtreecommitdiff
path: root/astro/astrometry
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2021-05-12 15:09:20 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-05-12 15:17:26 +0000
commit73930aef4a58ba896326b417c66949177ed38aeb (patch)
tree4f5833aa897822a77f1fcd3416a0207f2f198ae7 /astro/astrometry
parent43f07d47286a9b0e8de1f69897ffb4fb2f8de744 (diff)
downloadports-73930aef4a58ba896326b417c66949177ed38aeb.tar.gz
ports-73930aef4a58ba896326b417c66949177ed38aeb.zip
astro/astrometry: Update to 0.85
Python dependent scripts and apps like 'solve-field' work again. Cause was missing dependency astro/py-astropy (pyfits). Changelog: https://github.com/dstndstn/astrometry.net/releases/tag/0.85 Reported by: Repology
Diffstat (limited to 'astro/astrometry')
-rw-r--r--astro/astrometry/Makefile32
-rw-r--r--astro/astrometry/distinfo6
-rw-r--r--astro/astrometry/files/os-features-config.h3
-rw-r--r--astro/astrometry/files/patch-blind_Makefile61
-rw-r--r--astro/astrometry/files/patch-plot_Makefile31
-rw-r--r--astro/astrometry/files/patch-sdss_Makefile6
-rw-r--r--astro/astrometry/pkg-plist37
7 files changed, 65 insertions, 111 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index 9f1f0114cbf8..30553487c42a 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -1,8 +1,7 @@
# Created by: Sébastien Santoro <dereckson@gmail.com>
PORTNAME= astrometry
-PORTVERSION= 0.80
-PORTREVISION= 2
+PORTVERSION= 0.85
CATEGORIES= astro
MASTER_SITES= http://astrometry.net/downloads/
DISTNAME= ${PORTNAME}.net-${PORTVERSION}
@@ -22,28 +21,37 @@ LIB_DEPENDS= libcairo.so:graphics/cairo \
libpng.so:graphics/png \
libnetpbm.so:graphics/netpbm \
libwcs.so:astro/wcslib
-RUN_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astropy>0:astro/py-astropy@${PY_FLAVOR} \
+ ${PYNUMPY}
USES= gmake jpeg localbase pkgconfig python shebangfix
-SHEBANG_FILES= bin/* blind/*.py sdss/*.py util/[!c]*.py
USE_LDCONFIG= yes
+SHEBANG_FILES= bin/* sdss/*.py solver/*.py util/[!c]*.py
-ALL_TARGET= all extra
MAKE_ARGS= NETPBM_INC="-I${LOCALBASE}/include/netpbm" \
NETPBM_LIB="-L${LOCALBASE}/lib -lnetpbm" \
SYSTEM_GSL=yes
MAKE_ENV= INSTALL_DIR=${STAGEDIR}${PREFIX} \
- DOC_INSTALL_DIR=${STAGEDIR}${PREFIX}/${PORTNAME}/doc \
- EXAMPLE_INSTALL_DIR=${STAGEDIR}${PREFIX}/${PORTNAME}/examples \
+ DOC_INSTALL_DIR=${STAGEDIR}${DOCSDIR} \
+ EXAMPLE_INSTALL_DIR=${STAGEDIR}${EXAMPLESDIR} \
MAN1_INSTALL_DIR=${STAGEDIR}${PREFIX}/man/man1 \
PYTHON=${PYTHON_CMD} PYTHON_SCRIPT=${PYTHON_CMD}
MAKE_JOBS_UNSAFE= yes
-# Changes search path in astrometry-engine
-DATA_INSTALL_DIR= ${STAGEDIR}${DATADIR}
+ALL_TARGET= all extra
+LDFLAGS+= -lz
+
# Need this to get gzipped man pages
MANDIRS= ${MANPREFIX}/man/man1
SUB_FILES= pkg-message
-LDFLAGS+= -lz
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFAULT= EXAMPLES
+
+# Changes search path in astrometry-engine
+DATA_INSTALL_DIR= ${STAGEDIR}${DATADIR}
# DATA_INSTALL_DIR does not work globally :(
post-install:
@@ -52,10 +60,10 @@ post-install:
${STAGEDIR}${PREFIX}/etc/${PORTNAME}.cfg
@${RMDIR} ${STAGEDIR}${PREFIX}/data
@${MKDIR} ${STAGEDIR}${DATADIR}/sdss
- @${MKDIR} ${STAGEDIR}${DATADIR}/blind
+ @${MKDIR} ${STAGEDIR}${DATADIR}/solver
@${MKDIR} ${STAGEDIR}${DATADIR}/catalogs
${INSTALL_DATA} ${WRKSRC}/sdss/testdata/*.fit* ${STAGEDIR}${DATADIR}/sdss
- ${INSTALL_DATA} ${WRKSRC}/blind/index-9918.fits ${STAGEDIR}${DATADIR}/blind
+ ${INSTALL_DATA} ${WRKSRC}/solver/index-9918.fits ${STAGEDIR}${DATADIR}/solver
${INSTALL_DATA} ${WRKSRC}/catalogs/*.fit* ${STAGEDIR}${DATADIR}/catalogs
.include <bsd.port.mk>
diff --git a/astro/astrometry/distinfo b/astro/astrometry/distinfo
index 9c1e759053c3..476b6bd73cad 100644
--- a/astro/astrometry/distinfo
+++ b/astro/astrometry/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1587972675
-SHA256 (astrometry.net-0.80.tar.gz) = 6eb73c2371df30324d6532955c46d5f324f2aad87f1af67c12f9354cfd4a7864
-SIZE (astrometry.net-0.80.tar.gz) = 11637496
+TIMESTAMP = 1618499902
+SHA256 (astrometry.net-0.85.tar.gz) = e5aa28cbd6c5dd2eaf6df68f95398c3cae190668d86e9922521d29689fc27221
+SIZE (astrometry.net-0.85.tar.gz) = 11633235
diff --git a/astro/astrometry/files/os-features-config.h b/astro/astrometry/files/os-features-config.h
index ad00021dd871..644a53d2ec55 100644
--- a/astro/astrometry/files/os-features-config.h
+++ b/astro/astrometry/files/os-features-config.h
@@ -1,5 +1,2 @@
#define NEED_CANONICALIZE_FILE_NAME 1
-#define NEED_DECLARE_QSORT_R 1
-#define NEED_QSORT_R 0
-#define NEED_SWAP_QSORT_R 0
#define HAVE_NETPBM 1
diff --git a/astro/astrometry/files/patch-blind_Makefile b/astro/astrometry/files/patch-blind_Makefile
deleted file mode 100644
index 74cf81babd94..000000000000
--- a/astro/astrometry/files/patch-blind_Makefile
+++ /dev/null
@@ -1,61 +0,0 @@
---- blind/Makefile.orig 2019-04-22 16:25:30 UTC
-+++ blind/Makefile
-@@ -223,11 +223,11 @@ PYTHON_EXECS := plotann.py
- PYTHON_INSTALL := $(PYTHON_EXECS) __init__.py
-
- install: $(INSTALL_EXECS) $(INSTALL_LIB)
-- @echo Installing in directory '$(INSTALL_DIR)'
-+ @echo Installing executables in directory '$(INSTALL_DIR)'
- $(MKDIR) '$(INSTALL_DIR)/bin'
- @for x in $(INSTALL_EXECS); do \
-- echo $(CP) $$x '$(INSTALL_DIR)/bin'; \
-- $(CP) $$x '$(INSTALL_DIR)/bin'; \
-+ echo $(BSD_INSTALL_PROGRAM) $$x '$(INSTALL_DIR)/bin'; \
-+ $(BSD_INSTALL_PROGRAM) $$x '$(INSTALL_DIR)/bin'; \
- done
- $(MKDIR) '$(ETC_INSTALL_DIR)'
- $(PYTHON) -c "import os; print(open('../etc/astrometry.cfg-dist').read().replace('DATA_INSTALL_DIR', '$(DATA_FINAL_DIR)'))" > '$(ETC_INSTALL_DIR)/astrometry.cfg'
-@@ -238,8 +238,8 @@ install: $(INSTALL_EXECS) $(INSTALL_LIB)
- done
- $(MKDIR) '$(LIB_INSTALL_DIR)'
- @for x in $(INSTALL_LIB); do \
-- echo $(CP) $$x '$(LIB_INSTALL_DIR)'; \
-- $(CP) $$x '$(LIB_INSTALL_DIR)'; \
-+ echo $(BSD_INSTALL_LIB) $$x '$(LIB_INSTALL_DIR)'; \
-+ $(BSD_INSTALL_LIB) $$x '$(LIB_INSTALL_DIR)'; \
- done
- $(MKDIR) '$(PY_INSTALL_DIR)'
- @for x in $(PYTHON_INSTALL); do \
-@@ -254,26 +254,27 @@ install: $(INSTALL_EXECS) $(INSTALL_LIB)
- done
-
-
--PYTHON_EXTRA_INSTALL := plotstuff.py plotstuff_c.py _plotstuff_c$(PYTHON_SO_EXT)
-+PYTHON_EXTRA_INSTALL := plotstuff.py plotstuff_c.py
-
- install-extra: $(INSTALL_CAIRO_EXECS)
-- @echo Installing in directory '$(INSTALL_DIR)'
-+ @echo Installing executables in directory '$(INSTALL_DIR)'
- $(MKDIR) '$(INSTALL_DIR)/bin'
- @for x in $(INSTALL_CAIRO_EXECS); do \
-- echo $(CP) $$x '$(INSTALL_DIR)/bin'; \
-- $(CP) $$x '$(INSTALL_DIR)/bin'; \
-+ echo $(BSD_INSTALL_PROGRAM) $$x '$(INSTALL_DIR)/bin'; \
-+ $(BSD_INSTALL_PROGRAM) $$x '$(INSTALL_DIR)/bin'; \
- done
- $(MKDIR) '$(INCLUDE_INSTALL_DIR)'
- @for x in $(PLOT_INSTALL_H); do \
- echo $(CP) '$(INCLUDE_DIR)/'$$x '$(INCLUDE_INSTALL_DIR)'; \
- $(CP) '$(INCLUDE_DIR)/'$$x '$(INCLUDE_INSTALL_DIR)'; \
- done
-- $(MAKE) $(PYTHON_EXTRA_INSTALL)
-+ $(MAKE) $(PYTHON_EXTRA_INSTALL) _plotstuff_c$(PYTHON_SO_EXT)
- $(MKDIR) '$(PY_INSTALL_DIR)'
- @for x in $(PYTHON_EXTRA_INSTALL); do \
- echo $(CP) $$x '$(PY_INSTALL_DIR)/'$$x; \
- $(CP) $$x '$(PY_INSTALL_DIR)/'$$x; \
- done
-+ $(BSD_INSTALL_LIB) _plotstuff_c$(PYTHON_SO_EXT) '$(PY_INSTALL_DIR)'
-
- test-solver: test-solver.o solver_test.o $(SLIB)
- test-solver-2: test-solver-2.o solver_test_2.o $(SLIB)
diff --git a/astro/astrometry/files/patch-plot_Makefile b/astro/astrometry/files/patch-plot_Makefile
new file mode 100644
index 000000000000..879b71c4bc0a
--- /dev/null
+++ b/astro/astrometry/files/patch-plot_Makefile
@@ -0,0 +1,31 @@
+--- plot/Makefile.orig 2020-07-16 20:26:35 UTC
++++ plot/Makefile
+@@ -119,23 +119,24 @@ install:
+ PYTHON_EXTRA_INSTALL := plotstuff.py plotstuff_c.py _plotstuff_c$(PYTHON_SO_EXT)
+
+ install-extra: $(INSTALL_CAIRO_EXECS)
+- @echo Installing in directory '$(INSTALL_DIR)'
++ @echo Installing executables in directory '$(INSTALL_DIR)'
+ $(MKDIR) '$(INSTALL_DIR)/bin'
+ @for x in $(INSTALL_CAIRO_EXECS); do \
+- echo $(CP) $$x '$(INSTALL_DIR)/bin'; \
+- $(CP) $$x '$(INSTALL_DIR)/bin'; \
++ echo $(BSD_INSTALL_PROGRAM) $$x '$(INSTALL_DIR)/bin'; \
++ $(BSD_INSTALL_PROGRAM) $$x '$(INSTALL_DIR)/bin'; \
+ done
+ $(MKDIR) '$(INCLUDE_INSTALL_DIR)'
+ @for x in $(PLOT_INSTALL_H); do \
+ echo $(CP) '$(INCLUDE_DIR)/'$$x '$(INCLUDE_INSTALL_DIR)'; \
+ $(CP) '$(INCLUDE_DIR)/'$$x '$(INCLUDE_INSTALL_DIR)'; \
+ done
+- $(MAKE) $(PYTHON_EXTRA_INSTALL)
++ $(MAKE) $(PYTHON_EXTRA_INSTALL) _plotstuff_c$(PYTHON_SO_EXT)
+ $(MKDIR) '$(PY_INSTALL_DIR)'
+ @for x in $(PYTHON_EXTRA_INSTALL); do \
+ echo $(CP) $$x '$(PY_INSTALL_DIR)/'$$x; \
+ $(CP) $$x '$(PY_INSTALL_DIR)/'$$x; \
+ done
++ $(BSD_INSTALL_LIB) _plotstuff_c$(PYTHON_SO_EXT) '$(PY_INSTALL_DIR)'
+
+ $(COMMON)/cairoutils.o:
+ $(MAKE) -C $(COMMON) cairoutils.o
diff --git a/astro/astrometry/files/patch-sdss_Makefile b/astro/astrometry/files/patch-sdss_Makefile
index 845ed7218512..d4c6b524fbab 100644
--- a/astro/astrometry/files/patch-sdss_Makefile
+++ b/astro/astrometry/files/patch-sdss_Makefile
@@ -1,11 +1,11 @@
---- sdss/Makefile.orig 2019-04-22 16:25:30 UTC
+--- sdss/Makefile.orig 2021-03-22 15:27:41 UTC
+++ sdss/Makefile
@@ -25,15 +25,15 @@ _cutils$(PYTHON_SO_EXT) cutils.py: cutils.i
INSTALL_PY := __init__.py common.py cutout.py dr7.py dr8.py runList-dr8.par \
dr9.py fields.py cutout.py runList-dr9.par dr10.py runList-dr10.par \
-- sdss_das.py sdss_name.py yanny.py
-+ sdss_das.py sdss_name.py yanny.py cutils.py
+- sdss_das.py sdss_name.py yanny.py casjobs.py
++ sdss_das.py sdss_name.py yanny.py casjobs.py cutils.py
-INSTALL_LIB := cutils.py _cutils$(PYTHON_SO_EXT)
+INSTALL_LIB := _cutils$(PYTHON_SO_EXT)
diff --git a/astro/astrometry/pkg-plist b/astro/astrometry/pkg-plist
index 16770fcb27a8..7b2e23ac583b 100644
--- a/astro/astrometry/pkg-plist
+++ b/astro/astrometry/pkg-plist
@@ -1,23 +1,3 @@
-astrometry/doc/CREDITS
-astrometry/doc/LICENSE
-astrometry/doc/README.md
-astrometry/doc/report.txt
-astrometry/examples/CREDITS
-astrometry/examples/apod1.jpg
-astrometry/examples/apod1.xyls
-astrometry/examples/apod2.jpg
-astrometry/examples/apod2.xyls
-astrometry/examples/apod3.jpg
-astrometry/examples/apod3.xyls
-astrometry/examples/apod4.jpg
-astrometry/examples/apod4.xyls
-astrometry/examples/apod5.jpg
-astrometry/examples/apod5.xyls
-astrometry/examples/m44-1910-04-01.jpg
-astrometry/examples/m44-1975-01-18.jpg
-astrometry/examples/sdss.jpg
-astrometry/examples/sdss.xyls
-astrometry/examples/tycho2-mag6.fits
bin/an-fitstopnm
bin/an-pnmtofits
bin/astrometry-engine
@@ -47,7 +27,6 @@ bin/modhead
bin/new-wcs
bin/pad-file
bin/plot-constellations
-bin/plotann.py
bin/plotquad
bin/plotxy
bin/query-starkd
@@ -89,8 +68,6 @@ include/astrometry/bl-sort.h
include/astrometry/bl.h
include/astrometry/bl.inc
include/astrometry/bl.ph
-include/astrometry/blind.h
-include/astrometry/blindutils.h
include/astrometry/brightstars.h
include/astrometry/bt.h
include/astrometry/build-index.h
@@ -139,6 +116,7 @@ include/astrometry/multiindex.h
include/astrometry/new-wcs.h
include/astrometry/nomad-fits.h
include/astrometry/nomad.h
+include/astrometry/onefield.h
include/astrometry/openngc.h
include/astrometry/os-features-config.h
include/astrometry/os-features.h
@@ -181,6 +159,7 @@ include/astrometry/sip.h
include/astrometry/sip_qfits.h
include/astrometry/solvedfile.h
include/astrometry/solver.h
+include/astrometry/solverutils.h
include/astrometry/starkd.h
include/astrometry/starutil.h
include/astrometry/starutil.inc
@@ -212,18 +191,17 @@ lib/libcatalogs.a
lib/libkd.a
lib/libqfits.a
lib/python/astrometry/__init__.py
-lib/python/astrometry/blind/__init__.py
-lib/python/astrometry/blind/_plotstuff_c%%PYTHON_EXT_SUFFIX%%.so
-lib/python/astrometry/blind/plotann.py
-lib/python/astrometry/blind/plotstuff.py
-lib/python/astrometry/blind/plotstuff_c.py
lib/python/astrometry/catalogs/__init__.py
lib/python/astrometry/libkd/__init__.py
lib/python/astrometry/libkd/spherematch.py
lib/python/astrometry/libkd/spherematch_c%%PYTHON_EXT_SUFFIX%%.so
lib/python/astrometry/net/client/client.py
+lib/python/astrometry/plot/_plotstuff_c%%PYTHON_EXT_SUFFIX%%.so
+lib/python/astrometry/plot/plotstuff.py
+lib/python/astrometry/plot/plotstuff_c.py
lib/python/astrometry/sdss/__init__.py
lib/python/astrometry/sdss/_cutils%%PYTHON_EXT_SUFFIX%%.so
+lib/python/astrometry/sdss/casjobs.py
lib/python/astrometry/sdss/common.py
lib/python/astrometry/sdss/cutils.py
lib/python/astrometry/sdss/cutout.py
@@ -238,6 +216,7 @@ lib/python/astrometry/sdss/runList-dr9.par
lib/python/astrometry/sdss/sdss_das.py
lib/python/astrometry/sdss/sdss_name.py
lib/python/astrometry/sdss/yanny.py
+lib/python/astrometry/solver/__init__.py
lib/python/astrometry/util/EXIF.py
lib/python/astrometry/util/__init__.py
lib/python/astrometry/util/_util%%PYTHON_EXT_SUFFIX%%.so
@@ -300,7 +279,6 @@ man/man1/wcs-resample.1.gz
man/man1/wcs-to-tan.1.gz
man/man1/wcs-xy2rd.1.gz
man/man1/wcsinfo.1.gz
-%%DATADIR%%/blind/index-9918.fits
%%DATADIR%%/catalogs/abell-all.fits
%%DATADIR%%/catalogs/brightstars.fits
%%DATADIR%%/catalogs/openngc-ic.fits
@@ -316,3 +294,4 @@ man/man1/wcsinfo.1.gz
%%DATADIR%%/sdss/psf1k0.fits
%%DATADIR%%/sdss/psf2k0.fits
%%DATADIR%%/sdss/tsField-002830-6-0398.fit
+%%DATADIR%%/solver/index-9918.fits