aboutsummaryrefslogtreecommitdiff
path: root/astro/qmapshack
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-11-23 16:25:09 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-11-23 16:25:09 +0000
commit97e8e6433db731ac39fb5355757ce5138dcfae6e (patch)
tree1797ce3d53a190cb11f04f98d05b8bceef535d89 /astro/qmapshack
parent2c7cadfd739604ad13d17fdbe756c2a6ec7afd05 (diff)
downloadports-97e8e6433db731ac39fb5355757ce5138dcfae6e.tar.gz
ports-97e8e6433db731ac39fb5355757ce5138dcfae6e.zip
astro/qmapshack: UNBREAK and Update version 1.13.0=>1.14.0
- Change MASTER_SITES to GITHUB - Update WWW in pkg-descr - Fix USES - Prevent a crash when not getting info on devices back from dbus (this happens when an nvme device (nvd*) is installed in the system, bsdisks doesn't handle these yet). (already reported upstream). PR: 241647 Submitted by: cmt MFH: 2019Q4 (runtime fix) Relnotes: https://github.com/Maproom/qmapshack/releases
Notes
Notes: svn path=/head/; revision=518253
Diffstat (limited to 'astro/qmapshack')
-rw-r--r--astro/qmapshack/Makefile13
-rw-r--r--astro/qmapshack/distinfo6
-rw-r--r--astro/qmapshack/files/patch-src_qmapshack_device_CDeviceWatcherLinux.cpp26
-rw-r--r--astro/qmapshack/pkg-descr6
4 files changed, 26 insertions, 25 deletions
diff --git a/astro/qmapshack/Makefile b/astro/qmapshack/Makefile
index 28f11323e803..40324b2f2579 100644
--- a/astro/qmapshack/Makefile
+++ b/astro/qmapshack/Makefile
@@ -2,16 +2,13 @@
# $FreeBSD$
PORTNAME= qmapshack
-PORTVERSION= 1.13.0
-PORTREVISION= 2
+PORTVERSION= 1.14.0
+DISTVERSIONPREFIX= V_
CATEGORIES= astro
-MASTER_SITES= https://bitbucket.org/maproom/qmapshack/downloads/
MAINTAINER= bofh@FreeBSD.org
COMMENT= Ultimate outdoor aficionado's tool
-BROKEN= unfetchable
-
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -21,9 +18,13 @@ LIB_DEPENDS= libgdal.so:graphics/gdal \
libroutino.so:astro/routino
RUN_DEPENDS= ${LOCALBASE}/bin/bsdisks:sysutils/bsdisks
-USES= cmake compiler:c++11-lib desktop-file-utils jpeg pkgconfig qt:5
+USES= cmake compiler:c++11-lib desktop-file-utils gl jpeg \
+ pkgconfig qt:5 xorg
USE_QT= buildtools core dbus declarative gui linguisttools location network \
printsupport qmake sql sql-sqlite3 uitools \
webchannel webengine widgets xml
+USE_GL= gl
+USE_GITHUB= yes
+GH_ACCOUNT= Maproom
.include <bsd.port.mk>
diff --git a/astro/qmapshack/distinfo b/astro/qmapshack/distinfo
index 2d4860559c56..a19c55fd84db 100644
--- a/astro/qmapshack/distinfo
+++ b/astro/qmapshack/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1554993320
-SHA256 (qmapshack-1.13.0.tar.gz) = 6a658f9188cd96ec53bd051cf475256b4bacc4a76a7043c5f478a38cc27161b3
-SIZE (qmapshack-1.13.0.tar.gz) = 12323773
+TIMESTAMP = 1574525969
+SHA256 (Maproom-qmapshack-V_1.14.0_GH0.tar.gz) = fd50f335b741087ab228ce4f8f45e386562eb128aea84298a1bdcfd299126576
+SIZE (Maproom-qmapshack-V_1.14.0_GH0.tar.gz) = 12541988
diff --git a/astro/qmapshack/files/patch-src_qmapshack_device_CDeviceWatcherLinux.cpp b/astro/qmapshack/files/patch-src_qmapshack_device_CDeviceWatcherLinux.cpp
index 31b3a856b073..83b6f7053f8b 100644
--- a/astro/qmapshack/files/patch-src_qmapshack_device_CDeviceWatcherLinux.cpp
+++ b/astro/qmapshack/files/patch-src_qmapshack_device_CDeviceWatcherLinux.cpp
@@ -1,13 +1,13 @@
---- src/qmapshack/device/CDeviceWatcherLinux.cpp.orig 2019-04-20 21:33:23.749597000 +0200
-+++ src/qmapshack/device/CDeviceWatcherLinux.cpp 2019-04-20 21:34:05.021101000 +0200
-@@ -174,7 +174,9 @@
- #if defined(Q_OS_FREEBSD)
- for(const QVariant &arg : reply.arguments())
- {
-- points.append(arg.value<QDBusVariant>().variant().value<QStringList>().first());
-+ if(!arg.value<QDBusVariant>().variant().value<QStringList>().isEmpty()) {
-+ points.append(arg.value<QDBusVariant>().variant().value<QStringList>().first());
-+ }
- }
- #else
- QList<QByteArray> list;
+--- src/qmapshack/device/CDeviceWatcherLinux.cpp.orig 2019-11-01 16:47:46 UTC
++++ src/qmapshack/device/CDeviceWatcherLinux.cpp
+@@ -58,6 +58,10 @@ void CDeviceWatcherLinux::slotDeviceAdded(const QDBusO
+ // create path of to drive the block device belongs to
+ QDBusInterface * blockIface = new QDBusInterface("org.freedesktop.UDisks2", path.path(), "org.freedesktop.UDisks2.Block", QDBusConnection::systemBus(), this);
+ QDBusObjectPath drive_object = blockIface->property("Drive").value<QDBusObjectPath>();
++ if(drive_object.path() == nullptr)
++ {
++ return;
++ }
+ QString idLabel = blockIface->property("IdLabel").toString().toUpper();
+
+ // read vendor string attached to drive
diff --git a/astro/qmapshack/pkg-descr b/astro/qmapshack/pkg-descr
index 602bf7a28e5b..21dac163985e 100644
--- a/astro/qmapshack/pkg-descr
+++ b/astro/qmapshack/pkg-descr
@@ -1,6 +1,6 @@
-Use QMapShack to plan your next outdoor trip or to visualize and archive all the
-GPS recordings of your past exciting adventures. QMapShack is the next
+Use QMapShack to plan your next outdoor trip or to visualize and archive all
+the GPS recordings of your past exciting adventures. QMapShack is the next
generation of the famous QLandkarte GT application. And of course it's even
better and easier to use.
-WWW: https://bitbucket.org/maproom/qmapshack
+WWW: https://github.com/Maproom/qmapshack/