aboutsummaryrefslogtreecommitdiff
path: root/audio/codec2
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2015-12-15 05:30:07 +0000
committerStephen Hurd <shurd@FreeBSD.org>2015-12-15 05:30:07 +0000
commit2ff7cdda580870e06f9949900072e7b832c759d3 (patch)
tree494cd704fd4cc8e79c27442636f00685161219a2 /audio/codec2
parent8509e9940c7ca4d8ab994323e87d7f48c200974f (diff)
downloadports-2ff7cdda580870e06f9949900072e7b832c759d3.tar.gz
ports-2ff7cdda580870e06f9949900072e7b832c759d3.zip
New port: audio/codec2
Codec2 is an open source low bit rate speech codec designed for communications quality speech at 2400 bit/s and below. Applications include low bandwidth HF/VHF digital radio and VOIP trunking. Codec 2 operating at 2400 bit/s can send 26 phone calls using the bandwidth required for one 64 kbit/s uncompressed phone call. It fills a gap in open source, free-as-in-speech voice codecs beneath 5000 bit/s and is released under the GNU Lesser General Public License (LGPL). WWW: http://www.rowetel.com/blog/?page_id=452
Notes
Notes: svn path=/head/; revision=403762
Diffstat (limited to 'audio/codec2')
-rw-r--r--audio/codec2/Makefile19
-rw-r--r--audio/codec2/distinfo2
-rw-r--r--audio/codec2/pkg-descr10
-rw-r--r--audio/codec2/pkg-plist28
4 files changed, 59 insertions, 0 deletions
diff --git a/audio/codec2/Makefile b/audio/codec2/Makefile
new file mode 100644
index 000000000000..a726365dc9c6
--- /dev/null
+++ b/audio/codec2/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= codec2
+PORTVERSION= 0.5
+CATEGORIES= audio hamradio
+MASTER_SITES= http://files.freedv.org/codec2/ \
+ LOCAL/shurd
+
+MAINTAINER= hamradio@FreeBSD.org
+COMMENT= Low bit rate codec
+
+LIB_DEPENDS= libspeex.so:${PORTSDIR}/audio/speex
+
+USES= cmake:outsource compiler:c11 tar:xz
+CMAKE_ARGS+= -DBUILD_SHARED_LIBS:BOOL=ON
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/audio/codec2/distinfo b/audio/codec2/distinfo
new file mode 100644
index 000000000000..7d9aa7d12330
--- /dev/null
+++ b/audio/codec2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (codec2-0.5.tar.xz) = 1ffda04ec6629f5ad5a38349c6d9d38d29bfbc1c677c12014ff20d480a343f17
+SIZE (codec2-0.5.tar.xz) = 7845164
diff --git a/audio/codec2/pkg-descr b/audio/codec2/pkg-descr
new file mode 100644
index 000000000000..55404b2b0219
--- /dev/null
+++ b/audio/codec2/pkg-descr
@@ -0,0 +1,10 @@
+Codec2 is an open source low bit rate speech codec designed for
+communications quality speech at 2400 bit/s and below. Applications
+include low bandwidth HF/VHF digital radio and VOIP trunking. Codec 2
+operating at 2400 bit/s can send 26 phone calls using the bandwidth
+required for one 64 kbit/s uncompressed phone call. It fills a gap in
+open source, free-as-in-speech voice codecs beneath 5000 bit/s and
+is released under the GNU Lesser General Public License (LGPL).
+
+
+WWW: http://www.rowetel.com/blog/?page_id=452
diff --git a/audio/codec2/pkg-plist b/audio/codec2/pkg-plist
new file mode 100644
index 000000000000..7e2650951c36
--- /dev/null
+++ b/audio/codec2/pkg-plist
@@ -0,0 +1,28 @@
+bin/c2dec
+bin/c2demo
+bin/c2enc
+bin/c2sim
+bin/fdmdv_demod
+bin/fdmdv_get_test_bits
+bin/fdmdv_interleave
+bin/fdmdv_mod
+bin/fdmdv_put_test_bits
+bin/fec_dec
+bin/fec_enc
+bin/fm_demod
+bin/insert_errors
+include/codec2/codec2.h
+include/codec2/codec2_cohpsk.h
+include/codec2/codec2_fdmdv.h
+include/codec2/codec2_fifo.h
+include/codec2/codec2_fm.h
+include/codec2/comp.h
+include/codec2/comp_prim.h
+include/codec2/freedv_api.h
+include/codec2/freedv_api_internal.h
+include/codec2/golay23.h
+include/codec2/kiss_fft.h
+include/codec2/modem_stats.h
+include/codec2/varicode.h
+lib/libcodec2.so
+lib/libcodec2.so.0.5