aboutsummaryrefslogtreecommitdiff
path: root/audio/codec2
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2020-08-25 23:27:40 +0000
committerDiane Bruce <db@FreeBSD.org>2020-08-25 23:27:40 +0000
commit9dcc41034f75bd980ca5fa4bf85009592e1db41c (patch)
tree970c817abbbb4d296c95d9277b66cdf129e43898 /audio/codec2
parentfa7428ce490d279ce7c2bce993cea034a8407b37 (diff)
downloadports-9dcc41034f75bd980ca5fa4bf85009592e1db41c.tar.gz
ports-9dcc41034f75bd980ca5fa4bf85009592e1db41c.zip
Thanks to Dima Panov <fluffy@FreeBSD.org> for pointing out it was
older compilers not clang 11 failing this. *sigh* PR: ports/248894 Submitted by: vvd@unislabs.com
Notes
Notes: svn path=/head/; revision=546241
Diffstat (limited to 'audio/codec2')
-rw-r--r--audio/codec2/Makefile2
-rw-r--r--audio/codec2/files/patch-src__freedv_api.c19
2 files changed, 15 insertions, 6 deletions
diff --git a/audio/codec2/Makefile b/audio/codec2/Makefile
index 904898e7c8b8..c844490eaad8 100644
--- a/audio/codec2/Makefile
+++ b/audio/codec2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= codec2
DISTVERSION= 0.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio hamradio
MASTER_SITES= https://hobbes1069.fedorapeople.org/freetel/codec2/
diff --git a/audio/codec2/files/patch-src__freedv_api.c b/audio/codec2/files/patch-src__freedv_api.c
index 9bff96fb0802..837ebd164f48 100644
--- a/audio/codec2/files/patch-src__freedv_api.c
+++ b/audio/codec2/files/patch-src__freedv_api.c
@@ -1,11 +1,20 @@
---- src/freedv_api.c.orig 2020-08-24 17:11:35 UTC
+--- src/freedv_api.c.orig 2018-05-29 05:59:17 UTC
+++ src/freedv_api.c
-@@ -76,6 +76,8 @@
+@@ -36,7 +36,7 @@
+ #ifdef __APPLE__
+ #include <malloc/malloc.h>
+ #else
+-#include <malloc.h>
++#include <stdlib.h>
+ #endif /* __APPLE__ */
- /* OFDM payload data test frame for 700D */
+ #include "fsk.h"
+@@ -75,6 +75,8 @@
+ #define NORM_PWR_OFDM 1.00
-+extern const struct OFDM_CONFIG * OFDM_CONFIG_700D;
+ /* OFDM payload data test frame for 700D */
+
++extern const struct OFDM_CONFIG * OFDM_CONFIG_700D;
+
extern int payload_data_bits[];
- /*---------------------------------------------------------------------------*\