aboutsummaryrefslogtreecommitdiff
path: root/biology/bowtie
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2018-11-03 23:16:49 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2018-11-03 23:16:49 +0000
commit8503d5208f833b51a8cbcddb5e1c5e35ee6a8064 (patch)
tree7bbd4dc04ac8f96a2b8a58967cecb0dcac6fec68 /biology/bowtie
parent020f86dfcc79dcec1be7e761e3b4cabd9f122003 (diff)
downloadports-8503d5208f833b51a8cbcddb5e1c5e35ee6a8064.tar.gz
ports-8503d5208f833b51a8cbcddb5e1c5e35ee6a8064.zip
biology/bowtie: Revert previous commit with missing log message
Notes
Notes: svn path=/head/; revision=483953
Diffstat (limited to 'biology/bowtie')
-rw-r--r--biology/bowtie/Makefile11
-rw-r--r--biology/bowtie/files/patch-ebwt.h11
2 files changed, 5 insertions, 17 deletions
diff --git a/biology/bowtie/Makefile b/biology/bowtie/Makefile
index 5b8aaedd3598..8d486190a122 100644
--- a/biology/bowtie/Makefile
+++ b/biology/bowtie/Makefile
@@ -1,9 +1,9 @@
# $FreeBSD$
PORTNAME= bowtie
+PORTVERSION= 1.1.2
+PORTREVISION= 6
DISTVERSIONPREFIX= v
-DISTVERSION= 1.1.2
-PORTREVISION= 7
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
@@ -13,14 +13,13 @@ LICENSE= ART10
# May also work on other 64-bit platforms, but untested
ONLY_FOR_ARCHS= amd64
-
-USES= gmake perl5 python:run shebangfix
# FIXME: bowtie-align intermittently dumps core when compiled with clang
# GCC 4.2 does not provide good performance
USE_GCC= yes
+USES= gmake perl5 python:run shebangfix
USE_PERL5= run
-
-SHEBANG_FILES= scripts/*.pl bowtie bowtie-build bowtie-inspect
+SHEBANG_FILES= scripts/*.pl bowtie bowtie-build \
+ bowtie-inspect
USE_GITHUB= yes
GH_ACCOUNT= BenLangmead
diff --git a/biology/bowtie/files/patch-ebwt.h b/biology/bowtie/files/patch-ebwt.h
deleted file mode 100644
index 4272bbd8303c..000000000000
--- a/biology/bowtie/files/patch-ebwt.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ebwt.h.orig 2018-11-03 20:51:56 UTC
-+++ ebwt.h
-@@ -860,7 +860,7 @@ public:
- TIndexOffU* ftab() const { return _ftab; }
- TIndexOffU* eftab() const { return _eftab; }
- TIndexOffU* offs() const { return _offs; }
-- uint32_t* isa() const { return _isa; } /* check */
-+ uint32_t* isa() const { return (uint32_t)_isa; } /* check */
- TIndexOffU* plen() const { return _plen; }
- TIndexOffU* rstarts() const { return _rstarts; }
- uint8_t* ebwt() const { return _ebwt; }