aboutsummaryrefslogtreecommitdiff
path: root/biology/stacks
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-01-11 17:27:30 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-01-11 17:27:30 +0000
commitbced63b1b352dff0bdfaab9926ceb2d942396587 (patch)
tree60ba7ab8fa7420bb68ae2eecf0638cfa2b006a4f /biology/stacks
parentef665861634bf69e5cc2f940ce83a278cefbadc1 (diff)
downloadports-bced63b1b352dff0bdfaab9926ceb2d942396587.tar.gz
ports-bced63b1b352dff0bdfaab9926ceb2d942396587.zip
biology/stacks: Drop dependency on gcc
Replace compiler:openmp with compiler:c++11-lang and localbase Set USE_GCC for i386 to work around limitations in clang atomic (PR 230888) PR: port/247753, ports/252379
Notes
Notes: svn path=/head/; revision=561234
Diffstat (limited to 'biology/stacks')
-rw-r--r--biology/stacks/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/biology/stacks/Makefile b/biology/stacks/Makefile
index 9bbb1c171b55..4ce7729e121f 100644
--- a/biology/stacks/Makefile
+++ b/biology/stacks/Makefile
@@ -2,7 +2,7 @@
PORTNAME= stacks
DISTVERSION= 2.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= biology perl5 python
MASTER_SITES= http://catchenlab.life.illinois.edu/stacks/source/
@@ -12,7 +12,7 @@ COMMENT= Software pipeline for building loci from short-read sequences
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= compiler:openmp gmake python shebangfix
+USES= compiler:c++11-lang gmake python shebangfix
SHEBANG_FILES= scripts/*.pl scripts/*.py \
scripts/stacks-integrate-alignments scripts/stacks-gdb
@@ -22,8 +22,8 @@ LDFLAGS+= -lpthread
.include <bsd.port.pre.mk>
-# Force newer GCC on platforms using GCC 4.2 as base
-.if ${CHOSEN_COMPILER_TYPE} == gcc
+# Temp workaround, see PR 230888
+.if ${ARCH} == i386
USE_GCC= yes
.endif