aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-07 07:20:57 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-07 07:25:09 +0000
commit7be12eb0e21cff50ef862997d6420baf408ffa28 (patch)
tree8886b81f3846c4fa4aeddee1a61abef481151279 /biology
parent8932e251e160047041455cba6c1d22cd591b6d27 (diff)
downloadports-7be12eb0e21cff50ef862997d6420baf408ffa28.tar.gz
ports-7be12eb0e21cff50ef862997d6420baf408ffa28.zip
biology/abyss: Fix build with llvm15
Approved by: portmgr (blanket)
Diffstat (limited to 'biology')
-rw-r--r--biology/abyss/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/biology/abyss/Makefile b/biology/abyss/Makefile
index 8436eab2b31d..d023c7d5b8b6 100644
--- a/biology/abyss/Makefile
+++ b/biology/abyss/Makefile
@@ -42,4 +42,10 @@ PORTDOCS= *
PORTSCOUT= limit:^[0-9\.]*$$ # to ignore alpha-numeric tags
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=unused-but-set-variable
+.endif
+
+.include <bsd.port.post.mk>