aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2024-03-17 14:39:52 +0000
committerThierry Thomas <thierry@FreeBSD.org>2024-03-21 18:01:18 +0000
commit7632031eb3a9c542cdab66527b459790004cdf91 (patch)
tree7b6177a2cbd225a5cfedd535d7670dd23fd4e058 /cad
parentea54e4010f3762d05c4bb08fbd0936be88ae417c (diff)
downloadports-7632031eb3a9c542cdab66527b459790004cdf91.tar.gz
ports-7632031eb3a9c542cdab66527b459790004cdf91.zip
cad/kicad-devel: support of OpenCascade 7.8.0
Patch from OpenBSD by Johannes Thyssen Tishman. PR: 277311 Approved by: maintainer’s time-out
Diffstat (limited to 'cad')
-rw-r--r--cad/kicad-devel/Makefile2
-rw-r--r--cad/kicad-devel/files/patch-cmake_FindOCC.cmake35
-rw-r--r--cad/kicad-devel/files/patch-include-kiway.h4
-rw-r--r--cad/kicad-devel/files/patch-pcbnew_import__gfx_dxf__import__plugin.cpp (renamed from cad/kicad-devel/files/patch-pcbnew_import_gfx_dxf_import_plugin.cpp)20
-rw-r--r--cad/kicad-devel/files/patch-thirdparty_glew_CMakeLists.txt6
-rw-r--r--cad/kicad-devel/files/patch-thirdparty_nanodbc_CMakeLists.txt11
6 files changed, 57 insertions, 21 deletions
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index 625b03f8efc9..2950c10a75d4 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kicad
DISTVERSION= r${GIT_SRC_DATE}
-PORTREVISION= 7
+PORTREVISION= 8
#PORTREVISION= 1
CATEGORIES= cad
PKGNAMESUFFIX= -devel
diff --git a/cad/kicad-devel/files/patch-cmake_FindOCC.cmake b/cad/kicad-devel/files/patch-cmake_FindOCC.cmake
new file mode 100644
index 000000000000..b3eb1132e754
--- /dev/null
+++ b/cad/kicad-devel/files/patch-cmake_FindOCC.cmake
@@ -0,0 +1,35 @@
+--- cmake/FindOCC.cmake.orig 2023-06-22 13:35:48 UTC
++++ cmake/FindOCC.cmake
+@@ -45,7 +45,7 @@ set( OCC_LIBS
+ TKGeomAlgo
+ TKGeomBase
+ TKHLR
+- TKIGES
++ TKDEIGES
+ TKLCAF
+ TKMath
+ TKMesh
+@@ -55,18 +55,15 @@ set( OCC_LIBS
+ TKPrim
+ TKService
+ TKShHealing
+- TKSTEP209
+- TKSTEPAttr
+- TKSTEPBase
+- TKSTEP
+- TKSTL
++ TKDESTEP
++ TKDESTL
+ TKTObj
+ TKTopAlgo
+ TKV3d
+- TKVRML
++ TKDEVRML
+ TKXCAF
+- TKXDEIGES
+- TKXDESTEP
++ TKXSDRAWIGES
++ TKXSDRAWSTEP
+ TKXMesh
+ TKXmlL
+ TKXml
diff --git a/cad/kicad-devel/files/patch-include-kiway.h b/cad/kicad-devel/files/patch-include-kiway.h
index dda125f679c6..9244e58c8eea 100644
--- a/cad/kicad-devel/files/patch-include-kiway.h
+++ b/cad/kicad-devel/files/patch-include-kiway.h
@@ -1,6 +1,6 @@
---- include/kiway.h.orig 2021-12-11 08:54:03 UTC
+--- include/kiway.h.orig 2023-06-22 13:35:48 UTC
+++ include/kiway.h
-@@ -114,7 +114,7 @@
+@@ -115,7 +115,7 @@
#define KIFACE_INSTANCE_NAME_AND_VERSION "KIFACE_1"
#ifndef SWIG
diff --git a/cad/kicad-devel/files/patch-pcbnew_import_gfx_dxf_import_plugin.cpp b/cad/kicad-devel/files/patch-pcbnew_import__gfx_dxf__import__plugin.cpp
index 12625f24511b..2eeba09414c4 100644
--- a/cad/kicad-devel/files/patch-pcbnew_import_gfx_dxf_import_plugin.cpp
+++ b/cad/kicad-devel/files/patch-pcbnew_import__gfx_dxf__import__plugin.cpp
@@ -1,27 +1,34 @@
---- pcbnew/import_gfx/dxf_import_plugin.cpp.orig 2023-01-08 16:40:34.270267000 +0100
-+++ pcbnew/import_gfx/dxf_import_plugin.cpp 2023-01-08 16:40:37.228586000 +0100
-@@ -581,5 +581,5 @@
+--- pcbnew/import_gfx/dxf_import_plugin.cpp.orig 2023-06-22 13:35:48 UTC
++++ pcbnew/import_gfx/dxf_import_plugin.cpp
+@@ -580,7 +580,7 @@ void DXF_IMPORT_PLUGIN::addEllipse( const DL_EllipseDa
+ // For now, we assume ellipses in the XY plane.
VECTOR2D center( mapX( centerCoords.x ), mapY( centerCoords.y ) );
- VECTOR2D major( mapX( majorCoords.x ), mapY( majorCoords.y ) );
+ VECTOR2D _major( mapX( majorCoords.x ), mapY( majorCoords.y ) );
// DXF elliptical arcs store their angles in radians (unlike circular arcs which use degrees)
-@@ -599,5 +599,5 @@
+ // The arcs wind CCW as in KiCad. The end angle must be greater than the start angle, and if
+@@ -598,7 +598,7 @@ void DXF_IMPORT_PLUGIN::addEllipse( const DL_EllipseDa
+
if( aData.ratio == 1.0 )
{
- double radius = major.EuclideanNorm();
+ double radius = _major.EuclideanNorm();
if( startAngle == endAngle )
-@@ -617,5 +617,5 @@
+ {
+@@ -616,7 +616,7 @@ void DXF_IMPORT_PLUGIN::addEllipse( const DL_EllipseDa
+ }
std::vector<BEZIER<double>> splines;
- ELLIPSE<double> ellipse( center, major, aData.ratio, startAngle, endAngle );
+ ELLIPSE<double> ellipse( center, _major, aData.ratio, startAngle, endAngle );
TransformEllipseToBeziers( ellipse, splines );
-@@ -631,6 +631,6 @@
+
+@@ -630,8 +630,8 @@ void DXF_IMPORT_PLUGIN::addEllipse( const DL_EllipseDa
+ bufferToUse->AddSpline( b.Start, b.C1, b.C2, b.End, lineWidth );
// Naive bounding
- updateImageLimits( center + major );
@@ -30,3 +37,4 @@
+ updateImageLimits( center - _major );
}
+
diff --git a/cad/kicad-devel/files/patch-thirdparty_glew_CMakeLists.txt b/cad/kicad-devel/files/patch-thirdparty_glew_CMakeLists.txt
index 18c5a496dd6c..d56f7dd4d070 100644
--- a/cad/kicad-devel/files/patch-thirdparty_glew_CMakeLists.txt
+++ b/cad/kicad-devel/files/patch-thirdparty_glew_CMakeLists.txt
@@ -1,10 +1,10 @@
---- thirdparty/glew/CMakeLists.txt.orig 2022-05-07 15:44:23 +0200
+--- thirdparty/glew/CMakeLists.txt.orig 2023-06-22 13:35:48 UTC
+++ thirdparty/glew/CMakeLists.txt
-@@ -5,6 +5,7 @@
+@@ -5,6 +5,7 @@ target_include_directories( glew PRIVATE "${CMAKE_CURR
# The actual include directories will be added to the global include paths as
# system headers
target_include_directories( glew PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}/include" )
+target_include_directories( glew SYSTEM PRIVATE "${CMAKE_INSTALL_PREFIX}/include" )
# Definitions for compiling GLEW staticly for EGL (extracted from the main GLEW CMakeLists.txt file)
- add_definitions( -DGLEW_STATIC )
+ add_compile_definitions( GLEW_STATIC )
diff --git a/cad/kicad-devel/files/patch-thirdparty_nanodbc_CMakeLists.txt b/cad/kicad-devel/files/patch-thirdparty_nanodbc_CMakeLists.txt
index a4b434935ab1..79157d85e791 100644
--- a/cad/kicad-devel/files/patch-thirdparty_nanodbc_CMakeLists.txt
+++ b/cad/kicad-devel/files/patch-thirdparty_nanodbc_CMakeLists.txt
@@ -1,6 +1,6 @@
---- thirdparty/nanodbc/CMakeLists.txt.orig 2022-09-14 12:06:32 UTC
+--- thirdparty/nanodbc/CMakeLists.txt.orig 2023-06-22 13:35:48 UTC
+++ thirdparty/nanodbc/CMakeLists.txt
-@@ -165,16 +165,11 @@ elseif(MINGW)
+@@ -155,16 +155,11 @@ endif()
endif()
########################################
@@ -21,10 +21,3 @@
########################################
## library target
-@@ -202,4 +197,4 @@ endif()
- if(NANODBC_ENABLE_UNICODE)
- add_compile_definitions(NANODBC_ENABLE_UNICODE)
- target_compile_definitions(nanodbc PUBLIC NANODBC_ENABLE_UNICODE)
--endif()
-\ No newline at end of file
-+endif()