aboutsummaryrefslogtreecommitdiff
path: root/chinese/autoconvert
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-15 03:06:04 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-15 03:06:04 +0000
commit85beac225a0948d47dff8d50ec61b77164590e68 (patch)
tree433f2a2c9a3c750068e6b25ec2c596ae7ad8794f /chinese/autoconvert
parent8703788e33c29c33f1caafd54cbd735106aa10dc (diff)
downloadports-85beac225a0948d47dff8d50ec61b77164590e68.tar.gz
ports-85beac225a0948d47dff8d50ec61b77164590e68.zip
utilize USE_GETOPT_LONG and DATADIR
Approved by: maintainer
Notes
Notes: svn path=/head/; revision=81006
Diffstat (limited to 'chinese/autoconvert')
-rw-r--r--chinese/autoconvert/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/chinese/autoconvert/Makefile b/chinese/autoconvert/Makefile
index b3c60dae616d..01f4c8747d58 100644
--- a/chinese/autoconvert/Makefile
+++ b/chinese/autoconvert/Makefile
@@ -13,14 +13,14 @@ MASTER_SITES= http://people.debian.org/~ygh/
MAINTAINER= yinjieh@csie.nctu.edu.tw
COMMENT= Intelligent Chinese encoding converter
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-
+USE_GETOPT_LONG= yes
INSTALLS_SHLIB= yes
+DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX}-${PORTNAME}
pre-install:
- @${MKDIR} ${PREFIX}/share/zh-autoconvert
+ @${MKDIR} ${DATADIR}
.for i in ChangeLog LICENSE Readme TODO Thanks Version hz.txt procmailrc.example shed.big5 shed.gb shed.uni shed.utf7 shed.utf8
- @${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/zh-autoconvert
+ @${INSTALL_DATA} ${WRKSRC}/$i ${DATADIR}
.endfor
.include <bsd.port.mk>