aboutsummaryrefslogtreecommitdiff
path: root/chinese/libime
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-25 13:49:15 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-25 18:09:48 +0000
commit627d9b8a64cd6ad3beb69fc4b5a0e63e06a58ebe (patch)
tree9cf72edfc123acd77c66facafafc6e36282e3ceb /chinese/libime
parentde6240d6a1f7460da9b3ff0743aba1680eaf5a05 (diff)
downloadports-627d9b8a64cd6ad3beb69fc4b5a0e63e06a58ebe.tar.gz
ports-627d9b8a64cd6ad3beb69fc4b5a0e63e06a58ebe.zip
chinese/libime: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'chinese/libime')
-rw-r--r--chinese/libime/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/chinese/libime/Makefile b/chinese/libime/Makefile
index 64c4ccce69cf..7ac105beb7da 100644
--- a/chinese/libime/Makefile
+++ b/chinese/libime/Makefile
@@ -36,6 +36,17 @@ OPENGRAM_LM_TAR= lm_sc.arpa-20220810.tar.xz
OPENGRAM_DICT_TAR= dict-20220810.tar.xz
TABLE_DICT_TAR= table.tar.gz
+.include <bsd.port.options.mk>
+
+post-patch:
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+ @${REINPLACE_CMD} -e 's|std::binary_function|std::__binary_function|' \
+ ${WRKSRC}/src/libime/core/kenlm/lm/trie_sort.hh \
+ ${WRKSRC}/src/libime/core/kenlm/util/joint_sort.hh \
+ ${WRKSRC}/src/libime/core/kenlm/util/sized_iterator.hh
+.endif
+
+
post-extract:
${CP} ${DISTDIR}/${DIST_SUBDIR}/${OPENGRAM_LM_TAR} ${WRKSRC}/data
${CP} ${DISTDIR}/${DIST_SUBDIR}/${OPENGRAM_DICT_TAR} ${WRKSRC}/data