aboutsummaryrefslogtreecommitdiff
path: root/chinese/libime
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 00:44:22 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 00:48:20 +0000
commit95274bf4f99c71fc056013d966aec239161dfd74 (patch)
treebc1e95977678cb5b6b00b33e333b28161885e706 /chinese/libime
parentdbe06d2da8c38d9d058f7939a7c6af36a2c0f1c7 (diff)
downloadports-95274bf4f99c71fc056013d966aec239161dfd74.tar.gz
ports-95274bf4f99c71fc056013d966aec239161dfd74.zip
*/*: Fix build with llvm16 on 13.2-STABLE
As like as HEAD(14.0-RELEASE) llvm16 was merged in base for 13.2-STABLE with the OSVERSION 1302507. - Utilize USE_CXXSTD=c++14 or similar solution where applicable - Update conditionals to addtionally check for OSVERSION greater than 1302507 and less than 1400000 Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'chinese/libime')
-rw-r--r--chinese/libime/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/chinese/libime/Makefile b/chinese/libime/Makefile
index 7ac105beb7da..7d3abe79c1bf 100644
--- a/chinese/libime/Makefile
+++ b/chinese/libime/Makefile
@@ -36,10 +36,10 @@ OPENGRAM_LM_TAR= lm_sc.arpa-20220810.tar.xz
OPENGRAM_DICT_TAR= dict-20220810.tar.xz
TABLE_DICT_TAR= table.tar.gz
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
post-patch:
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
@${REINPLACE_CMD} -e 's|std::binary_function|std::__binary_function|' \
${WRKSRC}/src/libime/core/kenlm/lm/trie_sort.hh \
${WRKSRC}/src/libime/core/kenlm/util/joint_sort.hh \
@@ -52,4 +52,4 @@ post-extract:
${CP} ${DISTDIR}/${DIST_SUBDIR}/${OPENGRAM_DICT_TAR} ${WRKSRC}/data
${CP} ${DISTDIR}/${DIST_SUBDIR}/${TABLE_DICT_TAR} ${WRKSRC}/data
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>