aboutsummaryrefslogtreecommitdiff
path: root/databases/ruby-bdb
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-01-14 23:05:28 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-01-14 23:08:33 +0000
commit18c6e18276691edf5274406bf82a3b06792ff9ae (patch)
tree23a66e6997d92422bec9960a22edc07e5386d547 /databases/ruby-bdb
parent74d55245570c3645f49debe0db6ba89a30034bcd (diff)
downloadports-18c6e18276691edf5274406bf82a3b06792ff9ae.tar.gz
ports-18c6e18276691edf5274406bf82a3b06792ff9ae.zip
Mk/**ruby.mk: Switch from USE_RUBY=yes to USES=ruby
Switch from Mk/bsd.ruby.mk to Mk/Uses/ruby.mk Notable changes are. - Mk/bsd.ruby.mk is moved to Mk/Uses/ruby.mk. - USE_RUBY=yes is replaced with USES=ruby. - USE_RUBY_EXTCONF is replaced with USES=ruby:extconf. - USE_RUBY_RDOC is replaced with USES=ruby:rdoc. - USE_RUBY_SETUP is replaces with USES=ruby:setup. - RUBY_NO_BUILD_DEPENDS and RUBY_NO_RUN_DEPENDS are replaced with USES=ruby:{build,none,run}. - RUBY_REQUIRE isn't used anywhere, so removed. - USES=gem now implies USES=ruby. This is mainly the work of yasu@ at https://reviews.freebsd.org/D27863 I have just made some cosmetic changes and ran exp-run to test that the tree is not in a BROKEN state. Approved by: portmgr Differential Revision: https://reviews.freebsd.org/D37925
Diffstat (limited to 'databases/ruby-bdb')
-rw-r--r--databases/ruby-bdb/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/databases/ruby-bdb/Makefile b/databases/ruby-bdb/Makefile
index b4b1f20ec0f3..8873e3eee0f0 100644
--- a/databases/ruby-bdb/Makefile
+++ b/databases/ruby-bdb/Makefile
@@ -18,9 +18,7 @@ BROKEN_RUBY32= yes
BUILD_DEPENDS= rubygem-rdoc>=0.a:devel/rubygem-rdoc
-USES= bdb shebangfix tar:bzip2
-USE_RUBY= yes
-USE_RUBY_EXTCONF= yes
+USES= bdb ruby:extconf shebangfix tar:bzip2
SHEBANG_FILES= examples/basic.rb examples/cats.rb examples/cursor.rb \
examples/func.rb examples/join.rb examples/lock.rb \