aboutsummaryrefslogtreecommitdiff
path: root/databases/ruby-bdb
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2011-04-22 11:38:16 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2011-04-22 11:38:16 +0000
commit7484a75514658247c8602578879e90d4ed05556a (patch)
treeeeaae190059a50ee28e04b17402c51f43ebd62ef /databases/ruby-bdb
parentd4f32da1a47c0607ce6da16e1a1d410c848e5420 (diff)
downloadports-7484a75514658247c8602578879e90d4ed05556a.tar.gz
ports-7484a75514658247c8602578879e90d4ed05556a.zip
Update to 0.6.6 which I've just released.
Ruby 1.9.2 is now supported. PR: ports/156018 Submitted by: swills
Notes
Notes: svn path=/head/; revision=273036
Diffstat (limited to 'databases/ruby-bdb')
-rw-r--r--databases/ruby-bdb/Makefile16
-rw-r--r--databases/ruby-bdb/distinfo4
-rw-r--r--databases/ruby-bdb/files/patch-src_common.c20
3 files changed, 10 insertions, 30 deletions
diff --git a/databases/ruby-bdb/Makefile b/databases/ruby-bdb/Makefile
index ac64d68c2f9b..d8d3bf63b354 100644
--- a/databases/ruby-bdb/Makefile
+++ b/databases/ruby-bdb/Makefile
@@ -6,10 +6,12 @@
#
PORTNAME= bdb
-PORTVERSION= 0.6.5
-PORTREVISION= 1
+PORTVERSION= 0.6.6
CATEGORIES= databases ruby
-MASTER_SITES= RF
+MASTER_SITES= ftp://ftp.idaemons.org/pub/distfiles/ruby/ \
+ http://idaemons.org/distfiles/ruby/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= knu
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
PKGNAMESUFFIX= ${WITH_BDB_VER}
DIST_SUBDIR= ruby
@@ -17,7 +19,8 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
COMMENT= Ruby interface to Sleepycat's Berkeley DB revision 2 or later
-USE_BDB= YES
+USE_BDB= yes
+USE_BZIP2= yes
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}[2-4]*
@@ -26,15 +29,12 @@ USE_RUBY_EXTCONF= yes
USE_RUBY_RDOC= yes
CONFIGURE_ARGS= --with-db-include=${BDB_INCLUDE_DIR} \
- --with-db-lib=${BDB_LIB_DIR} \
- --with-db-version=${BDB_LIB_NAME:S/^db//}
+ --with-db-lib=${BDB_LIB_DIR}
INSTALL_TARGET= site-install
DOCS= Changes \
README.en \
- bdb.html \
bdb.rd \
- docs/*.html \
docs/*.rd
.include <bsd.port.pre.mk>
diff --git a/databases/ruby-bdb/distinfo b/databases/ruby-bdb/distinfo
index 1a8ab1f7127b..19794eb5a4d0 100644
--- a/databases/ruby-bdb/distinfo
+++ b/databases/ruby-bdb/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ruby/bdb-0.6.5.tar.gz) = edba29bb720fa32a93a80b2746667d52a30d63e418e89958b17896ef0f25889d
-SIZE (ruby/bdb-0.6.5.tar.gz) = 321865
+SHA256 (ruby/bdb-0.6.6.tar.bz2) = 8a4767568f06a1f85e1573f7e405a4db02cc32c2c11ac1cb7c11d069fae3afb8
+SIZE (ruby/bdb-0.6.6.tar.bz2) = 217988
diff --git a/databases/ruby-bdb/files/patch-src_common.c b/databases/ruby-bdb/files/patch-src_common.c
deleted file mode 100644
index c8d6cad0d575..000000000000
--- a/databases/ruby-bdb/files/patch-src_common.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/common.c.orig 2009-05-02 19:19:39.000000000 +0400
-+++ src/common.c 2009-05-02 19:20:04.000000000 +0400
-@@ -941,7 +941,7 @@
- }
- }
- if (!(dbst->options & BDB_NOT_OPEN)) {
-- bdb_test_error(dbst->dbp->close(dbst->dbp, flags));
-+ dbst->dbp->close(dbst->dbp, flags);
- }
- }
- else {
-@@ -950,7 +950,7 @@
- bdb_ary_delete(&envst->db_ary, dbst->ori_val);
- }
- if (!(dbst->options & BDB_NOT_OPEN)) {
-- bdb_test_error(dbst->dbp->close(dbst->dbp, flags));
-+ dbst->dbp->close(dbst->dbp, flags);
- }
- }
- }