aboutsummaryrefslogtreecommitdiff
path: root/deskutils/znotes
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-29 07:44:41 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-29 07:44:41 +0000
commite3df3096d4fa9ede9a22ecf2550962077d0dd4a0 (patch)
tree747b95c52b8cdb31d9323c1b27cdc9cd8e1c1654 /deskutils/znotes
parent1d66e03641d64e0fecc3914b0c3ab7b6657ff95f (diff)
downloadports-e3df3096d4fa9ede9a22ecf2550962077d0dd4a0.tar.gz
ports-e3df3096d4fa9ede9a22ecf2550962077d0dd4a0.zip
Flavorize deskutils/znotes
Submitted by: lebarondemerde@privacychain.ch Approved by: portmgr (mat) Differential Revision: https://reviews.freebsd.org/D14660
Notes
Notes: svn path=/head/; revision=468608
Diffstat (limited to 'deskutils/znotes')
-rw-r--r--deskutils/znotes/Makefile32
-rw-r--r--deskutils/znotes/distinfo5
-rw-r--r--deskutils/znotes/files/patch-single__inst_qtlocalpeer.cpp12
-rw-r--r--deskutils/znotes/pkg-plist17
4 files changed, 32 insertions, 34 deletions
diff --git a/deskutils/znotes/Makefile b/deskutils/znotes/Makefile
index fdae9ae85e22..4315079a7980 100644
--- a/deskutils/znotes/Makefile
+++ b/deskutils/znotes/Makefile
@@ -2,35 +2,41 @@
# $FreeBSD$
PORTNAME= znotes
-PORTVERSION= 0.4.5
-PORTREVISION= 2
+PORTVERSION= 0.4.5.20150825
CATEGORIES= deskutils
-MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
+PKGNAMESUFFIX= -${FLAVOR}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Simple notes managment application based on Qt 4
+MAINTAINER= lebarondemerde@privacychain.ch
+COMMENT= Simple notes managment application based on Qt
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
+FLAVORS= qt4 qt5
+FLAVOR?= ${FLAVORS:[1]}
+
USES= qmake
-USE_QT4= corelib gui network xml uic_build moc_build rcc_build \
- linguisttools_build
-QMAKE_ARGS= QMAKE_LRELEASE=${LRELEASE}
+USE_GL= gl
+
+USE_GITHUB= yes
+GH_ACCOUNT= proton
+GH_PROJECT= zNotes
+GH_TAGNAME= 6423c5e
+
+. if ${FLAVOR} == qt4
+USE_QT4= uic_build moc_build rcc_build linguisttools_build corelib gui network xml
+. else
+USE_QT5= buildtools_build linguisttools_build core gui network printsupport widgets xml
+. endif
DESKTOP_ENTRIES="zNotes" "Notes managment" \
"${PREFIX}/share/pixmaps/${PORTNAME}.png" "${PORTNAME}" \
"Utility;TextEditor;Qt;" true
-OPTIONS_DEFINE= NLS
-OPTIONS_SUB= yes
-
post-patch:
@${REINPLACE_CMD} -e '/.path =/s|/usr|$$$$PREFIX|g' \
-e '/PREFIX = /d' \
${WRKSRC}/${PORTNAME}.pro
- @${REINPLACE_CMD} -i -e 's,QCoreApplication::applicationDirPath()+"/translations","${DATADIR}/translations",g' \
- ${WRKSRC}/settings.cpp
pre-configure:
#Work around badly written .pro
diff --git a/deskutils/znotes/distinfo b/deskutils/znotes/distinfo
index 02e673be831e..879bcd87a62a 100644
--- a/deskutils/znotes/distinfo
+++ b/deskutils/znotes/distinfo
@@ -1,2 +1,3 @@
-SHA256 (znotes-0.4.5.tar.gz) = ac692253e74bda8f989db40042c26b6db2bb60a5f9c30cdbfcd824af0de1c5b2
-SIZE (znotes-0.4.5.tar.gz) = 171884
+TIMESTAMP = 1520867876
+SHA256 (proton-zNotes-0.4.5.20150825-6423c5e_GH0.tar.gz) = 93a9708a7c2522197e442d0aa28c9c20b13815c192ef8c51ced0006f6b352d2c
+SIZE (proton-zNotes-0.4.5.20150825-6423c5e_GH0.tar.gz) = 725999
diff --git a/deskutils/znotes/files/patch-single__inst_qtlocalpeer.cpp b/deskutils/znotes/files/patch-single__inst_qtlocalpeer.cpp
deleted file mode 100644
index aafe49c24fc7..000000000000
--- a/deskutils/znotes/files/patch-single__inst_qtlocalpeer.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- single_inst/qtlocalpeer.cpp.orig 2011-08-27 08:25:14 UTC
-+++ single_inst/qtlocalpeer.cpp
-@@ -58,9 +58,7 @@ static PProcessIdToSessionId pProcessIdT
- #if defined(Q_OS_UNIX)
- #include <time.h>
- #endif
--#if defined(Q_OS_OS2)
- #include <unistd.h>
--#endif
-
- namespace QtLP_Private {
- #include "qtlockedfile.cpp"
diff --git a/deskutils/znotes/pkg-plist b/deskutils/znotes/pkg-plist
index b1b15dfb99ed..8d544b68ec84 100644
--- a/deskutils/znotes/pkg-plist
+++ b/deskutils/znotes/pkg-plist
@@ -1,9 +1,12 @@
bin/znotes
share/pixmaps/znotes.png
-%%NLS%%%%DATADIR%%/translations/znotes_cs.qm
-%%NLS%%%%DATADIR%%/translations/znotes_en.qm
-%%NLS%%%%DATADIR%%/translations/znotes_es.qm
-%%NLS%%%%DATADIR%%/translations/znotes_pt_BR.qm
-%%NLS%%%%DATADIR%%/translations/znotes_ru.qm
-%%NLS%%%%DATADIR%%/translations/znotes_sk.qm
-%%NLS%%%%DATADIR%%/translations/znotes_uk.qm
+%%DATADIR%%/translations/znotes_cs.qm
+%%DATADIR%%/translations/znotes_de.qm
+%%DATADIR%%/translations/znotes_en.qm
+%%DATADIR%%/translations/znotes_es.qm
+%%DATADIR%%/translations/znotes_pl.qm
+%%DATADIR%%/translations/znotes_pt_BR.qm
+%%DATADIR%%/translations/znotes_ru.qm
+%%DATADIR%%/translations/znotes_sk.qm
+%%DATADIR%%/translations/znotes_sv.qm
+%%DATADIR%%/translations/znotes_uk.qm