aboutsummaryrefslogtreecommitdiff
path: root/devel/got
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2021-10-04 10:48:46 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2021-10-04 10:48:46 +0000
commit3170876d25844be648c0f77dc16c96114258bf72 (patch)
tree4cf6805778c3be55a5045c64c0918dfba201fed9 /devel/got
parentfeff7bce0dfb420e6f0fe65aff675da801d6a096 (diff)
downloadports-3170876d25844be648c0f77dc16c96114258bf72.tar.gz
ports-3170876d25844be648c0f77dc16c96114258bf72.zip
devel/got: update to 0.61
User-visible changes: - fix 'got send' with tree objects which contain symlinks - tog: show parent commit IDs of merge commits in the diff view - add a 'got merge' command for creating merge commits - fix 'got update' of an added + obstructed file - don't change bad symlinks into regular files during merges - fix 'got fetch' downloading too many objects in some cases - interrupt 'got rebase' upon missing/unversioned/not-deleted files - interrupt 'got histedit' upon missing/unversioned/not-deleted files - add histedit -e option which runs the 'edit' script command for every commit - skip ignored directories during 'got status' disk crawl
Diffstat (limited to 'devel/got')
-rw-r--r--devel/got/Makefile4
-rw-r--r--devel/got/distinfo6
-rw-r--r--devel/got/files/openbsd-compat/Makefile1
-rw-r--r--devel/got/files/openbsd-compat/open.c65
-rw-r--r--devel/got/files/openbsd-compat/openbsd-compat.h9
-rw-r--r--devel/got/files/patch-got_Makefile8
-rw-r--r--devel/got/files/patch-gotadmin_Makefile8
-rw-r--r--devel/got/files/patch-regress_cmdline_Makefile4
-rw-r--r--devel/got/files/patch-regress_cmdline_histedit.sh24
9 files changed, 34 insertions, 95 deletions
diff --git a/devel/got/Makefile b/devel/got/Makefile
index 93d6fb333aa6..d2f7597d6e07 100644
--- a/devel/got/Makefile
+++ b/devel/got/Makefile
@@ -1,5 +1,5 @@
PORTNAME= got
-PORTVERSION= 0.60
+PORTVERSION= 0.61
CATEGORIES= devel
MASTER_SITES= https://gameoftrees.org/releases/
@@ -25,7 +25,7 @@ post-extract:
# installed got
# installed git
# ssh to 127.0.0.1
-run-test:
+regress:
@(cd ${WRKSRC}/regress && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} regress)
.include <bsd.port.mk>
diff --git a/devel/got/distinfo b/devel/got/distinfo
index cac5835776bd..63104b70d9c4 100644
--- a/devel/got/distinfo
+++ b/devel/got/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1631710560
-SHA256 (got-0.60.tar.gz) = 3269b04c280f131482be3c7bb822c4066334ed03e1e91033c24113a19b2088fe
-SIZE (got-0.60.tar.gz) = 552219
+TIMESTAMP = 1633343772
+SHA256 (got-0.61.tar.gz) = 4a17f0ed3e13e9404e65b5cb96e7f4bd6a85f771beadc7b4e60812ea7256214a
+SIZE (got-0.61.tar.gz) = 563068
diff --git a/devel/got/files/openbsd-compat/Makefile b/devel/got/files/openbsd-compat/Makefile
index b07dd011928c..c590b173a81a 100644
--- a/devel/got/files/openbsd-compat/Makefile
+++ b/devel/got/files/openbsd-compat/Makefile
@@ -5,7 +5,6 @@ SRCS= freezero.c \
getdtablecount.c \
imsg.c \
imsg-buffer.c \
- open.c \
recallocarray.c
CFLAGS+= -I${.CURDIR}
diff --git a/devel/got/files/openbsd-compat/open.c b/devel/got/files/openbsd-compat/open.c
deleted file mode 100644
index fa9207c0814e..000000000000
--- a/devel/got/files/openbsd-compat/open.c
+++ /dev/null
@@ -1,65 +0,0 @@
-/*
- * Copyright (c) 2020 Christian Weisgerber <naddy@FreeBSD.org>
- *
- * Permission to use, copy, modify, and distribute this software for any
- * purpose with or without fee is hereby granted, provided that the above
- * copyright notice and this permission notice appear in all copies.
- *
- * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
- * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
- * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
- * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
- * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
- * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
- * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
- */
-
-#include <errno.h>
-#include <fcntl.h>
-#include <stdarg.h>
-
-/*
- * POSIX mandates that open(symlink, O_NOFOLLOW) fail with errno == ELOOP.
- * FreeBSD chooses to deviate from this, but Got depends on it.
- */
-int
-open_posix(const char *path, int flags, ...)
-{
- va_list ap;
- mode_t mode;
- int ret;
-
- if (flags & O_CREAT) {
- va_start(ap, flags);
- mode = va_arg(ap, int);
- va_end(ap);
- ret = open(path, flags, mode);
- } else
- ret = open(path, flags);
-
- if (ret == -1 && (flags & O_NOFOLLOW) && errno == EMLINK)
- errno = ELOOP;
-
- return (ret);
-}
-
-int
-openat_posix(int fd, const char *path, int flags, ...)
-{
- va_list ap;
- mode_t mode;
- int ret;
-
- if (flags & O_CREAT) {
- va_start(ap, flags);
- mode = va_arg(ap, int);
- va_end(ap);
- ret = openat(fd, path, flags, mode);
- } else
- ret = openat(fd, path, flags);
-
- if (ret == -1 && (flags & O_NOFOLLOW) && errno == EMLINK)
- errno = ELOOP;
-
- return (ret);
-}
diff --git a/devel/got/files/openbsd-compat/openbsd-compat.h b/devel/got/files/openbsd-compat/openbsd-compat.h
index 5615867b90c7..8f48c6469e4b 100644
--- a/devel/got/files/openbsd-compat/openbsd-compat.h
+++ b/devel/got/files/openbsd-compat/openbsd-compat.h
@@ -12,15 +12,6 @@
#define __dead __dead2
/*
- * <fcntl.h>
- */
-#define open(...) open_posix(__VA_ARGS__)
-#define openat(...) openat_posix(__VA_ARGS__)
-
-int open_posix(const char *path, int flags, ...);
-int openat_posix(int fd, const char *path, int flags, ...);
-
-/*
* <stdlib.h>
*/
void freezero(void *, size_t);
diff --git a/devel/got/files/patch-got_Makefile b/devel/got/files/patch-got_Makefile
index 07fce0ea5d73..0d9181a70843 100644
--- a/devel/got/files/patch-got_Makefile
+++ b/devel/got/files/patch-got_Makefile
@@ -1,6 +1,6 @@
---- got/Makefile.orig 2020-11-10 22:54:37 UTC
+--- got/Makefile.orig 2021-10-04 10:07:14 UTC
+++ got/Makefile
-@@ -29,10 +29,6 @@ DPADD = ${LIBZ} ${LIBUTIL}
+@@ -29,8 +29,4 @@ DPADD = ${LIBZ} ${LIBUTIL}
NOMAN = Yes
.endif
@@ -8,6 +8,4 @@
- ${INSTALL} ${INSTALL_COPY} -o ${BINOWN} -g ${BINGRP} \
- -m ${BINMODE} ${PROG} ${BINDIR}/${PROG}
-
- dist:
- mkdir ../got-${GOT_VERSION}/got
- cp ${SRCS} ${MAN} ../got-${GOT_VERSION}/got
+ .include <bsd.prog.mk>
diff --git a/devel/got/files/patch-gotadmin_Makefile b/devel/got/files/patch-gotadmin_Makefile
index 7df973f9ff27..e35e667ab932 100644
--- a/devel/got/files/patch-gotadmin_Makefile
+++ b/devel/got/files/patch-gotadmin_Makefile
@@ -1,6 +1,6 @@
---- gotadmin/Makefile.orig 2021-06-22 19:37:49 UTC
+--- gotadmin/Makefile.orig 2021-10-04 10:08:55 UTC
+++ gotadmin/Makefile
-@@ -24,10 +24,6 @@ DPADD = ${LIBZ} ${LIBUTIL}
+@@ -24,8 +24,4 @@ DPADD = ${LIBZ} ${LIBUTIL}
NOMAN = Yes
.endif
@@ -8,6 +8,4 @@
- ${INSTALL} ${INSTALL_COPY} -o ${BINOWN} -g ${BINGRP} \
- -m ${BINMODE} ${PROG} ${BINDIR}/${PROG}
-
- dist:
- mkdir ../got-${GOT_VERSION}/${PROG}
- cp ${SRCS} ${MAN} ../got-${GOT_VERSION}/${PROG}
+ .include <bsd.prog.mk>
diff --git a/devel/got/files/patch-regress_cmdline_Makefile b/devel/got/files/patch-regress_cmdline_Makefile
index a38c4c878bf9..bb51b0909783 100644
--- a/devel/got/files/patch-regress_cmdline_Makefile
+++ b/devel/got/files/patch-regress_cmdline_Makefile
@@ -1,6 +1,6 @@
---- regress/cmdline/Makefile.orig 2021-08-26 12:59:24 UTC
+--- regress/cmdline/Makefile.orig 2021-10-04 10:11:31 UTC
+++ regress/cmdline/Makefile
-@@ -90,4 +90,6 @@ cleanup:
+@@ -93,4 +93,6 @@ cleanup:
./cleanup.sh -q -r "$(GOT_TEST_ROOT)"
diff --git a/devel/got/files/patch-regress_cmdline_histedit.sh b/devel/got/files/patch-regress_cmdline_histedit.sh
index 629d24da7795..5e6b3cf3f2da 100644
--- a/devel/got/files/patch-regress_cmdline_histedit.sh
+++ b/devel/got/files/patch-regress_cmdline_histedit.sh
@@ -1,6 +1,6 @@
---- regress/cmdline/histedit.sh.orig 2021-08-30 22:15:20 UTC
+--- regress/cmdline/histedit.sh.orig 2021-10-04 10:11:31 UTC
+++ regress/cmdline/histedit.sh
-@@ -1539,7 +1539,7 @@ test_histedit_fold_only() {
+@@ -1561,7 +1561,7 @@ test_histedit_fold_only() {
cat > $testroot/editor.sh <<EOF
#!/bin/sh
@@ -9,7 +9,7 @@
EOF
chmod +x $testroot/editor.sh
-@@ -1655,7 +1655,7 @@ test_histedit_fold_only_empty_logmsg() {
+@@ -1677,7 +1677,7 @@ test_histedit_fold_only_empty_logmsg() {
cat > $testroot/editor.sh <<EOF
#!/bin/sh
@@ -18,3 +18,21 @@
EOF
chmod +x $testroot/editor.sh
+@@ -1811,7 +1811,7 @@ test_histedit_edit_only() {
+
+ cat > $testroot/editor.sh <<EOF
+ #!/bin/sh
+-sed -i 's/.*/committing edited changes 1/' "\$1"
++sed -i '' 's/.*/committing edited changes 1/' "\$1"
+ EOF
+ chmod +x $testroot/editor.sh
+
+@@ -1840,7 +1840,7 @@ EOF
+
+ cat > $testroot/editor.sh <<EOF
+ #!/bin/sh
+-sed -i 's/.*/committing edited changes 2/' "\$1"
++sed -i '' 's/.*/committing edited changes 2/' "\$1"
+ EOF
+ chmod +x $testroot/editor.sh
+