aboutsummaryrefslogtreecommitdiff
path: root/devel/got
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2022-02-18 20:31:18 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2022-02-18 20:31:18 +0000
commit6765c120f2dcb0d2b78a7570c7c39127d07b20a4 (patch)
tree4f516afe087b0317aaf5061d1734042d96870843 /devel/got
parentf3ad5309b7c94b3a197b7a031c4c0bc8a64dc292 (diff)
downloadports-6765c120f2dcb0d2b78a7570c7c39127d07b20a4.tar.gz
ports-6765c120f2dcb0d2b78a7570c7c39127d07b20a4.zip
devel/got: update to 0.67
User-visible changes: - show rebase and histedit backups in tog ref view - make 'got rm' behave like rm(1) for paths found missing on disk - make 'got rm' report an "unexpected status" error for unversioned files - fix 'got status' showing unversioned directories on NFS - fix infinite loop triggered by pack files >= 4GB in size - fix 'got diff' on files which match an ignore pattern - display GMT offset in 'got cat' command
Diffstat (limited to 'devel/got')
-rw-r--r--devel/got/Makefile2
-rw-r--r--devel/got/distinfo6
-rw-r--r--devel/got/files/patch-got_Makefile4
-rw-r--r--devel/got/files/patch-lib_pack__create.c10
-rw-r--r--devel/got/files/patch-regress_cmdline_commit.sh4
-rw-r--r--devel/got/files/patch-regress_cmdline_histedit.sh10
6 files changed, 23 insertions, 13 deletions
diff --git a/devel/got/Makefile b/devel/got/Makefile
index fa73fde04ca3..0ce1f0ec035d 100644
--- a/devel/got/Makefile
+++ b/devel/got/Makefile
@@ -1,5 +1,5 @@
PORTNAME= got
-PORTVERSION= 0.66
+PORTVERSION= 0.67
CATEGORIES= devel
MASTER_SITES= https://gameoftrees.org/releases/
diff --git a/devel/got/distinfo b/devel/got/distinfo
index f133f4ba0f3f..60deb3f6afbc 100644
--- a/devel/got/distinfo
+++ b/devel/got/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1641916009
-SHA256 (got-0.66.tar.gz) = abed77d4c324e81d15464979ba4441596a3ca34000f71415ea88ac0235f86a1b
-SIZE (got-0.66.tar.gz) = 583551
+TIMESTAMP = 1645215179
+SHA256 (got-0.67.tar.gz) = b76d09225a90bcae2d3ec01096c20c2b35fc951d2db576b0efd2940e1c08cdf6
+SIZE (got-0.67.tar.gz) = 588365
diff --git a/devel/got/files/patch-got_Makefile b/devel/got/files/patch-got_Makefile
index 0d9181a70843..fe501a4835a5 100644
--- a/devel/got/files/patch-got_Makefile
+++ b/devel/got/files/patch-got_Makefile
@@ -1,6 +1,6 @@
---- got/Makefile.orig 2021-10-04 10:07:14 UTC
+--- got/Makefile.orig 2022-01-19 10:29:31 UTC
+++ got/Makefile
-@@ -29,8 +29,4 @@ DPADD = ${LIBZ} ${LIBUTIL}
+@@ -30,8 +30,4 @@ DPADD = ${LIBZ} ${LIBUTIL}
NOMAN = Yes
.endif
diff --git a/devel/got/files/patch-lib_pack__create.c b/devel/got/files/patch-lib_pack__create.c
new file mode 100644
index 000000000000..df23013fb387
--- /dev/null
+++ b/devel/got/files/patch-lib_pack__create.c
@@ -0,0 +1,10 @@
+--- lib/pack_create.c.orig 2022-02-18 20:20:09 UTC
++++ lib/pack_create.c
+@@ -22,6 +22,7 @@
+ #include <sys/stat.h>
+ #include <sys/time.h>
+
++#include <endian.h>
+ #include <stdint.h>
+ #include <imsg.h>
+ #include <stdio.h>
diff --git a/devel/got/files/patch-regress_cmdline_commit.sh b/devel/got/files/patch-regress_cmdline_commit.sh
index 5bc4a9192ecb..82497661191a 100644
--- a/devel/got/files/patch-regress_cmdline_commit.sh
+++ b/devel/got/files/patch-regress_cmdline_commit.sh
@@ -1,6 +1,6 @@
---- regress/cmdline/commit.sh.orig 2021-08-30 22:15:20 UTC
+--- regress/cmdline/commit.sh.orig 2022-02-08 10:47:01 UTC
+++ regress/cmdline/commit.sh
-@@ -1377,7 +1377,7 @@ test_commit_prepared_logmsg() {
+@@ -1376,7 +1376,7 @@ test_commit_prepared_logmsg() {
cat > $testroot/editor.sh <<EOF
#!/bin/sh
diff --git a/devel/got/files/patch-regress_cmdline_histedit.sh b/devel/got/files/patch-regress_cmdline_histedit.sh
index 5e6b3cf3f2da..d56397895a19 100644
--- a/devel/got/files/patch-regress_cmdline_histedit.sh
+++ b/devel/got/files/patch-regress_cmdline_histedit.sh
@@ -1,6 +1,6 @@
---- regress/cmdline/histedit.sh.orig 2021-10-04 10:11:31 UTC
+--- regress/cmdline/histedit.sh.orig 2022-01-19 10:29:31 UTC
+++ regress/cmdline/histedit.sh
-@@ -1561,7 +1561,7 @@ test_histedit_fold_only() {
+@@ -1565,7 +1565,7 @@ test_histedit_fold_only() {
cat > $testroot/editor.sh <<EOF
#!/bin/sh
@@ -9,7 +9,7 @@
EOF
chmod +x $testroot/editor.sh
-@@ -1677,7 +1677,7 @@ test_histedit_fold_only_empty_logmsg() {
+@@ -1681,7 +1681,7 @@ test_histedit_fold_only_empty_logmsg() {
cat > $testroot/editor.sh <<EOF
#!/bin/sh
@@ -18,7 +18,7 @@
EOF
chmod +x $testroot/editor.sh
-@@ -1811,7 +1811,7 @@ test_histedit_edit_only() {
+@@ -1815,7 +1815,7 @@ test_histedit_edit_only() {
cat > $testroot/editor.sh <<EOF
#!/bin/sh
@@ -27,7 +27,7 @@
EOF
chmod +x $testroot/editor.sh
-@@ -1840,7 +1840,7 @@ EOF
+@@ -1844,7 +1844,7 @@ EOF
cat > $testroot/editor.sh <<EOF
#!/bin/sh