aboutsummaryrefslogtreecommitdiff
path: root/devel/got
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2023-10-01 13:21:50 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2023-10-01 13:21:50 +0000
commitbb39d9c437b01867dee5bd49121ffbaeeb348822 (patch)
tree47fd7bc29b482a25ae4ee14c7cded49ab20630b2 /devel/got
parent5526e99ac541e68b269f5ed7db608a2147eaf99b (diff)
downloadports-bb39d9c437b01867dee5bd49121ffbaeeb348822.tar.gz
ports-bb39d9c437b01867dee5bd49121ffbaeeb348822.zip
devel/got: honor fetch_all_branches configuration again
Fix a regression in 0.93 where the fetch_all_branches configuration setting from got.conf was dropped and always defaulted to "no".
Diffstat (limited to 'devel/got')
-rw-r--r--devel/got/Makefile1
-rw-r--r--devel/got/files/patch-lib_repository.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/devel/got/Makefile b/devel/got/Makefile
index df3523c3f2bb..46c5d76e224a 100644
--- a/devel/got/Makefile
+++ b/devel/got/Makefile
@@ -1,5 +1,6 @@
PORTNAME= got
DISTVERSION= 0.93
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://gameoftrees.org/releases/
diff --git a/devel/got/files/patch-lib_repository.c b/devel/got/files/patch-lib_repository.c
new file mode 100644
index 000000000000..68b194262533
--- /dev/null
+++ b/devel/got/files/patch-lib_repository.c
@@ -0,0 +1,11 @@
+--- lib/repository.c.orig 2023-09-29 20:30:16 UTC
++++ lib/repository.c
+@@ -947,6 +947,8 @@ got_repo_remote_repo_dup(struct got_remote_repo **newp
+
+ new->mirror_references = repo->mirror_references;
+
++ new->fetch_all_branches = repo->fetch_all_branches;
++
+ new->nfetch_branches = repo->nfetch_branches;
+ if (repo->fetch_branches) {
+ new->fetch_branches = calloc(repo->nfetch_branches,