aboutsummaryrefslogtreecommitdiff
path: root/dns/totd
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-12-13 06:14:27 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-12-13 06:14:27 +0000
commitdc60c4418c9580aefd1e95285aa937be2f22ca2c (patch)
tree58f3dff7c7ad51f2fc852065c01881d03e931afe /dns/totd
parenta9fe983d5ee002c1e07ceb17cc85ba91f86c2923 (diff)
downloadports-dc60c4418c9580aefd1e95285aa937be2f22ca2c.tar.gz
ports-dc60c4418c9580aefd1e95285aa937be2f22ca2c.zip
dns/totd: Replace custom @sample-like pkg-install script with just @sample
Notes
Notes: svn path=/head/; revision=519968
Diffstat (limited to 'dns/totd')
-rw-r--r--dns/totd/Makefile7
-rw-r--r--dns/totd/pkg-deinstall18
-rw-r--r--dns/totd/pkg-install45
3 files changed, 4 insertions, 66 deletions
diff --git a/dns/totd/Makefile b/dns/totd/Makefile
index 9aac7cbdfc80..3d7a3cff10ed 100644
--- a/dns/totd/Makefile
+++ b/dns/totd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= totd
PORTVERSION= 1.5.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= https://BSDforge.com/projects/source/dns/totd/
@@ -15,8 +15,9 @@ USES= desthack uidfix
USE_RC_SUBR= totd
GNU_CONFIGURE= yes
-PLIST_FILES= etc/totd.conf.sample sbin/totd \
- man/man8/totd.8.gz
+PLIST_FILES= "@sample etc/totd.conf.sample" \
+ man/man8/totd.8.gz \
+ sbin/totd
EXTRA_PATCHES= ${FILESDIR}/extra-patch-ne_mesg.c \
${FILESDIR}/extra-patch-tcp_response.c
diff --git a/dns/totd/pkg-deinstall b/dns/totd/pkg-deinstall
deleted file mode 100644
index ad0f2ba9987c..000000000000
--- a/dns/totd/pkg-deinstall
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-# $OpenBSD: DEINSTALL,v 1.1 2000/06/11 01:15:53 fgsch Exp $
-#
-# Post-deinstallation cleanup of totd
-
-if [ x$2 = "xDEINSTALL" ]; then
-echo ""
-echo "** To completely deinstall the totd package you need to perform this"
-echo "** as root:"
-echo "**"
-echo "** rm -f ${PKG_PREFIX}/etc/totd.conf"
-echo "**"
-echo "** Be absolutly sure you want to completely remove the package before"
-echo "** issuing this command."
-echo ""
-fi
-
-exit 0
diff --git a/dns/totd/pkg-install b/dns/totd/pkg-install
deleted file mode 100644
index c64a12b12394..000000000000
--- a/dns/totd/pkg-install
+++ /dev/null
@@ -1,45 +0,0 @@
-#! /bin/sh
-# $OpenBSD: INSTALL,v 1.1 2000/06/11 01:15:53 fgsch Exp $
-#
-# Post-installation setup of totd - based on majordomo INSTALL script
-# from daniel@reichardt.ch
-
-set -e
-PATH=/bin:/usr/bin:/sbin:/usr/sbin
-PREFIX=${PKG_PREFIX:-/usr/local}
-
-do_install_configuration()
-{
- echo -n "Let's see if there is already a configuration file... "
- if [ -f ${PREFIX}/etc/totd.conf ]; then
- echo "yes"
- echo "Please compare your existing configuration with"
- echo "${PREFIX}/etc/totd.conf.sample"
- else
- echo "no"
- echo -n "Copying sample configuration file... "
- install -o root -g wheel -m 644 ${PREFIX}/etc/totd.conf.sample \
- ${PREFIX}/etc/totd.conf
- echo "ok"
- echo "Please review new configuration ${PREFIX}/etc/totd.conf"
- fi
-}
-
-if [ $# -ne 2 ]; then
- echo "usage: $0 distname { PRE-INSTALL | POST-INSTALL }" >&2
- exit 1
-fi
-
-case $2 in
- PRE-INSTALL)
- ;;
- POST-INSTALL)
- do_install_configuration
- ;;
- *)
- echo "usage: $0 distname { PRE-INSTALL | POST-INSTALL }" >&2
- exit 1
- ;;
-esac
-
-exit 0