aboutsummaryrefslogtreecommitdiff
path: root/editors/abiword
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-03-27 14:57:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-03-27 14:57:59 +0000
commit6bc6f3a9e07f4647594e7ad34d21cff7b6cd3418 (patch)
tree95ab4f85bf7bf8cb530a6cecc47ac36a30dcab4b /editors/abiword
parent37e8aaec0258c9c628ea0ecb9fd1f26a00577d4b (diff)
downloadports-6bc6f3a9e07f4647594e7ad34d21cff7b6cd3418.tar.gz
ports-6bc6f3a9e07f4647594e7ad34d21cff7b6cd3418.zip
- Update security/gnutls to 3.4.10.
- Rename the LIBDANE option DANE because that's the name of the protocol supported by libgnutls-dane and gnutls-cli. Also clarify the option description. - Add an IDN option. - libgnutls-openssl has been removed in 3.4. Some ports used this library in their LIB_DEPENDS but no port actually required it. - Some old API functions have been removed. Ports that used these have been updated or patched to use the new API. - Add a patch to print/cups to prevent overlinking of libgnutls.so. - Bump PORTREVISION on dependent ports. net-im/jabber: This port used the old API to give users fine grained control over which crypto algorithms were used via a configuration file. It's not immediately obvious how to port this to the new API so the port always uses the defaults now. www/hydra: Mark BROKEN. This uses more removed calls than the other ports, is said to be alpha quality and not fully functional and has been abandoned 10 years ago. PR: 207768 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=411990
Diffstat (limited to 'editors/abiword')
-rw-r--r--editors/abiword/Makefile2
-rw-r--r--editors/abiword/files/patch-plugins_collab_backends_service_xp_tls_tunnel.cpp24
2 files changed, 25 insertions, 1 deletions
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index ef7de5a448de..72c9135a8295 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -3,7 +3,7 @@
PORTNAME= abiword
PORTVERSION= 3.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors
MASTER_SITES= http://www.abisource.com/downloads/abiword/${PORTVERSION}/source/
DIST_SUBDIR= AbiWord
diff --git a/editors/abiword/files/patch-plugins_collab_backends_service_xp_tls_tunnel.cpp b/editors/abiword/files/patch-plugins_collab_backends_service_xp_tls_tunnel.cpp
new file mode 100644
index 000000000000..4854e1dfd745
--- /dev/null
+++ b/editors/abiword/files/patch-plugins_collab_backends_service_xp_tls_tunnel.cpp
@@ -0,0 +1,24 @@
+--- plugins/collab/backends/service/xp/tls_tunnel.cpp.orig 2014-11-04 01:12:14 UTC
++++ plugins/collab/backends/service/xp/tls_tunnel.cpp
+@@ -306,8 +306,6 @@ void Proxy::tunnel_(transport_ptr_t tran
+ disconnect_(transport_ptr, session_ptr, local_socket_ptr, remote_socket_ptr);
+ }
+
+-static const int PRIORITIES[] = { GNUTLS_KX_ANON_DH, GNUTLS_KX_RSA, GNUTLS_KX_DHE_DSS, GNUTLS_KX_DHE_RSA, 0 };
+-static const int CIPHERS[] = { GNUTLS_CIPHER_AES_256_CBC, GNUTLS_CIPHER_AES_128_CBC, GNUTLS_CIPHER_3DES_CBC, GNUTLS_CIPHER_ARCFOUR_128, 0 };
+
+ // FIXME: this clientproxy can only handle 1 SSL connection at the same time
+ ClientProxy::ClientProxy(const std::string& connect_address, unsigned short connect_port,
+@@ -399,9 +397,9 @@ session_ptr_t ClientProxy::setup_tls_ses
+
+ // setup session
+ return_val_if_neg(gnutls_init(session_ptr.get(), GNUTLS_CLIENT), session_ptr_t());
+- return_val_if_neg(gnutls_set_default_priority(*session_ptr), session_ptr_t());
+- return_val_if_neg(gnutls_kx_set_priority(*session_ptr,PRIORITIES), session_ptr_t());
+- return_val_if_neg(gnutls_cipher_set_priority(*session_ptr,CIPHERS), session_ptr_t());
++ return_val_if_neg(gnutls_priority_set_direct(*session_ptr,"NORMAL"
++ ":-CIPHER-ALL:+AES-256-CBC:+AES-128-CBC:+3DES-CBC:+ARCFOUR-128"
++ ":-KX-ALL:+ANON-DH:+RSA:+DHE-DSS:+DHE-RSA",NULL), session_ptr_t());
+ return_val_if_neg(gnutls_credentials_set(*session_ptr, GNUTLS_CRD_CERTIFICATE, x509cred), session_ptr_t());
+
+ // setup transport