aboutsummaryrefslogtreecommitdiff
path: root/editors/biew
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2009-10-01 15:42:20 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2009-10-01 15:42:20 +0000
commit35259e8cbe1decc3ffe546e2fd23c7682ccd57af (patch)
tree565e1f2e83d6f711422056b687ab278ae73c588f /editors/biew
parent8960d5500b931163e0d38fbab0e06051abbb6830 (diff)
downloadports-35259e8cbe1decc3ffe546e2fd23c7682ccd57af.tar.gz
ports-35259e8cbe1decc3ffe546e2fd23c7682ccd57af.zip
- Allow to build with ncurses renderer; while it still fails to behave
correctly in text console, it gets better in xterm/screen [*] - Optimize away ``.for .. .endfor'' loop while here Requested by: Alex Kozlov [*]
Notes
Notes: svn path=/head/; revision=242360
Diffstat (limited to 'editors/biew')
-rw-r--r--editors/biew/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/editors/biew/Makefile b/editors/biew/Makefile
index 91d013222209..f60f4f8880ea 100644
--- a/editors/biew/Makefile
+++ b/editors/biew/Makefile
@@ -14,12 +14,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}-src
MAINTAINER= danfe@FreeBSD.org
COMMENT= Binary file viewer and editor
-LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
-
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --cc="${CC}" --with-extraincdir="${LOCALBASE}/include" \
--ld="${CC}" --with-extralibdir="${LOCALBASE}/lib" \
- --prefix="${PREFIX}" --datadir="${DATADIR}" --enable-slang
+ --prefix="${PREFIX}" --datadir="${DATADIR}"
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
@@ -38,8 +36,17 @@ MAN1= biew.1
PORTDOCS= biew_en.txt biew_ru.txt develop.en develop.ru file_ini.en \
file_ini.ru licence.en licence.ru release.txt unix.txt
+OPTIONS= SLANG "Use S-Lang based display renderer" on
+
.include <bsd.port.pre.mk>
+.if defined(WITH_SLANG)
+LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
+CONFIGURE_ARGS+= --enable-slang
+.else
+CONFIGURE_ARGS+= --enable-curses
+.endif
+
.if ${ARCH} == "sparc64"
BROKEN= Does not compile
.endif
@@ -63,9 +70,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/doc/biew.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>