aboutsummaryrefslogtreecommitdiff
path: root/editors/calligra
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-07-09 21:46:54 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-07-09 21:49:33 +0000
commit680bd562fcf69bee54eefbe2f126c7fd853f3655 (patch)
tree80a22ec1d4cbdba0fb5d1561d56751a6eb63e886 /editors/calligra
parent22b261986aed507dc61926c83269056db127a7ba (diff)
downloadports-680bd562fcf69bee54eefbe2f126c7fd853f3655.tar.gz
ports-680bd562fcf69bee54eefbe2f126c7fd853f3655.zip
*/*: Update KDE Frameworks to 5.83
Saturday, 12 June 2021 KDE today announces the release of KDE Frameworks 5.83.0. KDE Frameworks are 83 addon libraries to Qt which provide a wide variety of commonly needed functionality in mature, peer reviewed and well tested libraries with friendly licensing terms. For an introduction see the KDE Frameworks release announcement. This release is part of a series of planned monthly releases making improvements available to developers in a quick and predictable manner. Full announcement: https://kde.org/announcements/frameworks/5/5.83.0/ PR: 256665 Exp-run by: antoine
Diffstat (limited to 'editors/calligra')
-rw-r--r--editors/calligra/files/patch-CMakeLists.txt17
-rw-r--r--editors/calligra/files/patch-libs_text_CMakeLists.txt20
2 files changed, 37 insertions, 0 deletions
diff --git a/editors/calligra/files/patch-CMakeLists.txt b/editors/calligra/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..d9be84715185
--- /dev/null
+++ b/editors/calligra/files/patch-CMakeLists.txt
@@ -0,0 +1,17 @@
+Fix build against KDE Frameworks 5.83
+(no longer ships find module, and the
+cmake default one is used).
+
+--- CMakeLists.txt.orig 2021-07-09 21:31:30 UTC
++++ CMakeLists.txt
+@@ -641,8 +641,8 @@ if(NOT WIN32 AND NOT APPLE)
+ )
+ endif()
+
+-if(NOT FONTCONFIG_FOUND OR NOT FREETYPE_FOUND)
+- set(FONTCONFIG_INCLUDE_DIR "")
++if(NOT Fontconfig_FOUND OR NOT FREETYPE_FOUND)
++ set(Fontconfig_INCLUDE_DIRS "")
+ set(FREETYPE_INCLUDE_DIRS "")
+ else()
+ add_definitions( -DSHOULD_BUILD_FONT_CONVERSION )
diff --git a/editors/calligra/files/patch-libs_text_CMakeLists.txt b/editors/calligra/files/patch-libs_text_CMakeLists.txt
new file mode 100644
index 000000000000..3079dfd8cd05
--- /dev/null
+++ b/editors/calligra/files/patch-libs_text_CMakeLists.txt
@@ -0,0 +1,20 @@
+Fix build against KDE Frameworks 5.83
+(no longer ships find module, and the
+cmake default one is used).
+
+--- libs/text/CMakeLists.txt.orig 2021-07-09 21:32:19 UTC
++++ libs/text/CMakeLists.txt
+@@ -152,11 +152,11 @@ if( SHOULD_BUILD_FEATURE_RDF )
+ endif()
+
+ if( FONTCONFIG_FOUND )
+- target_link_libraries(kotext PRIVATE ${FONTCONFIG_LIBRARIES})
++ target_link_libraries(kotext PRIVATE Fontconfig::Fontconfig)
+ endif()
+
+ if( FREETYPE_FOUND )
+- target_link_libraries(kotext PRIVATE ${FREETYPE_LIBRARIES})
++ target_link_libraries(kotext PRIVATE Freetype::Freetype)
+ endif()
+
+