aboutsummaryrefslogtreecommitdiff
path: root/editors/calligra
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-09-12 06:13:58 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-09-12 15:14:58 +0000
commitd040b1f838df86c5ae4125f667707e7c5d870fc4 (patch)
treeded1ea08fd0674d1aa15f08b420843adfcc141d0 /editors/calligra
parenta69c99e8100ff2f2c289a46455de4229b3925f97 (diff)
downloadports-d040b1f838df86c5ae4125f667707e7c5d870fc4.tar.gz
ports-d040b1f838df86c5ae4125f667707e7c5d870fc4.zip
editors/calligra: move webkit behind default-off option
qt5-webkit will be removed by the end of the year.
Diffstat (limited to 'editors/calligra')
-rw-r--r--editors/calligra/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 7dfe2628db72..fe4d75a1d309 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -1,6 +1,6 @@
PORTNAME= calligra
DISTVERSION= 3.2.1
-PORTREVISION= 57
+PORTREVISION= 58
CATEGORIES= editors kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
DIST_SUBDIR= KDE/${PORTNAME}
@@ -54,16 +54,19 @@ USE_KDE= activities akonadicontacts archive auth bookmarks calendarcore \
xmlgui \
ecm:build
USE_QT= concurrent core dbus declarative gui network opengl phonon4 \
- printsupport script sql svg testlib webkit widgets x11extras \
+ printsupport script sql svg testlib widgets x11extras \
xml \
buildtools:build qmake:build
USE_XORG= ice sm x11 xext
-OPTIONS_DEFINE= OPENEXR
+OPTIONS_DEFINE= OPENEXR WEBKIT
OPTIONS_DEFAULT= OPENEXR
OPENEXR_LIB_DEPENDS= libOpenEXR.so:graphics/openexr
OPENEXR_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_OpenEXR
+WEBKIT_DESC= Use obsolete qt5-webkit to build Browser Plugin
+WEBKIT_USE= QT5=webkit
+WEBKIT_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Qt5WebKit
CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:STRING="${QT_INCDIR} ${LOCALBASE}/include" \
-DPRODUCTSET:STRING="DESKTOP"