aboutsummaryrefslogtreecommitdiff
path: root/editors/chexedit
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-01-28 17:47:30 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-01-28 17:47:30 +0000
commit3d0cb520b32f5c144abeecf175c3eb04f17cb298 (patch)
tree746c00a41a715cb61c709a7ff7fce00b3f80c545 /editors/chexedit
parent62f3cebd1802aefa301ab40ecb5b948d53c01c90 (diff)
downloadports-3d0cb520b32f5c144abeecf175c3eb04f17cb298.tar.gz
ports-3d0cb520b32f5c144abeecf175c3eb04f17cb298.zip
- Fix search on 64-bit systems
Notes
Notes: svn path=/head/; revision=311132
Diffstat (limited to 'editors/chexedit')
-rw-r--r--editors/chexedit/Makefile1
-rw-r--r--editors/chexedit/files/patch-src-search.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/editors/chexedit/Makefile b/editors/chexedit/Makefile
index 38b87dfff8dc..16bafe19dc4a 100644
--- a/editors/chexedit/Makefile
+++ b/editors/chexedit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= chexedit
PORTVERSION= 0.9.7
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= http://www.rogoyski.com/adam/programs/hexedit/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/editors/chexedit/files/patch-src-search.c b/editors/chexedit/files/patch-src-search.c
new file mode 100644
index 000000000000..ed56d008ebba
--- /dev/null
+++ b/editors/chexedit/files/patch-src-search.c
@@ -0,0 +1,11 @@
+--- src/search.c.orig 1999-06-27 17:45:29.000000000 +0400
++++ src/search.c 2013-01-28 21:43:29.590293182 +0400
+@@ -39,7 +39,7 @@
+ if (!buf)
+ return &found;
+
+- memset (l_table, 0, 256 * sizeof (int));
++ memset (l_table, 0, 256 * sizeof (unsigned long));
+ i = 0;
+ s = substr + len - 1;
+ while (i < len)