aboutsummaryrefslogtreecommitdiff
path: root/editors/cpeditor
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-08-01 07:35:37 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-08-01 07:35:40 +0000
commitd8a7f486b1d060f32c074c66c4abaab223536beb (patch)
treeb006e4aa4bac0e80d3157572eaf440a6ef859518 /editors/cpeditor
parentcd876745538da60f59c7f23c552211af9b63c069 (diff)
downloadports-d8a7f486b1d060f32c074c66c4abaab223536beb.tar.gz
ports-d8a7f486b1d060f32c074c66c4abaab223536beb.zip
editors/cpeditor: add workaround for cmake 3.21.1
CMake Error: Running '/usr/local/bin/ninja' '-C' '/wrkdirs/usr/ports/editors/cpeditor/work/.build' '-t' 'recompact' failed with: ninja: error: build.ninja:824: multiple rules generate ui/ui_appwindow.h [-w dupbuild=err] PR: 257489
Diffstat (limited to 'editors/cpeditor')
-rw-r--r--editors/cpeditor/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/editors/cpeditor/Makefile b/editors/cpeditor/Makefile
index cc30e416733a..3a22856189e1 100644
--- a/editors/cpeditor/Makefile
+++ b/editors/cpeditor/Makefile
@@ -8,8 +8,9 @@ COMMENT= Lightweight and cross-platform code editor for competitive programming
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake compiler:c++14-lang qt:5
-USE_QT= core gui network widgets buildtools_build linguisttools_build qmake_build
+USES= cmake:noninja compiler:c++14-lang qt:5
+USE_QT= core gui network widgets \
+ buildtools_build linguisttools_build qmake_build
USE_GITHUB= yes
GH_TUPLE= \
cpeditor:QCodeEditor:ca5f949:cpeditor_QCodeEditor/third_party/QCodeEditor \