aboutsummaryrefslogtreecommitdiff
path: root/editors/dhex
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-01-23 12:47:04 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-01-23 12:47:04 +0000
commit4febb29427a9d30d5c2f9e78ba27f7ee25eff27d (patch)
tree5927f004c9e4f4de789e1f1592d86dd82f51079e /editors/dhex
parentccb1c1d4f26aaa55e54be9ef1890d6a78f913241 (diff)
downloadports-4febb29427a9d30d5c2f9e78ba27f7ee25eff27d.tar.gz
ports-4febb29427a9d30d5c2f9e78ba27f7ee25eff27d.zip
Add dhex, a ncurses-based hex-editor with diff mode.
Feature safe: yes
Notes
Notes: svn path=/head/; revision=268132
Diffstat (limited to 'editors/dhex')
-rw-r--r--editors/dhex/Makefile26
-rw-r--r--editors/dhex/distinfo2
-rw-r--r--editors/dhex/files/patch-Makefile20
-rw-r--r--editors/dhex/pkg-descr7
4 files changed, 55 insertions, 0 deletions
diff --git a/editors/dhex/Makefile b/editors/dhex/Makefile
new file mode 100644
index 000000000000..1c61794f019b
--- /dev/null
+++ b/editors/dhex/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: dhex
+# Date created: 23 Jan 2011
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dhex
+PORTVERSION= 0.62
+CATEGORIES= editors
+MASTER_SITES= http://www.dettus.net/dhex/ \
+ CRITICAL
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= A ncurses-based hex-editor with diff mode
+
+LICENSE= GPLv2
+PLIST_FILES= bin/dhex
+
+MAKE_JOBS_SAFE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/editors/dhex/distinfo b/editors/dhex/distinfo
new file mode 100644
index 000000000000..3852186ecd5f
--- /dev/null
+++ b/editors/dhex/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dhex_0.62.tar.gz) = fcf9a48e30cebb99bf6cc0e8f9521ac61f7bfae942785a218a0ce32091009e5b
+SIZE (dhex_0.62.tar.gz) = 45399
diff --git a/editors/dhex/files/patch-Makefile b/editors/dhex/files/patch-Makefile
new file mode 100644
index 000000000000..8d789af63e50
--- /dev/null
+++ b/editors/dhex/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- ./Makefile.orig 2011-01-12 13:34:30.000000000 +0100
++++ ./Makefile 2011-01-23 13:27:13.000000000 +0100
+@@ -1,7 +1,7 @@
+-CC= gcc
+-LDFLAGS= -L/usr/lib -L/usr/local/lib -L/usr/lib/ncurses -L/usr/local/lib/ncurses
+-CPPFLAGS= -I/usr/include -I/usr/local/include -I/usr/include/ncurses -I/usr/local/include/ncurses
+-CFLAGS= -O3 -Wall -std=c99
++CC?= gcc
++#LDFLAGS+= -L/usr/lib -L/usr/local/lib -L/usr/lib/ncurses -L/usr/local/lib/ncurses
++#CPPFLAGS+= -I/usr/include -I/usr/local/include -I/usr/include/ncurses -I/usr/local/include/ncurses
++CFLAGS+= -std=c99
+ #CFLAGS+= -ffunction-sections -fdata-sections
+ #LDFLAGS+= --gc-sections
+ LIBS= -lncurses
+@@ -24,5 +24,3 @@
+
+ clean:
+ rm -f dhex $(OFILES)
+-
+-
diff --git a/editors/dhex/pkg-descr b/editors/dhex/pkg-descr
new file mode 100644
index 000000000000..555cda320742
--- /dev/null
+++ b/editors/dhex/pkg-descr
@@ -0,0 +1,7 @@
+dhex is a more than just another hex editor: It includes a diff mode, which can
+be used to easily and conveniently compare two binary files. Since it is based
+on ncurses and is themeable, it can run on any number of systems and scenarios.
+With its utilization of search logs, it is possible to track changes in
+different iterations of files easily.
+
+WWW: http://www.dettus.net/dhex/