aboutsummaryrefslogtreecommitdiff
path: root/editors/dhex
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-01-31 08:38:11 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-01-31 08:38:11 +0000
commitd501f3cd30f15a74d54461513122a8dfcffa5395 (patch)
treef0c59bb7e7528a2349c2c85d45134fae0011b8c0 /editors/dhex
parent83cb0309a2718b5771495d8d9c7bdb6a9f4a6c0b (diff)
downloadports-d501f3cd30f15a74d54461513122a8dfcffa5395.tar.gz
ports-d501f3cd30f15a74d54461513122a8dfcffa5395.zip
Also install manpages for dhexrc.5 dhex_markers.5 dhex_searchlog.5.
Feature safe: yes
Notes
Notes: svn path=/head/; revision=268466
Diffstat (limited to 'editors/dhex')
-rw-r--r--editors/dhex/Makefile5
-rw-r--r--editors/dhex/files/patch-Makefile6
-rw-r--r--editors/dhex/files/patch-dhex.118
-rw-r--r--editors/dhex/files/patch-dhexrc.59
4 files changed, 35 insertions, 3 deletions
diff --git a/editors/dhex/Makefile b/editors/dhex/Makefile
index 03f2a3840124..9c221eebbd71 100644
--- a/editors/dhex/Makefile
+++ b/editors/dhex/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dhex
PORTVERSION= 0.63
+PORTREVISION= 1
CATEGORIES= editors
MASTER_SITES= http://www.dettus.net/dhex/ \
CRITICAL
@@ -17,6 +18,7 @@ COMMENT= A ncurses-based hex-editor with diff mode
LICENSE= GPLv2
MAN1= dhex.1
+MAN5= dhexrc.5 dhex_markers.5 dhex_searchlog.5
PLIST_FILES= bin/dhex
MAKE_JOBS_SAFE= yes
@@ -24,5 +26,8 @@ MAKE_JOBS_SAFE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+.for f in ${MAN5}
+ ${INSTALL_MAN} ${WRKSRC}/${f} ${MANPREFIX}/man/man5
+.endfor
.include <bsd.port.mk>
diff --git a/editors/dhex/files/patch-Makefile b/editors/dhex/files/patch-Makefile
index 8d789af63e50..5b53f3516370 100644
--- a/editors/dhex/files/patch-Makefile
+++ b/editors/dhex/files/patch-Makefile
@@ -1,5 +1,5 @@
---- ./Makefile.orig 2011-01-12 13:34:30.000000000 +0100
-+++ ./Makefile 2011-01-23 13:27:13.000000000 +0100
+--- ./Makefile.orig 2011-01-29 00:19:37.000000000 +0100
++++ ./Makefile 2011-01-31 09:28:00.000000000 +0100
@@ -1,7 +1,7 @@
-CC= gcc
-LDFLAGS= -L/usr/lib -L/usr/local/lib -L/usr/lib/ncurses -L/usr/local/lib/ncurses
@@ -12,7 +12,7 @@
#CFLAGS+= -ffunction-sections -fdata-sections
#LDFLAGS+= --gc-sections
LIBS= -lncurses
-@@ -24,5 +24,3 @@
+@@ -29,5 +29,3 @@
clean:
rm -f dhex $(OFILES)
diff --git a/editors/dhex/files/patch-dhex.1 b/editors/dhex/files/patch-dhex.1
new file mode 100644
index 000000000000..ba7990a0f5bb
--- /dev/null
+++ b/editors/dhex/files/patch-dhex.1
@@ -0,0 +1,18 @@
+--- ./dhex.1.orig 2011-01-31 09:28:21.000000000 +0100
++++ ./dhex.1 2011-01-31 09:29:15.000000000 +0100
+@@ -145,7 +145,7 @@
+
+ It is also possible to set up to ten bookmarks in this screen: Pressing '0'...'9' will select one of them. Move the cursor to "Set" to alter one of those book marks. The "Diff:" fields are showing the difference between the actual cursor position and the bookmark.
+
+-Bookmarks can be stored and loaded, for this there are the "Save Markers" and "Load Markers" items on the bottom. Upon selecting one of them, the user is being prompted for a filename. It is possible to load a marker file at start time, by providing the -m parameter. dhex_marker(5) describes the format of the marker files.
++Bookmarks can be stored and loaded, for this there are the "Save Markers" and "Load Markers" items on the bottom. Upon selecting one of them, the user is being prompted for a filename. It is possible to load a marker file at start time, by providing the -m parameter. dhex_markers(5) describes the format of the marker files.
+
+
+ .Ss Searching
+@@ -178,5 +178,5 @@
+ .An Thomas Dettbarn
+ .Sh SEE ALSO
+ .Xr dhexrc 5 ,
+-.Xr dhex_marker 5 ,
++.Xr dhex_markers 5 ,
+ .Xr dhex_searchlog 5
diff --git a/editors/dhex/files/patch-dhexrc.5 b/editors/dhex/files/patch-dhexrc.5
new file mode 100644
index 000000000000..fd2680f1b030
--- /dev/null
+++ b/editors/dhex/files/patch-dhexrc.5
@@ -0,0 +1,9 @@
+--- ./dhexrc.5.orig 2011-01-31 09:29:52.000000000 +0100
++++ ./dhexrc.5 2011-01-31 09:30:07.000000000 +0100
+@@ -233,5 +233,5 @@
+ .An Thomas Dettbarn
+ .Sh SEE ALSO
+ .Xr dhex 1 ,
+-.Xr dhex_marker 5 ,
++.Xr dhex_markers 5 ,
+ .Xr dhex_searchlog 5