aboutsummaryrefslogtreecommitdiff
path: root/editors/e93
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-05-22 08:03:52 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-05-22 08:03:52 +0000
commit153dd8a22fdde23eca5f81d18b4705a92dab0e36 (patch)
tree7e9a5f982f2040a01a8a5a792a21c1cb3b984bfa /editors/e93
parent06b034d04d79b606b7210c3041b5202ae233c7e8 (diff)
downloadports-153dd8a22fdde23eca5f81d18b4705a92dab0e36.tar.gz
ports-153dd8a22fdde23eca5f81d18b4705a92dab0e36.zip
- Fix build with Tcl 8.6
Reported by: miwi (Tcl/Tk 86 exp-run latecomers) Approved by: portmgr
Notes
Notes: svn path=/head/; revision=318746
Diffstat (limited to 'editors/e93')
-rw-r--r--editors/e93/Makefile1
-rw-r--r--editors/e93/files/patch-includes.h12
-rw-r--r--editors/e93/files/patch-shell.c20
-rw-r--r--editors/e93/files/patch-shellcmd.c11
4 files changed, 43 insertions, 1 deletions
diff --git a/editors/e93/Makefile b/editors/e93/Makefile
index 9bc3654f463a..8d863edcab4e 100644
--- a/editors/e93/Makefile
+++ b/editors/e93/Makefile
@@ -20,7 +20,6 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_XORG= x11 xinerama
-USE_TCL_BUILD= yes
USE_TCL= yes
USE_GMAKE= yes
MAKE_ARGS= PREFIX="${PREFIX}" \
diff --git a/editors/e93/files/patch-includes.h b/editors/e93/files/patch-includes.h
new file mode 100644
index 000000000000..9d0c50713760
--- /dev/null
+++ b/editors/e93/files/patch-includes.h
@@ -0,0 +1,12 @@
+--- includes.h.orig 2013-05-22 09:36:16.000000000 +0200
++++ includes.h 2013-05-22 09:42:02.000000000 +0200
+@@ -29,6 +29,9 @@
+ #include <locale.h>
+
+ #include <tcl.h>
++#if (TCL_MAJOR_VERSION < 8) || (TCL_MAJOR_VERSION == 8) && (TCL_MINOR_VERSION < 6)
++#define Tcl_GetErrorLine(interp) (interp->errorLine)
++#endif
+
+ #include "defines.h"
+ #include "guidefs.h"
diff --git a/editors/e93/files/patch-shell.c b/editors/e93/files/patch-shell.c
new file mode 100644
index 000000000000..2e68e44ee923
--- /dev/null
+++ b/editors/e93/files/patch-shell.c
@@ -0,0 +1,20 @@
+--- shell.c.orig 2013-05-22 09:35:54.000000000 +0200
++++ shell.c 2013-05-22 09:44:04.000000000 +0200
+@@ -992,7 +992,7 @@
+ Tcl_SetVar(interpreter,"SCRIPTPATH",scriptPath,TCL_LEAVE_ERR_MSG);
+ if(Tcl_EvalFile(interpreter,scriptPath)!=TCL_OK)
+ {
+- SetError("%s:%d:%s",scriptPath,interpreter->errorLine,Tcl_GetStringResult(interpreter));
++ SetError("%s:%d:%s",scriptPath,Tcl_GetErrorLine(interpreter),Tcl_GetStringResult(interpreter));
+ fail=true;
+ }
+ }
+@@ -1066,7 +1066,7 @@
+ }
+ else
+ {
+- SetError("Failed to Tcl_Init(): %s",tclInterpreter->result);
++ SetError("Failed to Tcl_Init(): %s",Tcl_GetStringResult(tclInterpreter));
+ }
+ UnInitChannels(tclInterpreter);
+ }
diff --git a/editors/e93/files/patch-shellcmd.c b/editors/e93/files/patch-shellcmd.c
new file mode 100644
index 000000000000..9e2967dec9dc
--- /dev/null
+++ b/editors/e93/files/patch-shellcmd.c
@@ -0,0 +1,11 @@
+--- shellcmd.c.orig 2013-05-22 09:45:47.000000000 +0200
++++ shellcmd.c 2013-05-22 09:46:25.000000000 +0200
+@@ -6354,7 +6354,7 @@
+ {
+ if(tclResult!=TCL_OK)
+ {
+- sprintf(tempString,"Error in line %d: ",localInterpreter->errorLine);
++ sprintf(tempString,"Error in line %d: ",Tcl_GetErrorLine(localInterpreter));
+ EditorAuxInsert(buffer,(UINT8 *)tempString,(UINT32)strlen(tempString));
+ }
+ EditorAuxInsert(buffer,(UINT8 *)stringResult,(UINT32)strlen(stringResult));