aboutsummaryrefslogtreecommitdiff
path: root/editors/fxite
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-04-22 15:16:30 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-04-22 15:16:30 +0000
commit6c341ee07fb17b8b90e2504440e01a9ea8e212e5 (patch)
tree09a1c2a07a413d2f847368b865942b031691a118 /editors/fxite
parentebd56c1a0c8d41768ce2c17fbfb5f3bd9ec24c8f (diff)
downloadports-6c341ee07fb17b8b90e2504440e01a9ea8e212e5.tar.gz
ports-6c341ee07fb17b8b90e2504440e01a9ea8e212e5.zip
- Update to 0.91
- Add OPTIONs to chose whether to use FOX-1.6 or FOX-1.7 - Switch to GitHub as a MASTER_SITE Feature safe: yes
Notes
Notes: svn path=/head/; revision=316238
Diffstat (limited to 'editors/fxite')
-rw-r--r--editors/fxite/Makefile49
-rw-r--r--editors/fxite/distinfo4
-rw-r--r--editors/fxite/files/patch-jef_compat.cpp11
3 files changed, 46 insertions, 18 deletions
diff --git a/editors/fxite/Makefile b/editors/fxite/Makefile
index 50dd766b39ab..20fc08d4d413 100644
--- a/editors/fxite/Makefile
+++ b/editors/fxite/Makefile
@@ -2,29 +2,50 @@
# $FreeBSD$
PORTNAME= fxite
-PORTVERSION= 0.9
+PORTVERSION= 0.91
CATEGORIES= editors
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= gahr@FreeBSD.org
COMMENT= An advanced cross-platform text editor
-LIB_DEPENDS= FOX-1.6:${PORTSDIR}/x11-toolkits/fox16
+LIB_DEPENDS= #
+
+OPTIONS_SINGLE= FOX
+OPTIONS_SINGLE_FOX= FOX16 FOX17
+FOX16_DESC= Use FOX 1.6
+FOX17_DESC= Use FOX 1.7
+OPTIONS_DEFAULT= FOX16
+
+USE_GITHUB= yes
+GH_ACCOUNT= yetanothergeek
+GH_TAGNAME= FXITE-0_91
+GH_COMMIT= c2ecac3
-USE_GETTEXT= yes
USE_LUA= yes
-USE_GNOME= pkgconfig
-GNU_CONFIGURE= yes
-CXXFLAGS+= -g -O0 -fPIC
+USE_PKGCONFIG= build
+USE_AUTOTOOLS= aclocal autoconf automake
+ACLOCAL_ARGS= --force -I m4
+AUTOMAKE_ARGS= --gnu --add-missing --copy
+USE_GMAKE= yes
+CXXFLAGS+= -fPIC
LDFLAGS+= -L${LOCALBASE}/lib -lintl
CONFIGURE_ARGS+=--with-system-lua \
--with-lua-pkg=lua-${LUA_VER}
+CONFIGURE_ENV+= FOX_CFLAGS="${FOX_CFLAGS}" \
+ FOX_LIBS="${FOX_LIBS}"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${OSVERSION} < 800067
-LIB_DEPENDS+= getline.1:${PORTSDIR}/devel/libgetline
-LDFLAGS+= -lgetline
+.if ${PORT_OPTIONS:MFOX16}
+LIB_DEPENDS+= FOX-1.6:${PORTSDIR}/x11-toolkits/fox16
+FOX_CFLAGS+= `fox-config --cflags`
+FOX_LIBS+= `fox-config --libs`
+.endif
+
+.if ${PORT_OPTIONS:MFOX17}
+LIB_DEPENDS+= FOX-1.7:${PORTSDIR}/x11-toolkits/fox17
+FOX_CFLAGS+= `pkgconf fox17 --cflags`
+FOX_LIBS+= `pkgconf fox17 --libs`
.endif
PLIST_FILES= bin/fxite \
@@ -32,8 +53,4 @@ PLIST_FILES= bin/fxite \
share/applications/fxite.desktop
PLIST_DIRSTRY= share/applications
-post-patch:
- ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- ${WRKSRC}/${CONFIGURE_SCRIPT}
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/fxite/distinfo b/editors/fxite/distinfo
index a75269bd2eba..424f893f5fc5 100644
--- a/editors/fxite/distinfo
+++ b/editors/fxite/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fxite-0.9.tar.gz) = a49894a27c255d0a76ecf9da471ff92a6b4849005f7e096f92de356d952fa8fb
-SIZE (fxite-0.9.tar.gz) = 1161194
+SHA256 (fxite-0.91.tar.gz) = 6b45272d8765e1c9ba9cd09900f4345063f6ed780a99e7733a80fdb3642db06b
+SIZE (fxite-0.91.tar.gz) = 1012281
diff --git a/editors/fxite/files/patch-jef_compat.cpp b/editors/fxite/files/patch-jef_compat.cpp
new file mode 100644
index 000000000000..46ca575eadb8
--- /dev/null
+++ b/editors/fxite/files/patch-jef_compat.cpp
@@ -0,0 +1,11 @@
+--- jef/compat.cpp.orig 2013-04-02 11:39:14.000000000 +0200
++++ jef/compat.cpp 2013-04-02 11:39:34.000000000 +0200
+@@ -292,7 +292,7 @@
+
+
+
+-static bool ClientMsg(FXTopWindow*w, const char *msg, ulong d0=0, ulong d1=0, ulong d2=0, ulong d3=0, ulong d4=0) {
++static bool ClientMsg(FXTopWindow*w, const char *msg, FXulong d0=0, FXulong d1=0, FXulong d2=0, FXulong d3=0, FXulong d4=0) {
+ Display*dpy=(Display*)w->getApp()->getDisplay();
+ Window root=w->getApp()->getRootWindow()->id();
+ XEvent event;