aboutsummaryrefslogtreecommitdiff
path: root/editors/jedit
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-08-07 06:31:46 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-08-07 06:31:46 +0000
commit8cf5f5ecad2330f56d4a1d24ee70e073eda12ea1 (patch)
tree273e00fc17cb61c4faf616e945cf2d3ed0a0b467 /editors/jedit
parent83ce1d58362836cfb803f90c31b7b5838430d022 (diff)
downloadports-8cf5f5ecad2330f56d4a1d24ee70e073eda12ea1.tar.gz
ports-8cf5f5ecad2330f56d4a1d24ee70e073eda12ea1.zip
- update to 5.1.0, attach gplv2 license
- pass maintainership to submitter - properly support DOCS (instscript no longer required) PR: 181009 Submitted by: danilogondolfo@gmail.com
Notes
Notes: svn path=/head/; revision=324330
Diffstat (limited to 'editors/jedit')
-rw-r--r--editors/jedit/Makefile34
-rw-r--r--editors/jedit/distinfo4
-rw-r--r--editors/jedit/files/instscript7
-rw-r--r--editors/jedit/pkg-descr2
4 files changed, 32 insertions, 15 deletions
diff --git a/editors/jedit/Makefile b/editors/jedit/Makefile
index 21a3725df05c..3df03416c044 100644
--- a/editors/jedit/Makefile
+++ b/editors/jedit/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= jedit
-PORTVERSION= 5.0.0
+PORTVERSION= 5.1.0
PORTEPOCH= 1
CATEGORIES= editors java
MASTER_SITES= SF
@@ -10,12 +10,31 @@ DISTNAME= ${PORTNAME}${PORTVERSION}install
EXTRACT_SUFX= .jar
EXTRACT_ONLY=
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danilogondolfo@gmail.com
COMMENT= Powerful programmer\'s text editor written in Java
+LICENSE= GPLv2
+
RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
-CONFLICTS= jedit-4.3.p*
+OPTIONS_DEFINE= MACROS DOCS
+MACROS_DESC= Install default set of macros (highly recommended)
+
+OPTIONS_DEFAULT= MACROS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+DOCS=y
+.else
+DOCS=n
+.endif
+
+.if ${PORT_OPTIONS:MMACROS}
+MACROS=y
+.else
+MACROS=n
+.endif
USE_JAVA= yes
JAVA_VERSION= 1.6+
@@ -27,12 +46,15 @@ DATADIR= ${JAVASHAREDIR}/${PORTNAME}
SUB_FILES= jedit.sh
+DESKTOP_ENTRIES="jEdit" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Development;" false
+
MAN1= jedit.1
# The complete PLIST is generated in post-install
-PLIST_FILES= bin/jedit
+PLIST_FILES= bin/jedit share/pixmaps/${PORTNAME}.png
do-install:
- @${SED} "s|%%PREFIX%%|${PREFIX}| ; s|%%DATADIR%%|${DATADIR}| ; s|%%WRKDIR%%|${WRKDIR}|" ${FILESDIR}/instscript | \
+ @${PRINTF} "${DATADIR}\n${WRKDIR}\n${PREFIX}/man/man1\nY\n${MACROS}\n${DOCS}" | \
${SETENV} CLASSPATH=${DISTDIR}/${DISTNAME}.jar \
${JAVA} installer.Install text
@${INSTALL_SCRIPT} ${WRKDIR}/jedit.sh ${PREFIX}/bin/jedit
@@ -42,5 +64,7 @@ post-install:
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${DATADIR} -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+ @${INSTALL_DATA} ${DATADIR}/doc/jedit.png \
+ ${PREFIX}/share/pixmaps/${PORTNAME}.png
.include <bsd.port.mk>
diff --git a/editors/jedit/distinfo b/editors/jedit/distinfo
index c1aa119d4be8..c7c9b43bc7e5 100644
--- a/editors/jedit/distinfo
+++ b/editors/jedit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (jedit5.0.0install.jar) = 24b7f10f012737d77fe4bfa6c7961fca978ad3dd410561efd1ca8ab796e0f6ad
-SIZE (jedit5.0.0install.jar) = 3136160
+SHA256 (jedit5.1.0install.jar) = 96f229d91a1effd6b0da1aee209390d8a131bd68e0cf4cd274dca14245ba30d7
+SIZE (jedit5.1.0install.jar) = 3196992
diff --git a/editors/jedit/files/instscript b/editors/jedit/files/instscript
deleted file mode 100644
index 535ca886a694..000000000000
--- a/editors/jedit/files/instscript
+++ /dev/null
@@ -1,7 +0,0 @@
-%%DATADIR%%
-%%WRKDIR%%
-%%PREFIX%%/man/man1
-Y
-Y
-Y
-
diff --git a/editors/jedit/pkg-descr b/editors/jedit/pkg-descr
index 153fbb89a533..913967764bbe 100644
--- a/editors/jedit/pkg-descr
+++ b/editors/jedit/pkg-descr
@@ -7,7 +7,7 @@ easy to use, intuitive interface, and enough features and flexibility to please
even the most hard-core programmer. A very incomplete list of jEdit's features
follows.
-o Syntax highlighting for 30+ file types (including C, C++, Java, Perl, etc)
+o Syntax highlighting for 200+ file types (including C, C++, Java, Perl, etc)
o Semi-intelligent auto indent in C, C++ and Java modes
o Bracket highlighting and matching
o Powerful macro system