aboutsummaryrefslogtreecommitdiff
path: root/editors/joe
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2015-03-24 16:19:16 +0000
committerMikhail Teterin <mi@FreeBSD.org>2015-03-24 16:19:16 +0000
commitfb2d2336cce73188fd056dfb0f9a9a9b0d2c3462 (patch)
tree82e7f93ef36fc510525503908b7d0193f381b4f3 /editors/joe
parent440da136f069029e70fa01abf9bb44ae1159566b (diff)
downloadports-fb2d2336cce73188fd056dfb0f9a9a9b0d2c3462.tar.gz
ports-fb2d2336cce73188fd056dfb0f9a9a9b0d2c3462.zip
Upgrade from 3.7 to 4.0.
Notes
Notes: svn path=/head/; revision=382116
Diffstat (limited to 'editors/joe')
-rw-r--r--editors/joe/Makefile5
-rw-r--r--editors/joe/distinfo4
-rw-r--r--editors/joe/files/patch-main.c18
-rw-r--r--editors/joe/files/patch-tty.c4
4 files changed, 6 insertions, 25 deletions
diff --git a/editors/joe/Makefile b/editors/joe/Makefile
index 55bae1db15f6..77661b6bb4bf 100644
--- a/editors/joe/Makefile
+++ b/editors/joe/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= joe
-PORTVERSION= 3.7
-PORTREVISION= 2
+PORTVERSION= 4.0
PORTEPOCH= 1
CATEGORIES?= editors
MASTER_SITES= SF/joe-editor/JOE%20sources/joe-${PORTVERSION}
@@ -11,7 +10,7 @@ MASTER_SITES= SF/joe-editor/JOE%20sources/joe-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Joe's Own Editor
-LICENSE= GPLv1
+LICENSE= GPLv2
BUILD_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
RUN_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
diff --git a/editors/joe/distinfo b/editors/joe/distinfo
index b38e15a052ec..ff4255386e6d 100644
--- a/editors/joe/distinfo
+++ b/editors/joe/distinfo
@@ -1,2 +1,2 @@
-SHA256 (joe-3.7.tar.gz) = cae456e1ad5a8c1d3c94920a3416c2347277739b260e3494d3bc0f2b9b73106f
-SIZE (joe-3.7.tar.gz) = 696036
+SHA256 (joe-4.0.tar.gz) = c556adff77fd97bf1b86198de6cb82e0b92cda18579c4fef6c83b608d2ed2915
+SIZE (joe-4.0.tar.gz) = 838783
diff --git a/editors/joe/files/patch-main.c b/editors/joe/files/patch-main.c
deleted file mode 100644
index 9646f53d6e85..000000000000
--- a/editors/joe/files/patch-main.c
+++ /dev/null
@@ -1,18 +0,0 @@
-$NetBSD: patch-main.c,v 1.1 2011/04/01 13:12:24 wiz Exp $
-
-Fix for crash with a segv if called as jmacs with more then
-one file as an argument on the command line from upstream.
-
-http://joe-editor.cvs.sourceforge.net/viewvc/joe-editor/joe-current/main/main.c?r1=1.5&r2=1.6
-
---- main.c.orig 2008-10-27 03:01:11.000000000 +0000
-+++ main.c
-@@ -431,7 +431,7 @@ int main(int argc, char **real_argv, cha
- b->orphan = 1;
- b->oldcur = pdup(b->bof, USTR "main");
- pline(b->oldcur, get_file_pos(b->name));
-- p_goto_bol(bw->cursor);
-+ p_goto_bol(b->oldcur);
- line = b->oldcur->line - (maint->h - 1) / 2;
- if (line < 0)
- line = 0;
diff --git a/editors/joe/files/patch-tty.c b/editors/joe/files/patch-tty.c
index e6023dd2f4fb..a5c1ccffd6e4 100644
--- a/editors/joe/files/patch-tty.c
+++ b/editors/joe/files/patch-tty.c
@@ -1,5 +1,5 @@
---- tty.c.orig Fri Mar 18 10:40:11 2005
-+++ tty.c Fri May 6 16:58:38 2005
+--- joe/tty.c Fri Mar 18 10:40:11 2005
++++ joe/tty.c Fri May 6 16:58:38 2005
@@ -1074,8 +1074,10 @@
setsid(); /* I think you do setprgp(0,0) on systems with no setsid() */
#ifndef SETPGRP_VOID