aboutsummaryrefslogtreecommitdiff
path: root/editors/micro
diff options
context:
space:
mode:
authorLewis Cook <lcook@FreeBSD.org>2023-06-03 07:18:57 +0000
committerLewis Cook <lcook@FreeBSD.org>2023-06-03 07:26:13 +0000
commit4cf70d53286fa93a6568167b5c734beb3050d332 (patch)
tree78413360755725a782543b5b882eb3b8318991c4 /editors/micro
parent987561dd63a1676e13dbb8881ffa416f5034e888 (diff)
downloadports-4cf70d53286fa93a6568167b5c734beb3050d332.tar.gz
ports-4cf70d53286fa93a6568167b5c734beb3050d332.zip
editors/micro: Set MAKE_ENV during pre-build phase
`go generate` requires $XDG_CACHE_HOME, otherwise may write to /nonexistent in Poudriere causing a build failure. Reported by: Steffen Dirkwinkel <freebsd@steffen.cc> Differential Revision: https://reviews.freebsd.org/D37941
Diffstat (limited to 'editors/micro')
-rw-r--r--editors/micro/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/editors/micro/Makefile b/editors/micro/Makefile
index e7d21d80db5a..91f314d0fde7 100644
--- a/editors/micro/Makefile
+++ b/editors/micro/Makefile
@@ -1,7 +1,7 @@
PORTNAME= micro
DISTVERSIONPREFIX= v
DISTVERSION= 2.0.11
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= editors
MAINTAINER= lcook@FreeBSD.org
@@ -41,7 +41,7 @@ DEBUG_DESC= Enable debug logging
DEBUG_VARS= _BUILD_DEBUG=ON
pre-build:
- cd ${GO_WRKSRC} && ${SETENV} ${GO_ENV} ${GO_CMD} generate ./runtime
+ cd ${GO_WRKSRC} && ${SETENV} ${MAKE_ENV} ${GO_ENV} ${GO_CMD} generate ./runtime
post-install:
${INSTALL_DATA} ${WRKSRC}/assets/packaging/micro.1 \