aboutsummaryrefslogtreecommitdiff
path: root/editors/nedit
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-15 03:21:01 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-15 03:21:01 +0000
commit7d4b9358de8d39ef42a9b7968e6df14415e06df2 (patch)
tree3f7cb7ea9bdf118fe628aacfa73043252f05be48 /editors/nedit
parent8ea67380b8306a311c42d18a8e7daafd7f787f41 (diff)
downloadports-7d4b9358de8d39ef42a9b7968e6df14415e06df2.tar.gz
ports-7d4b9358de8d39ef42a9b7968e6df14415e06df2.zip
1: Stagify.
2: use @owner, @group, @mode. Approved by: portmgr@
Notes
Notes: svn path=/head/; revision=357822
Diffstat (limited to 'editors/nedit')
-rw-r--r--editors/nedit/Makefile6
-rw-r--r--editors/nedit/files/patch-aa32
-rw-r--r--editors/nedit/files/patch-ab10
-rw-r--r--editors/nedit/pkg-plist8
4 files changed, 30 insertions, 26 deletions
diff --git a/editors/nedit/Makefile b/editors/nedit/Makefile
index f69b7f6500bf..052cf441d353 100644
--- a/editors/nedit/Makefile
+++ b/editors/nedit/Makefile
@@ -22,14 +22,12 @@ MAINTAINER= deischen@FreeBSD.org
COMMENT= X11/Motif GUI text editor for programs and plain text files
LICENSE= GPLv1
-USES= motif
-USE_BZIP2= yes
+USES= motif tar:bzip2
USE_XORG= xpm
-MAN1= nclient.1 nedit.1
ALL_TARGET= freebsd
MAKE_ENV+= BINOWN=${BINOWN} BINGRP=${BINGRP} BINMODE=${BINMODE}
+PLIST_SUB+= BINOWN=${BINOWN} BINGRP=${BINGRP} BINMODE=${BINMODE}
-NO_STAGE= yes
post-extract:
${CP} ${DISTDIR}/nedit.app-defaults ${WRKSRC}/NEdit.ad
diff --git a/editors/nedit/files/patch-aa b/editors/nedit/files/patch-aa
index bd6e3db138ed..f2e9fc0158cb 100644
--- a/editors/nedit/files/patch-aa
+++ b/editors/nedit/files/patch-aa
@@ -1,17 +1,15 @@
-*** Makefile.orig Wed Jan 5 23:04:45 2000
---- Makefile Fri Mar 17 06:57:23 2000
-***************
-*** 22,27 ****
---- 22,33 ----
- (cd util; $(MAKE) -f Makefile.$@ libNUtil.a)
- (cd source; $(MAKE) -f Makefile.$@ nedit nc)
-
-+ install::
-+ (cd source; make -f Makefile.freebsd install)
-+ ${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m 644 doc/nedit.man ${PREFIX}/man/man1/nedit.1
-+ ${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m 644 doc/nc.man ${PREFIX}/man/man1/nclient.1
-+ ${INSTALL} ${COPY} -m 644 NEdit.ad ${LOCALBASE}/lib/X11/app-defaults/NEdit.ad
-+
- clean:
- (cd util; $(MAKE) -f Makefile.common clean)
- (cd source; $(MAKE) -f Makefile.common clean)
+--- Makefile.orig 2004-10-01 04:51:05.000000000 +0800
++++ Makefile 2014-06-15 11:03:09.564113068 +0800
+@@ -44,6 +44,12 @@ docs:
+ # that doesn't work since we require the user to specify the target. More
+ # thought is needed
+
++install::
++ (cd source; make -f Makefile.freebsd install)
++ ${INSTALL} ${COPY} -m 644 doc/nedit.man $(DESTDIR)${PREFIX}/man/man1/nedit.1
++ ${INSTALL} ${COPY} -m 644 doc/nc.man $(DESTDIR)${PREFIX}/man/man1/nclient.1
++ ${INSTALL} ${COPY} -m 644 NEdit.ad $(DESTDIR)${LOCALBASE}/lib/X11/app-defaults/NEdit.ad
++
+ clean:
+ (cd util; $(MAKE) -f Makefile.common clean)
+ (cd Xlt; $(MAKE) -f Makefile.common clean)
diff --git a/editors/nedit/files/patch-ab b/editors/nedit/files/patch-ab
index abe5194e6c2b..f10542e16308 100644
--- a/editors/nedit/files/patch-ab
+++ b/editors/nedit/files/patch-ab
@@ -1,12 +1,12 @@
---- source/Makefile.common.orig Thu May 15 19:42:31 2003
-+++ source/Makefile.common Sat Feb 7 14:47:52 2004
-@@ -21,6 +21,10 @@
+--- source/Makefile.common.orig 2004-03-21 22:25:56.000000000 +0800
++++ source/Makefile.common 2014-06-15 11:03:55.335101520 +0800
+@@ -28,6 +28,10 @@ nedit: $(OBJS) ../util/libNUtil.a $(XMLL
nc: nc.o server_common.o ../util/libNUtil.a
$(CC) $(CFLAGS) nc.o server_common.o ../util/libNUtil.a $(LIBS) -o $@
+install: nedit nc
-+ ${INSTALL} ${COPY} ${STRIP} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} nedit ${PREFIX}/bin
-+ ${INSTALL} ${COPY} ${STRIP} -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} nc ${PREFIX}/bin/nclient
++ ${INSTALL} ${COPY} ${STRIP} nedit $(DESTDIR)${PREFIX}/bin
++ ${INSTALL} ${COPY} ${STRIP} nc $(DESTDIR)${PREFIX}/bin/nclient
+
help.o: help.c
$(CC) $(CFLAGS) $(BIGGER_STRINGS) -c help.c -o $@
diff --git a/editors/nedit/pkg-plist b/editors/nedit/pkg-plist
index 46b0c50522f4..86caef5ce7c7 100644
--- a/editors/nedit/pkg-plist
+++ b/editors/nedit/pkg-plist
@@ -1,3 +1,11 @@
+@owner %%BINOWN%%
+@group %%BINGRP%%
+@mode %%BINMODE%%
bin/nclient
bin/nedit
+@mode
+man/man1/nclient.1.gz
+man/man1/nedit.1.gz
+@owner
+@group
lib/X11/app-defaults/NEdit.ad