aboutsummaryrefslogtreecommitdiff
path: root/editors/nvi-m17n
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-08-22 14:57:02 +0000
committerSteve Wills <swills@FreeBSD.org>2017-08-22 14:57:02 +0000
commit7077df04b53ea400d8bfe22efcd3c921bf02c360 (patch)
treefa8d511e84292c5da7a43602cca10954ad851a27 /editors/nvi-m17n
parentbda6a572c9f3ed2252361f502b8d4a554b822911 (diff)
downloadports-7077df04b53ea400d8bfe22efcd3c921bf02c360.tar.gz
ports-7077df04b53ea400d8bfe22efcd3c921bf02c360.zip
editors/nvi-m17n: Fix autodetect of iso-2022-jp2
PR: 215852 Submitted by: Yasuhito FUTATSUKI <freebsd-bug-report-yf@yf.bsdclub.org>
Notes
Notes: svn path=/head/; revision=448538
Diffstat (limited to 'editors/nvi-m17n')
-rw-r--r--editors/nvi-m17n/Makefile2
-rw-r--r--editors/nvi-m17n/files/patch-common-multibyte.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/editors/nvi-m17n/Makefile b/editors/nvi-m17n/Makefile
index 65868c59eefb..b901d2e14961 100644
--- a/editors/nvi-m17n/Makefile
+++ b/editors/nvi-m17n/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nvi
PORTVERSION= 1.79.20040608
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES?= editors
MASTER_SITES= ftp://ftp.mk.bsdclub.org/pub/FreeBSD/distfiles/ \
diff --git a/editors/nvi-m17n/files/patch-common-multibyte.c b/editors/nvi-m17n/files/patch-common-multibyte.c
new file mode 100644
index 000000000000..c18afc51d54e
--- /dev/null
+++ b/editors/nvi-m17n/files/patch-common-multibyte.c
@@ -0,0 +1,11 @@
+--- ../common/multibyte.c.orig 2017-01-07 18:04:20.087312000 +0900
++++ ../common/multibyte.c 2017-01-07 18:05:53.585988000 +0900
+@@ -1455,7 +1455,7 @@
+ return ename;
+
+ for (i = 0; i < maxfunc; i++) {
+- if (maybe == (1 << i))
++ if (maybe & (1 << i))
+ return dt->name[i];
+ }
+ }