aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-4
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2021-12-01 09:40:19 +0000
committerDon Lewis <truckman@FreeBSD.org>2021-12-01 09:53:11 +0000
commit3adea779c689b7f81b77a81c802e892674d025af (patch)
treed0df6bbd40ec0deaf4030748c7dfb5839efe8075 /editors/openoffice-4
parent41886a54b11adefacbfad557a780cba386b9b7d9 (diff)
downloadports-3adea779c689b7f81b77a81c802e892674d025af.tar.gz
ports-3adea779c689b7f81b77a81c802e892674d025af.zip
editors/openoffice*: unbreak build with clang 13+
The include file vigra/memory.hxx from the graphics/vigra port has this error: /usr/local/include/vigra/memory.hxx:43:12: fatal error: 'tr1/memory' file not found # include <tr1/memory> ^~~~~~~~~~~~ when compiling with clang 13.0 or newer in -std=gnu++98 mode. MFH: 2021Q4
Diffstat (limited to 'editors/openoffice-4')
-rw-r--r--editors/openoffice-4/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index dcf6e61ae326..95e6d692d36f 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -211,9 +211,12 @@ GCC_EXTRA_DISTFILES= d6eef4b4cacb2183f2bf265a5a03a354-boost_1_55_0.tar.bz2 \
.if ${CHOSEN_COMPILER_TYPE} == clang
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS+= --with-system-boost --with-system-vigra
-BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs \
- ${LOCALBASE}/bin/vigra-config:graphics/vigra
+CONFIGURE_ARGS+= --with-system-boost
+BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
+. if ${COMPILER_VERSION} < 130
+CONFIGURE_ARGS+= --with-system-vigra
+BUILD_DEPENDS+= ${LOCALBASE}/bin/vigra-config:graphics/vigra
+. endif
. if ${ARCH} == amd64
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-align16
. endif
@@ -222,7 +225,8 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-align16
# These extra distfiles are needed to use the bundled versions of
# boost and vigra for compatiblity with gcc. Also include them
# for the makesum target so they are included in distinfo
-.if ${CHOSEN_COMPILER_TYPE} == gcc || make(makesum) || make(distclean)
+.if ${CHOSEN_COMPILER_TYPE} == gcc || ${COMPILER_VERSION} >= 130 || \
+ make(makesum) || make(distclean)
DISTFILES+= ${GCC_EXTRA_DISTFILES:C/.*/&:sf/g}
.endif
@@ -339,7 +343,7 @@ do-extract-SDK-on:
post-extract:
${TAR} -C ${WRKSUBDIR} -xzf ${DISTDIR}/${DIST_SUBDIR}/${EXTSRC}
${CP} ${DISTDIR}/${DIST_SUBDIR}/${PYTHON_DISTFILE} ${WRKSUBDIR}/ext_sources/${PYTHON_DISTFILE}
-.if ${CHOSEN_COMPILER_TYPE} == gcc
+.if ${CHOSEN_COMPILER_TYPE} == gcc || ${COMPILER_VERSION} >= 130
. for f in ${GCC_EXTRA_DISTFILES}
${CP} ${DISTDIR}/${DIST_SUBDIR}/${f} ${WRKSUBDIR}/ext_sources/${f}
. endfor