aboutsummaryrefslogtreecommitdiff
path: root/editors/openoffice-4
diff options
context:
space:
mode:
authorDon Lewis <truckman@FreeBSD.org>2022-04-13 02:05:25 +0000
committerDon Lewis <truckman@FreeBSD.org>2022-04-13 02:12:50 +0000
commit7b40ee8ab732691960bcc7d49eacff1bf1f544fe (patch)
treefa49ea917fc2ec866f91901f212cb50c71e8b41b /editors/openoffice-4
parentc582b85eb19fc424d4dcc4c8ea561bc55f252387 (diff)
downloadports-7b40ee8ab732691960bcc7d49eacff1bf1f544fe.tar.gz
ports-7b40ee8ab732691960bcc7d49eacff1bf1f544fe.zip
editors/openoffice-4: Fix dependency issues
Fix an incorrect coinmp-related dependency that was causing spurious rebuilds. It was also reported to break the build, though I was unable to reproduce the problem, and it did not seem to break the official package build. Add another missing dependency. Both issues were reported by stage-qa. PR: 263238
Diffstat (limited to 'editors/openoffice-4')
-rw-r--r--editors/openoffice-4/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 770a8e0b1b04..255004f3e303 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -2,7 +2,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= editors java
MASTER_SITES= https://dlcdn.apache.org/openoffice/${PORTVERSION}/source/ \
https://archive.apache.org/dist/openoffice/${PORTVERSION}/source/ \
@@ -83,7 +83,7 @@ LIB_DEPENDS= \
libClpSolver.so:math/clp \
libCoinMP.so:math/coinmp \
libCoinUtils.so:math/coinutils \
- libcoinmumps.so:math/ipopt \
+ libcoinmumps.so:math/coin-or-mumps \
libnauty.so:math/nauty \
libopenblas.so:math/openblas \
libOsi.so:math/osi \
@@ -113,7 +113,7 @@ USES= autoreconf bison compiler:c++11-lib cpe desktop-file-utils \
gettext-runtime gl gmake gnome iconv jpeg perl5 pkgconfig \
shared-mime-info ssl tar:bzip2 xorg
USE_GL= gl glu
-USE_GNOME= gtk20 libxslt libidl glib20
+USE_GNOME= gdkpixbuf2 gtk20 libxslt libidl glib20
USE_JAVA= yes
JAVA_BUILD= jdk
JAVA_RUN= jdk