aboutsummaryrefslogtreecommitdiff
path: root/editors/sam
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1995-08-14 04:08:02 +0000
committerSatoshi Asami <asami@FreeBSD.org>1995-08-14 04:08:02 +0000
commit4a6b440781fce7e5e00b01f8e3b0026aef5b3705 (patch)
treeec76581865429a55b97c41e17913a7edc69067f0 /editors/sam
parentae8f5d05912d85bd9859a2d59ee74204ba4a85d1 (diff)
downloadports-4a6b440781fce7e5e00b01f8e3b0026aef5b3705.tar.gz
ports-4a6b440781fce7e5e00b01f8e3b0026aef5b3705.zip
Various plan9 utilities. It's such a complete collection, I'm going
to import it all at once! Submitted by: Eric L. Hernes <erich@lodgenet.com>
Notes
Notes: svn path=/head/; revision=2055
Diffstat (limited to 'editors/sam')
-rw-r--r--editors/sam/Makefile20
-rw-r--r--editors/sam/distinfo1
-rw-r--r--editors/sam/files/patch-aa62
-rw-r--r--editors/sam/files/patch-ab46
-rw-r--r--editors/sam/files/patch-ac71
-rw-r--r--editors/sam/files/patch-ae23
-rw-r--r--editors/sam/files/patch-af41
-rw-r--r--editors/sam/pkg-comment1
-rw-r--r--editors/sam/pkg-descr17
-rw-r--r--editors/sam/pkg-plist19
10 files changed, 301 insertions, 0 deletions
diff --git a/editors/sam/Makefile b/editors/sam/Makefile
new file mode 100644
index 000000000000..64fadcff43a8
--- /dev/null
+++ b/editors/sam/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: sam
+# Version required: 4.3
+# Date created: Sun Aug 13 12:36:14 CDT 1995
+# Whom: erich@rrnet.com
+#
+# $Id$
+#
+
+DISTNAME= sam
+PKGNAME= sam-4.3
+CATEGORIES+= plan9
+MASTER_SITES= ftp://ftp.ecf.toronto.edu/pub/plan9/matty/
+EXTRACT_SUFX= .msg.gz
+
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= zcat
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= |sh
+
+.include <bsd.port.mk>
diff --git a/editors/sam/distinfo b/editors/sam/distinfo
new file mode 100644
index 000000000000..f5d6a51ab301
--- /dev/null
+++ b/editors/sam/distinfo
@@ -0,0 +1 @@
+MD5 (sam.msg.gz) = c7e1e2f262ae7a9d08c7b7553d80595a
diff --git a/editors/sam/files/patch-aa b/editors/sam/files/patch-aa
new file mode 100644
index 000000000000..6b5c32ede1dc
--- /dev/null
+++ b/editors/sam/files/patch-aa
@@ -0,0 +1,62 @@
+*** libXg/Makefile.orig Fri Jul 28 14:02:17 1995
+--- libXg/Makefile Fri Jul 21 15:03:43 1995
+***************
+*** 1,24 ****
+ # Copyright (c) 1992 AT&T - All rights reserved.
+ #
+! # Prototype Makefile for libXg
+ #
+- # define operating system. ONE of:
+- # -DIRIX -DSUNOS -DUMIPS -DSYSVR3 -DAIX -DOSF1
+- # -DHPUX -DAPOLLO -DCONVEX -DDYNIX
+- #
+ # Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
+ # if your compiler supports posix-compatible compilation
+! OS=-DIRIX -ansiposix
+
+ # add -Iincludedir for any include directories that need to be searched
+! INCS=-I../include
+
+ # set this if your X libraries are in different locations
+ # or if you need extra libraries to load with X11 applications
+! XLIBS=/usr/local/X11R5/lib/libXt.a /usr/local/X11R5/lib/libX11.a
+
+ # add name of library orderer - use ":" if none
+! RANLIB=:
+
+ # add name of librarian
+ AR=ar
+--- 1,23 ----
+ # Copyright (c) 1992 AT&T - All rights reserved.
+ #
+! # Prototype BSDi Makefile for libXg
+! # Courtesy of Boyd Roberts
+! #
+! # Define operating system type: -DBSDi
+ #
+ # Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
+ # if your compiler supports posix-compatible compilation
+! OS=-O2 -DBSDi
+
+ # add -Iincludedir for any include directories that need to be searched
+! INCS=-I../include -I/usr/X11R6/include
+
+ # set this if your X libraries are in different locations
+ # or if you need extra libraries to load with X11 applications
+! XLIBS=/usr/X11/lib/libXt.a /usr/X11/lib/libX11.a
+
+ # add name of library orderer - use ":" if none
+! RANLIB=ranlib
+
+ # add name of librarian
+ AR=ar
+***************
+*** 50,56 ****
+ $(LIB): $(OBJS)
+ $(AR) rv $(LIB) $(OBJS)
+ $(RANLIB) $(LIB)
+-
+- $(LIB)(%.o): %.o
+
+ $(OBJS): ../include/libg.h libgint.h ../include/libc.h
+--- 49,53 ----
diff --git a/editors/sam/files/patch-ab b/editors/sam/files/patch-ab
new file mode 100644
index 000000000000..3ff1dcdce98c
--- /dev/null
+++ b/editors/sam/files/patch-ab
@@ -0,0 +1,46 @@
+*** libframe/Makefile.orig Fri Jul 28 14:08:32 1995
+--- libframe/Makefile Fri Jul 21 15:02:32 1995
+***************
+*** 1,21 ****
+ # Copyright (c) 1992 AT&T - All rights reserved.
+ #
+! # Prototype Makefile for libframe
+ #
+- # define operating system. ONE of:
+- # -DIRIX -DSUNOS -DUMIPS -DSYSVR3 -DAIX -DOSF1
+- # -DHPUX -DAPOLLO -DCONVEX -DDYNIX
+- #
+ # Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
+ # if your compiler supports posix-compatible compilation
+! OS=-DIRIX -ansiposix
+
+ # add -Iincludedir for any include directories that need to be searched
+ # for posix header files (for UMIPS, add -I/usr/include/posix)
+! INCS=-I../include
+
+ # add name of library orderer - use ":" if none exists
+! RANLIB=:
+
+ # add name of library
+ AR=ar
+--- 1,20 ----
+ # Copyright (c) 1992 AT&T - All rights reserved.
+ #
+! # Prototype BSDi Makefile for libframe
+! # Courtesy of Boyd Roberts
+! #
+! # Define operating system type: -DBSDi
+ #
+ # Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
+ # if your compiler supports posix-compatible compilation
+! OS=-DBSDi -O2
+
+ # add -Iincludedir for any include directories that need to be searched
+ # for posix header files (for UMIPS, add -I/usr/include/posix)
+! INCS=-I../include -I/usr/include/posix
+
+ # add name of library orderer - use ":" if none exists
+! RANLIB=ranlib
+
+ # add name of library
+ AR=ar
diff --git a/editors/sam/files/patch-ac b/editors/sam/files/patch-ac
new file mode 100644
index 000000000000..00db47f4ac62
--- /dev/null
+++ b/editors/sam/files/patch-ac
@@ -0,0 +1,71 @@
+*** samterm/Makefile.orig Fri Jul 28 14:09:32 1995
+--- samterm/Makefile Fri Jul 21 15:30:09 1995
+***************
+*** 1,31 ****
+ # Copyright (c) 1992 AT&T - All rights reserved.
+ #
+! # Prototype Makefile for samterm
+ #
+- # define operating system. ONE of:
+- # -DIRIX -DSUNOS -DUMIPS -DSYSVR3 -DAIX -DOSF1
+- # -DHPUX -DAPOLLO -DCONVEX -DDYNIX
+- #
+ # Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
+ # if your compiler supports posix-compatible compilation
+! OS=-DIRIX -ansiposix
+
+ # add -Iincludedir for any include directories that need to be searched
+ # for posix header files (for UMIPS, add -I/usr/include/posix)
+! INCS=-I../include
+
+ # SAMTERM contains the name of the file containing the samterm
+ # executable. SAMTERMDIR is the directory where it is installed.
+ SAMTERM=samterm
+! SAMTERMDIR=/v/bin
+
+ # set this if your X libraries are in different locations
+ # or if you need extra libraries to load with X11 applications
+! XLIBS=/usr/local/X11R5/lib/libXt.a /usr/local/X11R5/lib/libX11.a
+
+ CFLAGS=$(OS) $(INCS) -D_LIBXG_EXTENSION
+
+! LIBS=../libframe/libframe.a ../libXg/libXg.a
+ CC=cc
+
+ OBJ=main.o flayer.o icons.o io.o menu.o mesg.o rasp.o scroll.o unix.o
+--- 1,35 ----
+ # Copyright (c) 1992 AT&T - All rights reserved.
+ #
+! # Prototype BSDi Makefile for samterm
+! # Courtesy of Boyd Roberts
+! #
+! # Define operating system type: -DBSDi
+ #
+ # Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
+ # if your compiler supports posix-compatible compilation
+! OS=-DBSDi -O2
+
+ # add -Iincludedir for any include directories that need to be searched
+ # for posix header files (for UMIPS, add -I/usr/include/posix)
+! INCS=-I../include -I/usr/include/posix
+
+ # SAMTERM contains the name of the file containing the samterm
+ # executable. SAMTERMDIR is the directory where it is installed.
+ SAMTERM=samterm
+! SAMTERMDIR=$(PREFIX)/bin
+
+ # set this if your X libraries are in different locations
+ # or if you need extra libraries to load with X11 applications
+! #XLIBS= /usr/X11R6/lib/libXt.a \
+! # /usr/X11R6/lib/libSM.a \
+! # /usr/X11R6/lib/libICE.a \
+! # /usr/X11R6/lib/libX11.a
+!
+! XLIBS=-L/usr/X11R6/lib -lXt -lSM -lICE -lX11
+
+ CFLAGS=$(OS) $(INCS) -D_LIBXG_EXTENSION
+
+! LIBS=../libframe/libframe.a ../libXg/libXg.a
+ CC=cc
+
+ OBJ=main.o flayer.o icons.o io.o menu.o mesg.o rasp.o scroll.o unix.o
diff --git a/editors/sam/files/patch-ae b/editors/sam/files/patch-ae
new file mode 100644
index 000000000000..95c677a84255
--- /dev/null
+++ b/editors/sam/files/patch-ae
@@ -0,0 +1,23 @@
+*** include/u.h~ Fri Jul 21 15:01:18 1995
+--- include/u.h Fri Jul 21 16:47:00 1995
+***************
+*** 46,53 ****
+ #define NOFIFO /* turn off exstart in samterm/unix.c */
+ #endif /* UMIPS */
+
+! #ifdef SUNOS
+ typedef unsigned short ushort;
+ typedef unsigned long ulong;
+ extern char *strerror(int);
+ extern void *memmove(void*, const void*, size_t);
+--- 46,55 ----
+ #define NOFIFO /* turn off exstart in samterm/unix.c */
+ #endif /* UMIPS */
+
+! #if defined(SUNOS)
+! #ifndef __FreeBSD__
+ typedef unsigned short ushort;
++ #endif
+ typedef unsigned long ulong;
+ extern char *strerror(int);
+ extern void *memmove(void*, const void*, size_t);
diff --git a/editors/sam/files/patch-af b/editors/sam/files/patch-af
new file mode 100644
index 000000000000..ba87ef18a544
--- /dev/null
+++ b/editors/sam/files/patch-af
@@ -0,0 +1,41 @@
+*** Makefile.orig Fri Aug 11 15:55:41 1995
+--- Makefile Fri Aug 11 16:08:35 1995
+***************
+*** 3,8 ****
+--- 3,17 ----
+ # master makefile for sam. configure sub-makefiles first.
+ #
+
++
++ MAN=man
++ MAN1=sam
++ MAN3=add balloc bitblt cachechars event frame graphics rgbpix rune
++ MAN4=font keyboard utf
++ MAN6=bitmap regexp
++ APP_DEFAULT_DIR=/usr/X11R6/lib/X11/app-defaults
++ AD=Sam
++
+ all: lXg lframe samdir samtermdir
+
+ lXg:
+***************
+*** 21,26 ****
+--- 30,47 ----
+ cd libframe; $(MAKE) install
+ cd sam; $(MAKE) install
+ cd samterm; $(MAKE) install
++ pwd
++ for i in $(MAN1); do cp doc/$$i.1 $(PREFIX)/$(MAN)/man1/$$i.1; done
++ for i in $(MAN3); do cp doc/$$i.3 $(PREFIX)/$(MAN)/man3/$$i.3; done
++ for i in $(MAN4); do cp doc/$$i.4 $(PREFIX)/$(MAN)/man4/$$i.4; done
++ for i in $(MAN6); do cp doc/$$i.6 $(PREFIX)/$(MAN)/man6/$$i.6; done
++ cp doc/$(AD).ad $(APP_DEFAULT_DIR)/$(AD)
++ strip $(PREFIX)/bin/sam
++ strip $(PREFIX)/bin/samterm
++ for i in $(MAN1); do gzip -9nf $(PREFIX)/$(MAN)/man1/$$i.1; done
++ for i in $(MAN3); do gzip -9nf $(PREFIX)/$(MAN)/man3/$$i.3; done
++ for i in $(MAN4); do gzip -9nf $(PREFIX)/$(MAN)/man4/$$i.4; done
++ for i in $(MAN6); do gzip -9nf $(PREFIX)/$(MAN)/man6/$$i.6; done
+
+ clean:
+ cd libXg; $(MAKE) clean
diff --git a/editors/sam/pkg-comment b/editors/sam/pkg-comment
new file mode 100644
index 000000000000..aa2a297313cc
--- /dev/null
+++ b/editors/sam/pkg-comment
@@ -0,0 +1 @@
+The sam editor 4.3 -- Rob Pike's editor for plan9
diff --git a/editors/sam/pkg-descr b/editors/sam/pkg-descr
new file mode 100644
index 000000000000..2eab5d1faeaa
--- /dev/null
+++ b/editors/sam/pkg-descr
@@ -0,0 +1,17 @@
+This is an X11 version of Rob Pike's editor, sam. Documentation describing
+its use and construction are provided in subdirectory doc. The file doc/sam.1
+contains the manual page; doc/sam.tut.ms is a tutorial that can be
+formatted with troff -ms. It substitutes Bold and Italics for the
+fonts named CW and CS; if your system has these fonts, remove the
+CW and CS macros at the beginning of the file. The files doc/sam.ps
+and doc/se.ps are postscript versions of published papers describing
+sam and structural regular expressions. These papers reflect sam's
+capabilities at the time of publication several years ago; while the
+general description remains accurate, some functions may have changed
+or been removed. Other files in the doc directory contain manual pages
+for the library packages used by sam.
+
+Sam is composed of two programs: sam itself, which does the command processing
+and file manipulation; and samterm, which controls the display and
+interacts with the user. You can run sam on one machine and samterm on another
+connected via remote execution.
diff --git a/editors/sam/pkg-plist b/editors/sam/pkg-plist
new file mode 100644
index 000000000000..4ca58d2dc24d
--- /dev/null
+++ b/editors/sam/pkg-plist
@@ -0,0 +1,19 @@
+bin/sam
+bin/samterm
+bin/samsave
+bin/B
+man/man3/add.3.gz
+man/man3/balloc.3.gz
+man/man3/bitblt.3.gz
+man/man6/bitmap.6.gz
+man/man3/cachechars.3.gz
+man/man3/event.3.gz
+man/man4/font.4.gz
+man/man3/frame.3.gz
+man/man3/graphics.3.gz
+man/man4/keyboard.4.gz
+man/man6/regexp.6.gz
+man/man3/rgbpix.3.gz
+man/man3/rune.3.gz
+man/man1/sam.1.gz
+man/man4/utf.4.gz