aboutsummaryrefslogtreecommitdiff
path: root/editors/sam
diff options
context:
space:
mode:
authorFlorian Limberger <flo@purplekraken.com>2023-03-04 12:12:01 +0000
committerGleb Popov <arrowd@FreeBSD.org>2023-03-04 12:30:24 +0000
commit86b0628113b8be216de61b5b9c45c5ecaab03301 (patch)
treeabe7e0f2ce84b5a492e1439f05f76af64cb66184 /editors/sam
parent4a7a56c297de8b636a96d409f92b7ee8b33c703a (diff)
downloadports-86b0628113b8be216de61b5b9c45c5ecaab03301.tar.gz
ports-86b0628113b8be216de61b5b9c45c5ecaab03301.zip
editors/sam: + Unix port of the sam text editor from Bell Labs.
Reviewed by: arrowd, diizzy Differential Revision: https://reviews.freebsd.org/D38785
Diffstat (limited to 'editors/sam')
-rw-r--r--editors/sam/Makefile43
-rw-r--r--editors/sam/distinfo3
-rw-r--r--editors/sam/pkg-descr5
-rw-r--r--editors/sam/pkg-plist10
4 files changed, 61 insertions, 0 deletions
diff --git a/editors/sam/Makefile b/editors/sam/Makefile
new file mode 100644
index 000000000000..b64a2901d2d7
--- /dev/null
+++ b/editors/sam/Makefile
@@ -0,0 +1,43 @@
+PORTNAME= sam
+DISTVERSION= g20230103
+CATEGORIES= editors
+
+MAINTAINER= flo@purplekraken.com
+COMMENT= Unix port of the Sam text editor from Plan 9
+WWW= https://github.com/deadpixi/sam
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libfreetype.so:print/freetype2
+
+USES= localbase:ldflags xorg
+
+USE_GITHUB= yes
+GH_ACCOUNT= deadpixi
+GH_PROJECT= sam
+GH_TAGNAME= 5d8acb3
+
+USE_XORG= x11 xft xi xt
+
+# Some random build system fixes
+MAKE_JOBS_UNSAFE=yes
+CFLAGS+= -I${LOCALBASE}/include/freetype2
+
+do-configure:
+ ${SED} -e 's/LDFLAGS=/LDFLAGS?=/' -e 's/CC=/CC?=/' \
+ ${WRKSRC}/config.mk.def >${WRKSRC}/config.mk
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sam/sam ${STAGEDIR}${PREFIX}/bin
+ ${RLN} ${STAGEDIR}${PREFIX}/bin/sam ${STAGEDIR}${PREFIX}/bin/B
+ ${INSTALL_PROGRAM} ${WRKSRC}/samterm/samterm ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/ssam/ssam.sh ${STAGEDIR}${PREFIX}/bin/ssam
+ ${INSTALL_MAN} ${WRKSRC}/doc/sam.1 ${STAGEDIR}${PREFIX}/share/man/man1
+ ${RLN} ${STAGEDIR}${PREFIX}/share/man/man1/sam.1 ${STAGEDIR}${PREFIX}/share/man/man1/B.1
+ ${RLN} ${STAGEDIR}${PREFIX}/share/man/man1/sam.1 ${STAGEDIR}${PREFIX}/share/man/man1/samterm.1
+ ${RLN} ${STAGEDIR}${PREFIX}/share/man/man1/sam.1 ${STAGEDIR}${PREFIX}/share/man/man1/rsam.1
+ ${RLN} ${STAGEDIR}${PREFIX}/share/man/man1/sam.1 ${STAGEDIR}${PREFIX}/share/man/man1/sam.save.1
+ ${INSTALL_MAN} ${WRKSRC}/doc/samrc.5 ${STAGEDIR}${PREFIX}/share/man/man5
+
+.include <bsd.port.mk>
diff --git a/editors/sam/distinfo b/editors/sam/distinfo
new file mode 100644
index 000000000000..8190cbc4056c
--- /dev/null
+++ b/editors/sam/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1672738941
+SHA256 (deadpixi-sam-g20230103-5d8acb3_GH0.tar.gz) = 70781f60d2cf7212b9d563cf22c819e68699d5d536bea66927a33009b556f5d1
+SIZE (deadpixi-sam-g20230103-5d8acb3_GH0.tar.gz) = 312329
diff --git a/editors/sam/pkg-descr b/editors/sam/pkg-descr
new file mode 100644
index 000000000000..2e81a02150ea
--- /dev/null
+++ b/editors/sam/pkg-descr
@@ -0,0 +1,5 @@
+Sam is a text editor originally written for the Blit graphical terminal
+connected to a machine running 9th Edition Research Unix. It contained many
+useful innovations, the most famous of which was its use of structural regular
+expressions. This version of sam is based on that 1990s Unix port, with many
+useful additions and modifications.
diff --git a/editors/sam/pkg-plist b/editors/sam/pkg-plist
new file mode 100644
index 000000000000..cec5bc79142c
--- /dev/null
+++ b/editors/sam/pkg-plist
@@ -0,0 +1,10 @@
+bin/B
+bin/sam
+bin/samterm
+bin/ssam
+share/man/man1/B.1.gz
+share/man/man1/rsam.1.gz
+share/man/man1/sam.1.gz
+share/man/man1/sam.save.1.gz
+share/man/man1/samterm.1.gz
+share/man/man5/samrc.5.gz