aboutsummaryrefslogtreecommitdiff
path: root/editors/sam
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-05-29 23:56:58 +0000
committerSteve Price <steve@FreeBSD.org>2000-05-29 23:56:58 +0000
commitb53c7742bae3c53fe817c069cd03155f8f3d61cc (patch)
treea54b4ef24d502131c7e000f469ff8f0b56aa2335 /editors/sam
parent1bdc5ad34514a9a2992b6ee79fc82f1737265bf1 (diff)
downloadports-b53c7742bae3c53fe817c069cd03155f8f3d61cc.tar.gz
ports-b53c7742bae3c53fe817c069cd03155f8f3d61cc.zip
- Fix MASTER_SITES
- Sort pkg/PLIST PR: 16669 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Notes
Notes: svn path=/head/; revision=28963
Diffstat (limited to 'editors/sam')
-rw-r--r--editors/sam/Makefile12
-rw-r--r--editors/sam/files/patch-aa52
-rw-r--r--editors/sam/files/patch-ab45
-rw-r--r--editors/sam/files/patch-ac65
-rw-r--r--editors/sam/files/patch-af14
-rw-r--r--editors/sam/files/patch-ag103
-rw-r--r--editors/sam/pkg-plist5
7 files changed, 201 insertions, 95 deletions
diff --git a/editors/sam/Makefile b/editors/sam/Makefile
index 43538c510ebc..5bb32f831cb5 100644
--- a/editors/sam/Makefile
+++ b/editors/sam/Makefile
@@ -8,23 +8,23 @@
PORTNAME= sam
PORTVERSION= 4.3
CATEGORIES= editors plan9
-MASTER_SITES= ftp://ftp.ecf.toronto.edu/pub/plan9/matty/
+MASTER_SITES= ftp://ftp.cs.usyd.edu.au/matty/unicode/
DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .msg.gz
MAINTAINER= ports@FreeBSD.org
-USE_XLIB= yes
+EXTRACT_CMD= ${GZCAT}
+EXTRACT_BEFORE_ARGS= # empty
+EXTRACT_AFTER_ARGS= | ${SH}
+
NO_WRKSUBDIR= yes
-EXTRACT_CMD= zcat
-EXTRACT_BEFORE_ARGS=
-EXTRACT_AFTER_ARGS= |sh
+USE_X_PREFIX= yes
MAN1= sam.1
MAN3= add.3 balloc.3 bitblt.3 cachechars.3 event.3 frame.3 \
graphics.3 rgbpix.3 rune.3
MAN4= font.4 keyboard.4 utf.4
MAN6= bitmap.6 regexp.6
-MANCOMPRESSED= yes
.include <bsd.port.mk>
diff --git a/editors/sam/files/patch-aa b/editors/sam/files/patch-aa
index 6b5c32ede1dc..63af3ca481bd 100644
--- a/editors/sam/files/patch-aa
+++ b/editors/sam/files/patch-aa
@@ -1,15 +1,8 @@
-*** libXg/Makefile.orig Fri Jul 28 14:02:17 1995
---- libXg/Makefile Fri Jul 21 15:03:43 1995
+*** libXg/Makefile.orig Fri Feb 11 11:04:17 2000
+--- libXg/Makefile Fri Feb 11 11:07:47 2000
***************
-*** 1,24 ****
- # Copyright (c) 1992 AT&T - All rights reserved.
- #
-! # Prototype Makefile for libXg
- #
-- # define operating system. ONE of:
-- # -DIRIX -DSUNOS -DUMIPS -DSYSVR3 -DAIX -DOSF1
-- # -DHPUX -DAPOLLO -DCONVEX -DDYNIX
-- #
+*** 8,24 ****
+ #
# Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
# if your compiler supports posix-compatible compilation
! OS=-DIRIX -ansiposix
@@ -26,24 +19,18 @@
# add name of librarian
AR=ar
---- 1,23 ----
- # Copyright (c) 1992 AT&T - All rights reserved.
- #
-! # Prototype BSDi Makefile for libXg
-! # Courtesy of Boyd Roberts
-! #
-! # Define operating system type: -DBSDi
- #
+--- 8,24 ----
+ #
# Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
# if your compiler supports posix-compatible compilation
-! OS=-O2 -DBSDi
+! OS=-DBSDi
# add -Iincludedir for any include directories that need to be searched
-! INCS=-I../include -I/usr/X11R6/include
+! INCS=-I../include -I${X11BASE}/include
# set this if your X libraries are in different locations
# or if you need extra libraries to load with X11 applications
-! XLIBS=/usr/X11/lib/libXt.a /usr/X11/lib/libX11.a
+! XLIBS=-lXt -lX11 -L${X11BASE}/lib
# add name of library orderer - use ":" if none
! RANLIB=ranlib
@@ -51,6 +38,25 @@
# add name of librarian
AR=ar
***************
+*** 26,33 ****
+ # the name of the library
+ LIB=libXg.a
+
+! CFLAGS=$(OS) -D_LIBXG_EXTENSION $(INCS)
+! CC=cc
+
+ OBJS= arc.o arith.o balloc.o bitblt.o bitbltclip.o border.o bscreenrect.o\
+ circle.o clipline.o clipr.o copymasked.o cursorset.o cursorswitch.o\
+--- 26,33 ----
+ # the name of the library
+ LIB=libXg.a
+
+! CFLAGS+=$(OS) -D_LIBXG_EXTENSION $(INCS)
+! CC?=cc
+
+ OBJS= arc.o arith.o balloc.o bitblt.o bitbltclip.o border.o bscreenrect.o\
+ circle.o clipline.o clipr.o copymasked.o cursorset.o cursorswitch.o\
+***************
*** 50,56 ****
$(LIB): $(OBJS)
$(AR) rv $(LIB) $(OBJS)
@@ -59,4 +65,4 @@
- $(LIB)(%.o): %.o
$(OBJS): ../include/libg.h libgint.h ../include/libc.h
---- 49,53 ----
+--- 50,54 ----
diff --git a/editors/sam/files/patch-ab b/editors/sam/files/patch-ab
index 3ff1dcdce98c..b17dc608431b 100644
--- a/editors/sam/files/patch-ab
+++ b/editors/sam/files/patch-ab
@@ -1,15 +1,8 @@
-*** libframe/Makefile.orig Fri Jul 28 14:08:32 1995
---- libframe/Makefile Fri Jul 21 15:02:32 1995
+*** libframe/Makefile.orig Fri Feb 11 11:04:17 2000
+--- libframe/Makefile Fri Feb 11 11:10:18 2000
***************
-*** 1,21 ****
- # Copyright (c) 1992 AT&T - All rights reserved.
- #
-! # Prototype Makefile for libframe
- #
-- # define operating system. ONE of:
-- # -DIRIX -DSUNOS -DUMIPS -DSYSVR3 -DAIX -DOSF1
-- # -DHPUX -DAPOLLO -DCONVEX -DDYNIX
-- #
+*** 8,29 ****
+ #
# Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
# if your compiler supports posix-compatible compilation
! OS=-DIRIX -ansiposix
@@ -23,24 +16,34 @@
# add name of library
AR=ar
---- 1,20 ----
- # Copyright (c) 1992 AT&T - All rights reserved.
- #
-! # Prototype BSDi Makefile for libframe
-! # Courtesy of Boyd Roberts
-! #
-! # Define operating system type: -DBSDi
- #
+
+! CFLAGS=-c $(OS) $(INCS) -D_LIBXG_EXTENSION
+
+ LIB=libframe.a
+! CC=cc
+
+ OBJ=frbox.o frdelete.o frdraw.o frinit.o frinsert.o frptofchar.o\
+ frselect.o frstr.o frutil.o misc.o
+--- 8,29 ----
+ #
# Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
# if your compiler supports posix-compatible compilation
-! OS=-DBSDi -O2
+! OS=-DBSDi
# add -Iincludedir for any include directories that need to be searched
# for posix header files (for UMIPS, add -I/usr/include/posix)
-! INCS=-I../include -I/usr/include/posix
+! INCS=-I../include -I${X11BASE}/include
# add name of library orderer - use ":" if none exists
! RANLIB=ranlib
# add name of library
AR=ar
+
+! CFLAGS+=-c $(OS) $(INCS) -D_LIBXG_EXTENSION
+
+ LIB=libframe.a
+! CC?=cc
+
+ OBJ=frbox.o frdelete.o frdraw.o frinit.o frinsert.o frptofchar.o\
+ frselect.o frstr.o frutil.o misc.o
diff --git a/editors/sam/files/patch-ac b/editors/sam/files/patch-ac
index 00db47f4ac62..dca9bc5c5134 100644
--- a/editors/sam/files/patch-ac
+++ b/editors/sam/files/patch-ac
@@ -1,15 +1,8 @@
-*** samterm/Makefile.orig Fri Jul 28 14:09:32 1995
---- samterm/Makefile Fri Jul 21 15:30:09 1995
+*** samterm/Makefile.orig Fri Feb 11 11:04:17 2000
+--- samterm/Makefile Fri Feb 11 11:12:52 2000
***************
-*** 1,31 ****
- # Copyright (c) 1992 AT&T - All rights reserved.
- #
-! # Prototype Makefile for samterm
- #
-- # define operating system. ONE of:
-- # -DIRIX -DSUNOS -DUMIPS -DSYSVR3 -DAIX -DOSF1
-- # -DHPUX -DAPOLLO -DCONVEX -DDYNIX
-- #
+*** 8,32 ****
+ #
# Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
# if your compiler supports posix-compatible compilation
! OS=-DIRIX -ansiposix
@@ -27,27 +20,22 @@
# or if you need extra libraries to load with X11 applications
! XLIBS=/usr/local/X11R5/lib/libXt.a /usr/local/X11R5/lib/libX11.a
- CFLAGS=$(OS) $(INCS) -D_LIBXG_EXTENSION
+! CFLAGS=$(OS) $(INCS) -D_LIBXG_EXTENSION
-! LIBS=../libframe/libframe.a ../libXg/libXg.a
- CC=cc
+ LIBS=../libframe/libframe.a ../libXg/libXg.a
+! CC=cc
OBJ=main.o flayer.o icons.o io.o menu.o mesg.o rasp.o scroll.o unix.o
---- 1,35 ----
- # Copyright (c) 1992 AT&T - All rights reserved.
- #
-! # Prototype BSDi Makefile for samterm
-! # Courtesy of Boyd Roberts
-! #
-! # Define operating system type: -DBSDi
- #
+
+--- 8,32 ----
+ #
# Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
# if your compiler supports posix-compatible compilation
-! OS=-DBSDi -O2
+! OS=-DBSDi
# add -Iincludedir for any include directories that need to be searched
# for posix header files (for UMIPS, add -I/usr/include/posix)
-! INCS=-I../include -I/usr/include/posix
+! INCS=-I../include -I${X11BASE}/include
# SAMTERM contains the name of the file containing the samterm
# executable. SAMTERMDIR is the directory where it is installed.
@@ -56,16 +44,27 @@
# set this if your X libraries are in different locations
# or if you need extra libraries to load with X11 applications
-! #XLIBS= /usr/X11R6/lib/libXt.a \
-! # /usr/X11R6/lib/libSM.a \
-! # /usr/X11R6/lib/libICE.a \
-! # /usr/X11R6/lib/libX11.a
-!
-! XLIBS=-L/usr/X11R6/lib -lXt -lSM -lICE -lX11
+! XLIBS=-lXt -lX11 -lSM -lICE -L${X11BASE}/lib
- CFLAGS=$(OS) $(INCS) -D_LIBXG_EXTENSION
+! CFLAGS+=$(OS) $(INCS) -D_LIBXG_EXTENSION
-! LIBS=../libframe/libframe.a ../libXg/libXg.a
- CC=cc
+ LIBS=../libframe/libframe.a ../libXg/libXg.a
+! CC?=cc
OBJ=main.o flayer.o icons.o io.o menu.o mesg.o rasp.o scroll.o unix.o
+
+***************
+*** 42,47 ****
+ rm -f samterm
+
+ install: samterm
+! cp samterm $(SAMTERMDIR)/$(SAMTERM)
+
+ $(OBJ): samterm.h flayer.h ../include/frame.h ../include/libg.h ../include/u.h ../include/libc.h ../sam/mesg.h
+--- 42,47 ----
+ rm -f samterm
+
+ install: samterm
+! ${BSD_INSTALL_PROGRAM} samterm $(SAMTERMDIR)/$(SAMTERM)
+
+ $(OBJ): samterm.h flayer.h ../include/frame.h ../include/libg.h ../include/u.h ../include/libc.h ../sam/mesg.h
diff --git a/editors/sam/files/patch-af b/editors/sam/files/patch-af
index ba87ef18a544..2049df8ffb49 100644
--- a/editors/sam/files/patch-af
+++ b/editors/sam/files/patch-af
@@ -1,5 +1,5 @@
-*** Makefile.orig Fri Aug 11 15:55:41 1995
---- Makefile Fri Aug 11 16:08:35 1995
+*** Makefile.orig Fri Feb 11 09:18:10 2000
+--- Makefile Fri Feb 11 09:21:52 2000
***************
*** 3,8 ****
--- 3,17 ----
@@ -12,7 +12,7 @@
+ MAN3=add balloc bitblt cachechars event frame graphics rgbpix rune
+ MAN4=font keyboard utf
+ MAN6=bitmap regexp
-+ APP_DEFAULT_DIR=/usr/X11R6/lib/X11/app-defaults
++ APP_DEFAULT_DIR=$(PREFIX)/lib/X11/app-defaults
+ AD=Sam
+
all: lXg lframe samdir samtermdir
@@ -20,7 +20,7 @@
lXg:
***************
*** 21,26 ****
---- 30,47 ----
+--- 30,41 ----
cd libframe; $(MAKE) install
cd sam; $(MAKE) install
cd samterm; $(MAKE) install
@@ -30,12 +30,6 @@
+ for i in $(MAN4); do cp doc/$$i.4 $(PREFIX)/$(MAN)/man4/$$i.4; done
+ for i in $(MAN6); do cp doc/$$i.6 $(PREFIX)/$(MAN)/man6/$$i.6; done
+ cp doc/$(AD).ad $(APP_DEFAULT_DIR)/$(AD)
-+ strip $(PREFIX)/bin/sam
-+ strip $(PREFIX)/bin/samterm
-+ for i in $(MAN1); do gzip -9nf $(PREFIX)/$(MAN)/man1/$$i.1; done
-+ for i in $(MAN3); do gzip -9nf $(PREFIX)/$(MAN)/man3/$$i.3; done
-+ for i in $(MAN4); do gzip -9nf $(PREFIX)/$(MAN)/man4/$$i.4; done
-+ for i in $(MAN6); do gzip -9nf $(PREFIX)/$(MAN)/man6/$$i.6; done
clean:
cd libXg; $(MAKE) clean
diff --git a/editors/sam/files/patch-ag b/editors/sam/files/patch-ag
new file mode 100644
index 000000000000..da7977f6ca04
--- /dev/null
+++ b/editors/sam/files/patch-ag
@@ -0,0 +1,103 @@
+*** sam/Makefile.orig Fri Feb 11 11:16:53 2000
+--- sam/Makefile Fri Feb 11 11:25:38 2000
+***************
+*** 8,14 ****
+ #
+ # Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
+ # if your compiler supports posix-compatible compilation
+! OS=-DIRIX -ansiposix
+
+ # add -Iincludedir for any include directories that need to be searched
+ # for posix header files (for UMIPS, add -I/usr/include/posix)
+--- 8,14 ----
+ #
+ # Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
+ # if your compiler supports posix-compatible compilation
+! OS=-DBSDi
+
+ # add -Iincludedir for any include directories that need to be searched
+ # for posix header files (for UMIPS, add -I/usr/include/posix)
+***************
+*** 22,30 ****
+ # where sam is to be installed. SAMSAVEDIR is the name of the directory
+ # where the samsave file restoration script is stored.
+ RSAMNAME=sam
+! TERMNAME=/v/bin/samterm
+! SAMDIR=/usr/bin
+! SAMSAVEDIR=/v/bin
+
+ # Set TMP to a good place for tmp files (with lots of room)
+ TMP=/usr/tmp
+--- 22,30 ----
+ # where sam is to be installed. SAMSAVEDIR is the name of the directory
+ # where the samsave file restoration script is stored.
+ RSAMNAME=sam
+! TERMNAME=$(PREFIX)/bin/samterm
+! SAMDIR=$(PREFIX)/bin
+! SAMSAVEDIR=$(PREFIX)/bin
+
+ # Set TMP to a good place for tmp files (with lots of room)
+ TMP=/usr/tmp
+***************
+*** 37,47 ****
+ # Set RXNAME and RXPATHNAME to the name of the remote execution command
+ # and the pathname of its executable
+ RXNAME=rsh
+! RXPATHNAME=/usr/bsd/rsh
+
+ SAMSAVE=/bin/sh\\n$(SAMSAVEDIR)/samsave
+
+! CFLAGS=$(OS) -D_LIBXG_EXTENSION $(INCS)
+
+ SYSFLAGS= -DHOMEDIR=\"$(HOMEDIR)\" -DRSAMNAME=\"$(RSAMNAME)\" \
+ -DTERMNAME=\"$(TERMNAME)\" -DTMP=\"$(TMP)\" \
+--- 37,47 ----
+ # Set RXNAME and RXPATHNAME to the name of the remote execution command
+ # and the pathname of its executable
+ RXNAME=rsh
+! RXPATHNAME=/usr/bin/rsh
+
+ SAMSAVE=/bin/sh\\n$(SAMSAVEDIR)/samsave
+
+! CFLAGS+=$(OS) -D_LIBXG_EXTENSION $(INCS)
+
+ SYSFLAGS= -DHOMEDIR=\"$(HOMEDIR)\" -DRSAMNAME=\"$(RSAMNAME)\" \
+ -DTERMNAME=\"$(TERMNAME)\" -DTMP=\"$(TMP)\" \
+***************
+*** 50,56 ****
+ -DSAMSAVE=\"$(SAMSAVE)\"
+
+ LIB=../libframe/libframe.a ../libXg/libXg.a
+! CC=cc
+
+ OBJ=sam.o address.o buffer.o cmd.o disc.o error.o file.o io.o \
+ list.o mesg.o moveto.o multi.o rasp.o regexp.o shell.o \
+--- 50,56 ----
+ -DSAMSAVE=\"$(SAMSAVE)\"
+
+ LIB=../libframe/libframe.a ../libXg/libXg.a
+! CC?=cc
+
+ OBJ=sam.o address.o buffer.o cmd.o disc.o error.o file.o io.o \
+ list.o mesg.o moveto.o multi.o rasp.o regexp.o shell.o \
+***************
+*** 68,76 ****
+ rm -f sam
+
+ install: sam
+! cp sam $(SAMDIR)/$(RSAMNAME)
+! cp samsave $(SAMSAVEDIR)/samsave
+! chmod +x samsave
+
+ $(OBJ): sam.h ../include/u.h ../include/libc.h errors.h mesg.h
+
+--- 68,76 ----
+ rm -f sam
+
+ install: sam
+! ${BSD_INSTALL_PROGRAM} sam $(SAMDIR)/$(RSAMNAME)
+! ${BSD_INSTALL_SCRIPT} samsave $(SAMSAVEDIR)/samsave
+! ${BSD_INSTALL_SCRIPT} B.sh $(SAMSAVEDIR)/B
+
+ $(OBJ): sam.h ../include/u.h ../include/libc.h errors.h mesg.h
+
diff --git a/editors/sam/pkg-plist b/editors/sam/pkg-plist
index 1addd9ae1f93..64a46e127704 100644
--- a/editors/sam/pkg-plist
+++ b/editors/sam/pkg-plist
@@ -1,4 +1,5 @@
+bin/B
bin/sam
-bin/samterm
bin/samsave
-bin/B
+bin/samterm
+lib/X11/app-defaults/Sam