aboutsummaryrefslogtreecommitdiff
path: root/editors/scite
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-01-27 23:57:42 +0000
committerSteve Wills <swills@FreeBSD.org>2019-01-27 23:57:42 +0000
commit310a03182f157a3076f6b4e9df897b48f743d1e1 (patch)
treea6198804787c0c6fd3b223cb6a5e0f39eb8b6134 /editors/scite
parent944b17837236d3c119cd8ff15e4b12ed41d64a61 (diff)
downloadports-310a03182f157a3076f6b4e9df897b48f743d1e1.tar.gz
ports-310a03182f157a3076f6b4e9df897b48f743d1e1.zip
editors/scite: update to 4.1.0
PR: 228909 Submitted by: Naram Qashat <cyberbotx@cyberbotx.com> (maintainer)
Notes
Notes: svn path=/head/; revision=491445
Diffstat (limited to 'editors/scite')
-rw-r--r--editors/scite/Makefile8
-rw-r--r--editors/scite/distinfo6
-rw-r--r--editors/scite/files/patch-gtk_makefile (renamed from editors/scite/files/patch-makefile)34
-rw-r--r--editors/scite/files/patch-src_EditorConfig.cxx10
4 files changed, 32 insertions, 26 deletions
diff --git a/editors/scite/Makefile b/editors/scite/Makefile
index c54fc35989d5..f069874d8bf7 100644
--- a/editors/scite/Makefile
+++ b/editors/scite/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= scite
-DISTVERSION= 4.0.2
-PORTREVISION= 1
+DISTVERSION= 4.1.0
CATEGORIES= editors gnome
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
@@ -19,11 +18,14 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libscintilla.so:x11-toolkits/scintilla
RUN_DEPENDS= xdg-open:devel/xdg-utils
+USES= compiler:c++17-lang desktop-file-utils gmake pkgconfig tar:tgz
+
OPTIONS_DEFINE= DOCS
+PATCH_WRKSRC= ${WRKDIR}/${PORTNAME}
WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
-USES= compiler:c++14-lang desktop-file-utils gmake pkgconfig tar:tgz
+CXXSTD= c++17
USE_GNOME= cairo gdkpixbuf2 gtk20
MAKEFILE= makefile
diff --git a/editors/scite/distinfo b/editors/scite/distinfo
index 90bd2149ffa8..c747e4a9ae29 100644
--- a/editors/scite/distinfo
+++ b/editors/scite/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1516108933
-SHA256 (scite402.tgz) = 1f9bb8eccbaed77c110c30c0e6dbaac04b3f62b751a930192b133a7b6f0f29fb
-SIZE (scite402.tgz) = 2424648
+TIMESTAMP = 1529613535
+SHA256 (scite410.tgz) = d1f9cf27b8d44b3d6bab179173a58cdfe76b44f84c8e74aeb85bf16c50148cf7
+SIZE (scite410.tgz) = 2493701
diff --git a/editors/scite/files/patch-makefile b/editors/scite/files/patch-gtk_makefile
index 2e3191b90031..818cf6bae999 100644
--- a/editors/scite/files/patch-makefile
+++ b/editors/scite/files/patch-gtk_makefile
@@ -1,23 +1,17 @@
---- makefile.orig 2016-08-30 04:39:12 UTC
-+++ makefile
-@@ -7,16 +7,6 @@
- srcdir ?= .
-
- .SUFFIXES: .cxx .o .h .a .c
--ifdef CLANG
--# Can choose aspect to sanitize: address and undefined can simply change SANITIZE but for
--# thread also need to create Position Independent Executable -> search online documentation
--SANITIZE = address
--#SANITIZE = undefined
+--- gtk/makefile.orig 2018-05-06 22:32:10 UTC
++++ gtk/makefile
+@@ -12,8 +12,8 @@ ifdef CLANG
+ # thread also need to create Position Independent Executable -> search online documentation
+ SANITIZE = address
+ #SANITIZE = undefined
-CXX = clang++ -fsanitize=$(SANITIZE) -Wno-deprecated-register
-CC = clang -fsanitize=$(SANITIZE) -Wno-empty-body
--else
--MISLEADING=-Wno-misleading-indentation
--endif
-
- ifdef GTK3
- GTKVERSION=gtk+-3.0
-@@ -28,7 +18,7 @@ endif
++CXX = $(CXX) -fsanitize=$(SANITIZE) -Wno-deprecated-register
++CC = $(CC) -fsanitize=$(SANITIZE) -Wno-empty-body
+ else
+ MISLEADING=-Wno-misleading-indentation
+ endif
+@@ -28,7 +28,7 @@ endif
CONFIGFLAGS:=$(shell pkg-config --cflags $(GTKVERSION))
CONFIGLIB:=$(shell pkg-config --libs $(GTKVERSION) gthread-2.0 gmodule-no-export-2.0)
CONFIGTHREADS:=
@@ -26,12 +20,12 @@
ifndef prefix
ifdef gnomeprefix
prefix=$(gnomeprefix)
-@@ -119,8 +109,9 @@ FilePath.o SciTEBase.o FileWorker.o Cook
+@@ -122,8 +122,9 @@ FilePath.o EditorConfig.o SciTEBase.o Fi
ExportHTML.o ExportPDF.o ExportRTF.o ExportTEX.o ExportXML.o \
MatchMarker.o StringHelpers.o \
PropSetFile.o MultiplexExtension.o DirectorExtension.o SciTEProps.o StyleDefinition.o StyleWriter.o Utf8_16.o \
- JobQueue.o GTKMutex.o IFaceTable.o $(COMPLIB) $(LUA_OBJS)
-- $(CXX) `$(CONFIGTHREADS)` -rdynamic -Wl,--as-needed -Wl,--version-script $(srcdir)/lua.vers -DGTK $^ -o $@ $(CONFIGLIB) $(LIBDL) -lm -lstdc++
+- $(CXX) `$(CONFIGTHREADS)` -rdynamic -Wl,--as-needed -Wl,--version-script $(srcdir)/lua.vers -DGTK $^ -o $@ $(CONFIGLIB) $(LIBDL) $(LDLIBS) -lm -lstdc++
+ JobQueue.o GTKMutex.o IFaceTable.o $(LUA_OBJS)
+ $(CXX) -rdynamic -Wl,--version-script $(srcdir)/lua.vers -DGTK $(CXXFLAGS) $^ -o $@ \
+ $(LDFLAGS) -lscintilla -lscintilla_lexers -Wl,--as-needed $(CONFIGLIB)
diff --git a/editors/scite/files/patch-src_EditorConfig.cxx b/editors/scite/files/patch-src_EditorConfig.cxx
new file mode 100644
index 000000000000..c15d279777fa
--- /dev/null
+++ b/editors/scite/files/patch-src_EditorConfig.cxx
@@ -0,0 +1,10 @@
+--- src/EditorConfig.cxx.orig 2018-05-06 22:32:10 UTC
++++ src/EditorConfig.cxx
+@@ -13,6 +13,7 @@
+ #include <map>
+ #include <algorithm>
+ #include <memory>
++#include <sys/time.h>
+
+ #include "Scintilla.h"
+